FIaShJeSter Flashjester FAQ. @

the ultimate place for flashing tools

1. What is the minimum | need to fill in to be able to build my screen saver?

To make full use of the program, we suggest you fill in all the fields. However, if it is a quick start you
are after, you will need to fill in the following fields:

Company Name
Long Name

Short Name

Flash Projector File
Setup Box Graphic
Build Path

Filling in any less than this will cause your screen saver not to be built.

2. What tools does Creator include?

The tools included can perform many tasks. As well as creating a screen saver from your projector files,
Creator can make a totally customisable setup box. Once your screen saver has then been made, you can
package it up using Creator's built-in install maker.

3. What is Creator?

Creator takes your projector files made in Macromedia Flash and turns them into screen savers.
However, unlike many other screen saver creation programs, there is no need to leave the program.
Creator includes all the tools you need to create, package up and distribute in one program.

4. | have a bitmap at the start of my screen saver. When the screen saver loads up, the animation
for this bitmap is slow. Is there anything | can do about this?

The screen saver takes a little time to load the whole projector file at the start. To combat this, you will
either need to put in some empty frames at the beginning or use as little vectors/graphics at the start as
possible. It should only take a few seconds to load but it is best to leave a short delay before the
animation starts.

5. When | put the web, e-mail and other labels on my setup box they don't show up. Why?

Ok. This simple mistake has been made by a few people and is VERY simple to get around. What has
happened is you have put the labels on the transparency colour, not the bitmap. The bitmap is the only
part that will show when the screen saver is built, so al labels will need to be placed over this. When
designing your setup box bitmap, it isagood ideato leave room for your labels.

6. In my screen saver, it loads separate SWFs onto the different layers. This all works fine apart
from the SWF at the start. This does not load up. Why is this and how can | combat it?

Thisis quite ssmple. What is happening is that for the first and maybe second frame of the projector file,
Creator is extracting all the files used in the screen saver. So when you call for the SWF, it has not been
unpacked yet. You can solve this simply by loading the SWF on the second or third frame.

7. What if | don't pick an icon?
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The default Creator icon will be used.

8. Can | use any bitmap for the setup box?

Y es. Creator supports bitmaps of up to 256 colours but if you have a 16 million colour bitmap you wish
to use, Creator will optimiseit in 256 colours.

9. How customisable is the setup box?

Using a graphic, the setup box will form itself round the picture making a totally unique shape to each
bitmap used. Once the shape has been defined, you can select from a list of components to put in the
setup box including aweb link, e-mail link, sound mute control, interaction control and midi file sound
control.

10. What if I want to use my own install maker?

When Creator builds the screen saver it creates two folders, install and screen saver. Install contains the
install file with the screen saver inside. The screen saver folder contains just the screen saver. You can
use your own install maker here.

11. What about the install maker?

Creator can package your screen saver up before you leave the program. You can edit al the dialogue
boxes that appear as well as the background of the installer. You can display a bitmap or gradient
background, you can change the main bitmap in the dialogue boxes, you can include and exclude
dialogue boxes and do many more things.

12. Will my screensavers run on Win ME/2000/XP ?

Only if you have version v.1.2. If you don't then you will need to upgrade to the latest version. The best
thing about thisisthat the upgrade is FREE.

13. Is it possible to build screen savers for use on the MAC OS platform?

No, sorry. It's a completely different ball game. We don't have the skill or resources to port to the Mac,
well not at the moment, anyway. We suggest you use ScreenTime for the Mac and ours for the PC
version. Spot the difference !!

14. What's the minimum spec | need to run Creator ?

A minimum spec for Creator is any Pentium machine, 16MB RAM, 3MB Drive space,
WIN/95/98/NT/ME/2000/X P

15. I am trying to use JWeb to add a link to a URL from within a screensaver file | built with Creator.

I am using FlashMX, and when | go through Creator and build the install file, then install it and click
the link, | get this message:
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Error no URL defined

First you must use JStart and not JWeb in order to launch web pages, due to the security in NT. We have
written code to overcome this problem in JStart.

To create the command to paste into the FLA you MUST use Jugglor and the JTools section in there.
JHelpor will not work.

Detailed instructions.

1. In order to create a projector with a link to a live URL, that can be converted to a screensaver, you
need the following: Flash, Creator, Jstart, Jugglor

2. With Flash, you create your FLA file. In your FLA file, you will need a button, to launch the URL.

3. You'll need to create some code with Jugglor, to paste into your button Action window. If you open
Jugglor (you can download a 30 day free trial) and launch the program, go to the JTools section.

4. From the JTools section, click on Jstart, and enter in your URL and error message. If you are using
FlashM X, make sure the FlashM X checkbox is selected and then click the Copy button.

5. Go back to your flash file, and select your button. In the Actions window, select fscommand, then put
Exec in the first field, and paste in what you just copied, into the second field (this is assuming you are
using Normal Mode for your Actions window).

6. Save your FLA file. Publish your FLA file as a Windows Projector.

7. Quit Flash and Jugglor. Launch Creator. Follow the directions for importing your EXE (projector)
file. When you get to the screen to add additiona files, you'll need to manually add a JSTART .exefile -
thisisincluded in the C:\Program Files\FlashJester\JT ool s\Source\ folder on your Cdrive.

8. Proceed through the Creator screens and Build your screensaver That should do it.

Please |ook at the example file provided.

16. Where can | get cool midi files from for free?

Just pop on over to http://www.exrock.com. There's a lot there for you to use! And tell them the Jester
sent you.

17. Can | have both the Flash music file and the midi file playing at the same time?
Yes. You can play both or one or the other.

18. Can | use ANY flash projector file?
Yes, only PC versions though.

19. Does the screen saver support password protection?
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Yes

20. Why should | choose the FlashJester Entertainor?
The FlashJester Entertainor is one of the best Flash screen saver players about and has many different
features that are not in others. The FlashJester Entertainor allows you to add interaction to the screen
saver. By turning on the interaction, you can point and click at the screen saver. You can also turn the
sound to the Flash file on or off. By turning it off, you can also add another great feature to the screen
saver, playing amidi. The screen saver allows you to play any midi file along with the screen saver.

21. | have a few questions regarding installers. First, which specific WISE installer to you
recommend? Package Studio? Wise for Windows Installer? or Wise Installation System? Are they
all flavors of the same product? Are there any other less robust solutions that you might
recommend? For now, all | really need to do is create a simple installer that allows the option to
‘Launch at Startup'. I'm sure WISE products can do this but | have no need for its many other
functions.
OK See the attachment. We've just created a ssimple Installation for you using the Wizard. It will install a
Juggled filein ac:\program files\pitball directory and add alink in the Startup directory as you required.

We recommend you go for the

Wise Installation System 9 - Standard Edition
Thisisvery powerful asitis.
http://www.wise.com/ordercentermain3.asp?category=6

We use an old version of Wise Install. It does the job and alot more.

22. | have a bitmap at the start of my Juggled file. When the Juggled file loads up, the animation for
this bitmap is slow. Is there anything | can do about this?

The Juggled file takes a little time to load the whole projector file at the start. To combat this, you will
either need to put in some empty frames at the beginning or use as little vectors/graphics at the start as
possible. It should only take a few seconds to load but it is best to leave a short delay before the
animation starts.

23. Can the user control how the animation is played?

That depends if you have the keyboard interaction on or not. If the keyboard interaction is turned on, the
user will be able to start and stop the animation by pressing the Enter button. They can also go forward
and backwards through the frames by pressing the left and right buttons. If you turn keyboard interaction
off though, these keys will not function.

24. What about my screensaver? Won't that interrupt it?

One of the options of Jugglor isthat you can choose to disable the screen saver while the Juggled file is
playing. This can be done in the Flash Settings section.

Page 4



FlaShJeStel' Flashjester FAQ. @

the ultimate place for flashing tooils

25. Do the users need the Flash Shockwave plugin to view the Juggled file?

No. This is the beauty of Jugglor. You don't need any plugins at all as Jugglor uses Projector files,
stand-alone programs in themselves, to create the Juggled files.

26. What files will | need to include with the file?

Y ou don't need to include any files with the finished Juggled file since everything is packaged up in the
one EXE.

27. 1 have a lot of SWF movies which | load in using the Load Movie command. If | add them all into
the additional files section then the file is way too big and takes ages to load. Is there any way | can
get around this?

Yes. You do not haveto put al your moviesinto the Juggled file. By using Jugglor's " Current Directory”

feature (in the build section), you can specify the directory in which the Juggled file will look for the
movies

28. | want to be able to secure some of the files that are inside my Juggled file, as when they are
extracted anyone can acess them from the Windows/Temp. So | am looking to secure it using
Winzip. | have JStart and Jugglor. Now how can | extract/uncompress a password protected Winzip
file ?

In Winzip you can use command line to extract compressed files see

>>
Extracting Files
The command format is:

winzip32 -e [options| filename].zip] folder
where -eisrequired.

options

-0 and -j stand for "Overwrite existing files without prompting” and "Junk pathnames’, respectively.
Unless -j is specified, folder information is used. Use -sPassword to specify a case-sensitive password.
The password can be enclosed in quotes, for example, -s" Secret Password".

filename.zip
Specifies the name of the Zip file involved. Be sure to specify the full filename (including the folder).

folder
|sthe name of the folder to which the files are extracted. If the folder does not exist it is created.

>>
The above was taken from

http://www.winzip.com/xcmdline.htm

With JStart you can pass these parameter oni.e

File
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winzip32

Arguments
-e -s'flashjester” jstart.zip

where

the password is flashjester
jstart.zip isthe zip file inside the Juggled file

Remember the zip file will uncompress into the Windows/Temp where all the other file are.

Please download the working example and then build the project in Jugglor to see it working.

29. I'm using Jugglor and JSave together, and when | tell JSave to save to the text file the text file is
not there when | look. Where is it?

When you run a Juggled file, it extracts all the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you

run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the

JSave Help file -> Setting up JSave - Additional Commands

30. | can save text using JSave with Flash MX projector files ?
Yesyou can. You will have to use JSave and Jugglor together in order to do this.

Remember to look at the ActionScript very carefully and don't forget to add the EncodeForJugglor
function. YOU MUST ADD THIS.

Please download the example file to get a better understanding.

31. I'm using Jugglor and JSave together, and when | tell JSave to save to the text file the text file is
not there when | look. Where is it?

When you run a Juggled file, it extracts all the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you

run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the

JSave Help file -> Setting up JSave - Additional Commands

32. Are they compatible with a Juggled file?

The JTools and Jugglor are best companions. By using the two, you can come up with a fully
functioning piece of software.
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33. What if | want to have more that one web/email/program link?

You'll only need to include one copy of each JTool you use as the parameters inserted in the Projector
file reuse these JTools. These are to be kept in the same directory as the projector file.

34. 1 am now using Flash MX/6 Projector files, but none of my previous JTools link work ? Why is
this ?
Yes, this will not work due to the changes made by Macromedia in Flash MX. You will need to
recreated the links by pressing the Copy button again in the Jtools section and paste accordingly into the
FLA file and exporting it back as a Flash MX/6 projector file. Remember you will not need create the
FSCOMMAND directory for the JTools to work, Jugglor has taken care of this.

35. For FSCOMMAND - Exec to work with Flash MX, | heard you have to create a FSCOMMAND
directory ? Is that true ?

If you are using Jugglor and the JTools then you don't need to create the FSCOMMAND directory. If
you are not then yes you will need to create the FSCOMMAND directories yourself. Please see
respective helps.

36. | have Flash MX on my machine but | want to create a Flash 5 projector. How can | do this
without reinstalling Flash 5 ?

First make sure you have Flash 5 on the machine. Then locate
\Program Files\M acromedia\Flash 5\Players\FlashPla.exe

Open it and then close it. This will set the Flash 5 Player as default. Click on an exported Flash 5 SWF
file from Flash MX and now it will open up the Flash 5 player. Then go to File -? Create Projector. Now
if you would like to create a Flash MX Projector just use the Publish command and check Window
Projector checkbox.

37. Why doesn't the Patch command work with Flash MX files ?
Y ou don't need to patch Flash MX files. We are using a different approach here.

38. | want to run an AVI file but | don't like the default Microsoft AVI player. What should | do?

Weéll, if you have your own AVI playing program you can use JStart to get that to play your AVI. You
can however use our specially designed JAvi player. This will play an AVI file with the minimum
amount of effort. JAvi is totally customisable, with features including looping the AVI, closing when
finished playing, one instance and many more.

39. My Auvi plays from JAvi fine on one machine, but doesn't on another | tested it on?

Thisis probably due to the codec that you have encoded your Avi in and it is not installed on the other
machine.

40. Can JAvi detect whether a codec is installed?
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The JAvi play cannot currently do this, but we are looking into it for the next version.

41. Is there any way | can include all the files in one EXE rather than distribute the AVIs, JAVI and
projector together?
Yes there is. You can use another product in the FlashJester range, Jugglor. With Jugglor, you can
modify how your projector file plays and acts, but the feature that you will find most useful is the fact
that you can have al your files, JTools and projector files in the one EXE. A free evaluation version of
Jugglor can be found on the FlashJester website at http://www.jugglor.com.

For an example of Jugglor and AVI combined, check out the JAVI Example file included with this
installation of JAVI. If you want to see how this works then have alook at the JAVI Example file FLA.
There you will see al the links and how they work, and if you want to know how those links were setup
in JHelpor, the JHF is there as well.

42. How do | get JEmail working with Flash MX ??
See exampl e below.

43. Why is the text in the copy box in JHelpor different to the text that is inserted in the FSCommand
box when | press CTRL + V?

The reason for this is because JHelpor works out the actual code needed for the JTool. As the projector
file doesn't accept spaces what you see in the Argument box is the code with the spaces. JHelpor then
modifies this to take out all the spaces.

44. Will 1 have to include a copy of JMovie for each movie file | open with it with Flash 5?

No. JMovie works with parameters meaning that you don't need to make copies, it will just use the one
copy to run al your links. In Flash MX you will have to create one instance for each movie you use. The
best thing will be to use Jugglor and JMovie then you will only need one copy of JMovie.

45. Is there any way | can include all the files in one EXE rather than distribute the movie files,
JMovie and projector together?
Yes there is. You can use another product in the FlashJester range, Jugglor. With Jugglor, you can
modify how your projector file plays and acts, but the feature that you will find most useful is the fact
that you can have all your files, JTools and projector file in the one EXE. A free evaluation version of
Jugglor can be found on the FlashJester website at www.jugglor.com.

For an example of Jugglor and a movie file combined, check out the IMovie Example file included with
this installation of JMovie. If you want to see how this works then have a look at the IMovie Example
file FLA. There you will see all the links and how they work, and if you want to know how those links
were setup in JHelpor, the JHF is there as well.

46. Do | need JHelpor to set up JNetCheck links, the same as your other tools?

No, not at the moment. This is because you only need to simply run JNetCheck and do not need any
parameters to make it work. In the future, it may be necessary because of added features.
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47. 1 have JNetCheck set up, but what can | do with it?

Take alook at the Uses section of this help file and the example file that comes packaged as well. Try
experimenting with it also and if you come up with any good examples, let us know. Email
galery@flashjester.com with your examples.

48. I'm looking into creating a CD that would contain a Flash projector file on it. On one frame of the
file, it would contain a print button, that would print the contents of the frame to a PDF file. Do you
have a tool that would accomplish this?

Y ou can create the PDF files you need from the Flash file and save the save indivdua psf file then use
JStart to print the pdf file.

Look at the help file

C:\Program Files\FlashJester\JT ools

JStart_ IWeb JEmail.hlp -> JTool Settings -> JStart -Using the Print Command

or

Y ou will need a PDF Printer Driver.

Here one

http://www.pdf995.com/

yu can find more by going to

http://www.google.com/search?sourcei d=navclient& ie=UTF-8& oe=UTF-8& g=PDF+Printer+Driver
Basically you use the normal print command in Flash or you can use

JPrintor
http://jprintor.flashjester.com

and instead of printing to a Printer you select this PDF driver.

49. Will I have to include a copy of JPrintor each time | want to use it in my projector file?

No. JPrintor works with parameters meaning that you don't need to make copies, it will just use the one
copy to run all your links.

50. What if the user doesn't have a printer?
JPrintor will not print if the user does not have a printer.

51. How do | use JSave with Jugglor with Flash 5?
JSave can be used with Jugglor in the same way that all JTools are set up. See the Jugglor help file for
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more information on setting up JTools.

52. What does all this coding mean?
To find out more about the coding used in the Flash file, have alook at the Flash manual or help file.

53. | have followed the steps in the step by step guide but it still won't save. What can | do?

Copy the "Save" keyframe over again, and make sure you replace EVERY Memol with your own
choice of variable for your text box.

54. | have tried typing into the text box but it only takes my first line | type. Why's this?

JSave only takes the first line you insert into the text file and will not take any characters after you have
pressed return.

55. | have typed in a long paragraph but it got cut off half way through. Is there a limit to the amount
of words you can type and save?

Yes. Flash is limited to just exporting 255 characters (this is even less taking into consideration the
JSave command and the parameters for where the text file will be stored.)

56. Because the Flash file is in Flash format, does that mean | will need to patch it as | have had to
with other JTools?

No, you won't have to. The special coding ensures that is not needed for JSave.

57. I'm using Jugglor and JSave together, and when | tell JSave to save to the text file the text file is
not there when I look. Where is it?

When you run a Juggled file, it extracts al the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you

run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the

JSave Help file -> Setting up JSave - Additional Commands

58. Where can | get Jugglor from?

You can download a free evaluation version of Jugglor from the FlashJester website at
http://www.jugglor.com.

59. Am | limited to certain shapes?
No, not really. It's up to your imagination and Flash.

60. Why can | see bits hanging around my Juggled file?
Thisis caused by discolorisation of the transparent color, probably due to when it was decreased from 16
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million colours. You can easily get rid of this by adjusting the tolerance control in the main JShapor
window.

61. Why have the Border, Caption and Size options been disabled in my Juggled file when | add a
JShapor command?

These are disabled because the skin you choose specifies the size and you will not need the borders and
captions because of the custom shape.

62. We need to launch Excel files out of the projector. The master
CD works fine on my machine (winXP), but is erroring on WinME
and win98 cpus. The projector launches Excel okay, but cannot
find the files despite loading the application.

Here is a sample ini file.

[START]
Application=../Excel Files/cash flow projection.xls

Y ou are using fowardslash / when you are suppose to use backward slash \
So it should be

[START]
Application=..\Excel Files\cash flow projection.xls

63. | have a Flash MX projector file that uses the LOADMOVIE command to load additional SWF
files. Now | want these SWF files to load my Word, Pdf, EXE and other files. Is this possible ?

Y es, you can sure thisis possible.

Please download and carefully look the example file given.

64. Does the final flash file need to be an EXE for the JISTART commands to work or will an SWF
also work?

Yes it has to be a Projector file, it will not work on SWF files in a browswer due to security reasons,
unless you are using the LOADMOVIE command to load additional SWF files from a projector file. See
the FAQ above this one for more details.

65. | want the desk.cpl file (Display Properties) to launch when I click on a button in my movie. Is this
possible ?

Yessure. You will need to write the following
[START]

Application=rundl|32.exe
Parameters=shel|32.dll,Control_RunDLL desk.cpl
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Please see the example file below.

66. How can | open a file Maximised or Minimised when it has been launched ?

JStart allows you to open any file Maximized or Minimized. i.e Word Documents, PDF's, PowerPoint
file etc. All you need to do is specify the name of the file you want to print in the File box then add the

[/startmaximized - to Maximize
/startminimized - to Minimize
command in the Argument Box
Download the example file provided.

67. How can | automatically print a pdf file ?
JStart allows you to print any file that supports DDE printing. i.e Word Documents, PDF's, PowerPoint

file etc. All you need to do is specify the name of the file you want to print in the File box then add the
/print command in the Argument Box
P ease download the examplefile.

68. Can you show me how to use JStart to launch a browser that has links to files on my CD-ROM ?
See the exampl e file below.

69. How do | print a text file within a Flash Projector file on Win95/98/NT/ME/2000/XP ?
Using JTools - JStart.
1. Start JHelpor.
2. Pressthe Add command +
3. Select JStart from thelist of JTools available.
4. Select Use Parameters.
5. Under the heading 'File' write
For Win 95/98 machines.
WIN%\write.exe
For Win NT

SY S%\write.exe
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Y ou will have to create 2 different buttons

Click hereto print if you are using Win 95/98 and
Click hereto print if you areusing Win NT

if you can't determine what Operating System the user has.
6. Under the heading 'Arguments’ write
yourtextfile.txt /p /close

where yourtextfile.txt is the name of YOUR text file, Remember to keep it in the same directory as the
projector file. Otherwise different if you know where the text fileis.

/p prints the text file
/close closes write.exe

7. Optional, enter an Error Message something like,
"Whoops cannot print text file'

8. Press OK

9. Then the preview button to seeit in action.

10. If you are happy with the results then press the Copy button and then when in your *.fla copy the text
into the Arguments section using the FSCOMMAND , Exec.

70. Why do | need to use JWeb when | can use

getURL("http://www.flashjester.com”)

?
The advantages of using JWeb rather than GetUrl, is that

1. It will work on all Windows operating systems.

2. The browser window will always appear on top of the projector file and not behind it.
3. Each link you load up will open in the same browser window.

4. It'sFREE.

71. Does JWeb support the POST command?
No, you will have to use the POST command in GETURL in Flash.
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72. | have Flash and the web and e-mail links work fine when | create a projector file. Why do | need
JWeb and JEmail?

JWeb and JEmail's intended use was with Flash 3, as the projector files created in there had the web and
e-mail links disabled. JWeb and JEmail do also however work with Flash 4 or 5 if you so wish to use
them. One of the advantages of using JEmail for you e-mail links is that you can also specify the subject
of the e-mail.

Something which you might have also have found between the two versions of Flash is that the projector
file player is actually alot bigger than its predecessor adding around 100kb more. If you are not using the
extra features in Flash 4 or 5, then it is advisable that you use Flash 3 and the JTools as each JTool is
only 20kb in size and you only need one copy of each no matter how many links you create using them.

73. How do | delete the Shockwave/JPEG/ Real audio files from my cache after | have view/copied
them?

The browsers will automatically clear files in cache after a certain amount of time, but with Woof you
can choose to delete these files. To do this, you must first search you desired path for the file type of
your choice. When the files are listed, you can use the check boxes at the side to choose which ones you
wish to delete. Once you have selected them, either right click on your mouse and select delete from the
menu that appears or go to the file menu and select delete.

Also, after you have copied some files, Woof will then ask you if you wish to delete these. Selecting Yes
will delete them from the folder you copied them from. Selecting No will return you back to the list not
deleting any files.

74. Does Woof display Flash 3, 4 and 5 files?
Yes, it will display all flash files, no matter what version.

75. When | finish surfing the web, | load up Woof to copy the Shockwave files | have viewed online
to another director. However, when | search for them, they are not all there. Why does this happen?

When you browse the web, all the internet documents, images, Shockwave movies etc. are stored in the
temporary internet folders on your harddrive (cache). The maximum size that these folders can be are
defined by the internet browser. If it goes over this amount, it starts to delete old temporary internet files.
So, if you find that not all the Shockwave files that you view online are being kept, perhaps your
browser has set the size of the cache folder to quite a small size. You can ssimply change this by going
into the browser's properties and changing the size of these cache folders. Another, more simple way to
get round this is to use Woof just after you have viewed a Shockwave file. This will almost guarantee it
will still be in cache.

76. This preview window is too small to see the Shockwave in detail. Can | view it larger?

Yes you can. The point of the preview window is just so you get a rough idea of what the Shockwave
movie looks like. To view the Shockwave in a large window, right click on the desired Shockwave
movie, and select open. Thiswill then open the Shockwave in the Flash Shockwave Player.

77. Do you issue an invoice that | can use officially in my country ?
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Yes, sure you can. You will be able to print the invoice online when you register the product. Look out
for Print Invoice option.

78. What services do you offer?
We offer the Creator Express Service which involves putting together your screen saver. Y ou send us the

Projector File and the graphic for the setup box and we'll do the rest. We will convert it to a screen saver
using your graphic to make a custom designed and shaped setup box. Thiswill then be packaged up in a
setup file all ready for distribution. You can get al this for just $99! Y ou will be free to distribute your
screen saver as many times as you want. Y ou will also get a massive $100 discount on Creator which is
<a href="http://flashjester.com/services/creatorexpress/index.htm">Click here for more info.</a>

79. | can save text using JSave with Flash MX projector files ?

Yesyou can. You will have to use JSave and Jugglor together in order to do this.

Remember to look at the ActionScript very carefully and don't forget to add the EncodeForJugglor
function. YOU MUST ADD THIS.

Also DO NOT USE underscores in your filenames.

Please download the example file to get a better understanding.

80. Can JWeb and Jugglor work together ?
Can | make JWeb dynamic ?

Y es sure you can.

<a  href="http://www.flashjester.com/?section=fag& cPath=14 22">Click here  for  further
information</a>

81. I need help in using JWeb with Flash MX.
Please download the following JWeb example.

82. How do | save multi line text using JSave and Jugglor in MX ?
See the example below.

83. Why do | need to use JMapi when | can use JEmail of free ?
Well simple.
It allows you to do more than JEmail does.
1. Allows you to send attachments.

2. Works with ALL email clients. i.e Outlook, Outlook Express, Lotus Notes, Eudora and Netscape
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Mail. JEmail doesn't work too well with Lotus Notes.
3. Support Line breaks.

4. Much more stable.

See the exampl e files provided.

:\Program Files\FlashJester\JT ool s\JM api\M X

84. All I want is to put in a carriage return so | can get a space between lines in a standard txt file,
these created txt files will be used by another program. Is there a way or a work around?

Yes, you can by using the %CR command. See JSave Help file -> Setting up JSave -> Additional
Commandsi.e %LOCAL, %TIME, %DATE for moreinfo.

Please download the examplefile.

85. How can | open a new window like a popup from a Flash file inside a html file ?
Vigit... http://www.flash-db.com/PopUp/

Create the window with the features you want or don't want!, generate the code, and ssimply copy &
paste the generated code on your Flash button. No html stuff envolved here. Everything's in the Flash
movie.

86. How far back has Windows Media Player been packaged with the windows operating
system(win95, win98, win2k)? Does JMOVIE only work with certain versions of Windows Media
Player?

WMP - Windows Media Player comes with all the Windows operating systems.
JMovieisdesigned and will work with any WMP version, including the one

used on Win95. In the end, it will work even without WMP installed, then
it will usethe old MCl interface. Some features may work not so well then.

87. What is the difference between the Standard and Pro version ?

Creator Standard
Create an unlimited number of screensavers but you can only distribute 10,000 of each screensaver you
create.

Creator Pro
Create and distribute an unlimited number of screensavers

88. | have a Flash file which uses the FSCOMMAND - AllowScale=False.

How can | make my movie files fixed within the Flash area on all resolutions ?
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Y ou will need to use IMovie and Jugglor together for this.
JMovie -> Position Size -> Relative to Flash - Checked

JMovie -> Position Size -> Fixed flash size - Checked -> Enter in the size of the Flash file - Width x
Height

Please download the example source file to see how thisis achieved.

89. Is there are way to convert swf to fla ?
Look at

ASV
http://buraks.com/asv/index.html

90. | think | have an old version of the stand alon Flash Projector player. If there is - where can | find
it?
Y es sure go to the Macromedia site

http://www.macromedia.com/support/flash/downl oads.html

91. | want the HTML out of the Juggled Projector while still being able to link to AVIs, PDFs, and PP
outside of the Juggled Projector and to not need FlashPlayer installed on the user's machine. Is this
possible?

1. Download Jugglor from www.jugglor.com

2. Create the new JStart link in Jugglor - JTools

3. Select "Use parameters’

4. In the File box type LOCAL%MYHTMLFILE.HTM. This declares the html to be opened.

5. Copy and paste the command into the Flash FLA file.

6. Export the SWF and then patch it (Jugglor - JTools - Patch Movie).

7. Create a Projector file and assign thisin Jugglor - Flash Details - Flash Projector file

8. When you press build it will compile ONE Juggled file containing JStart and the Projector file. So all

you have to do is distribute onefile.

9. Make the links to PDFs, AVI's etc. in the html files have no paths just the files name and maybe a

subdirectory if you can created one.

We recommend you download the sample file from

92. 1. | want to launch the cdplayer.exe in Win98/2000 ... or the wmplayer.exe
in WinXP with the same Button in a Flash projector application with JStart.

2. | want to start from a Flash projector file located in the data-section
of a CD-Extra the Audio-Tracks in the audio section of this CD.
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Can you tell me which commands for jstart | have to create.

And at least: How can | avoid the error messages, when the apllication (e.g.
wmplayer.exe) indicated in a Jstart command does not exist on PC?

We suggest you just specify the name of the *.cdafile on your CD. This will
load the audio track with the default CD Player it has been assigned to.
Thiswill be the best option
See examplefile.
93. Do you have JWeb for the Mac?
No we don't and you don't need it. Y ou can use AppleScript
See
tell application "Finder"
open location "http://www.myurl.com"
end tell
Read the posting on FlashKit forums if you need more information.

http://www.flashkit.com/board/search.php?& action=showresul ts& searchid=941512

94. How do | save a text file to a floppy disk?
Y ou will have to write something like this

EncodeForJugglor('lJSAVE.EXE a\\demo.txt "Textbox1="+Textbox1)
See example file provided.

NOTE: Remember that flash usesthe\ as a prefix for special characters. \n is a new-line for example. So
\ must be coded as\\. Thisis Flash, not JSave requirement.

95. How do | get access the My Application Data directory? | want to save a text file there?
Y ou can now use the new command in 1.2
AppData%
which will give you accessto
C:\Documents and Settings\UserName\Application Data folder.
Look at example file provided and please read the

JSave Help -> Setting up JSave -> Additional Commands
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96. How do | get access the My Documents directory? | want to save a text file there?

Y ou can now use the new command in 1.2

MY DOC%

which will give you access to

C:\Documents and Settings\UserName

Look at example file provided and please read the

JSave Help -> Setting up JSave -> Additional Commands

97. How do | get access the Shared Object Directory, where the *.sol files are saved? | want to save
a text file there?

Y ou can now use the new command in 1.2

MY SOL%

which will give you access to

C:\Documents and Settings\UserName\A pplication Data\M acromedia\Flash Player\local host
Look at example file provided and please read the

JSave Help -> Setting up JSave -> Additional Commands

98. I'm trying to get an exe to launch from a Flash MX projector file, and it's not working, did | do
something wrong here?

on (release) {
fscommand("exec", "myprojector.exe");
}

For Flash MX the exe you want to launch must be in a folder called fscommand and that folder must be
located at the same level as your original file you are calling from. The folder name is not included in the
argument however, the script stays the same as listed above.

Download the example file below.

If you want to launch other types of filesi.e word, pdf etc take alook at
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http://jstart.flashjester.com
Please take a look at the example <a

href="http://www.macromedia.com/support/flash/tsdocuments/fscommand_projectors.htm"
class=allocation target=_blank>files</a> provided and the Macromedia site.

99. How does one send data from a projector to an email without the use of an email client mucking
up your interface...?

Y ou and use PHP and Flash to send emails.
See
http://www.sephiroth.it/tutorial s/flashPHP/email/
100. Does JMapi support multiple attachments ?
Y esit's possible to have multiple attachments
Y ou have to use the following syntax
Parameter3=FI L E1<#00>FIL E2<#00>FILE3
where FILE# are the paths of thefiles.
i.e
Parameter3=C:\Temp\imagel.JPG<#00>C:\Temp\image2.JPG<#00>C:\Temp\image3.JPG
S0 just add <#00> between files.
That will do the trick.
101. Can you add HTML tags to the body of the email ?
Sure it's possible see the following example
[MAPI]
Address=support@flashjester.com
Parameters=test
Parameter2=<html><body>title : thisis a test<br><br></body></html>

Parameter3=
Error=error

102. Can you load text into the body from a text or html file ?
Yeswe've just added this into the latest version of IMapi.
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Syntax : FILE:<filepath>

Example 1

FILE:bodytext.txt

where bodytext.txt is in the fscommand directory

Example 2

FILE:. \bodytext.txt

where bodytext.txt is in the same directory as the projector file

Please look at the examplefile

103. I am using Jugglor and JMapi. | want to be able to have multiply attachments and also want to
load a text file in for the body part.

Is this possible ?
Yesitis.

Body
Syntax : FILE:<filepath>

Example 1
FILE:bodytext.txt

where bodytext.txt isinside the Juggled file

Example 2
FILE:local%bodytext.txt

where bodytext.txt isin the same directory as the Juggled file
Multiply Attachments

Y ou have to use the following syntax
FILE1<#00>FILE2<#00>FILE3

where FILE# are the paths of thefiles.

i.e

images\imagel.JPG<#00>i mages\image2.JPG<#00>image3.JPG
theini file will look like this

Parameter 3=l ocal %i mages\imagel.JPG<#00>| ocal %i mages\image2.JPG<#00>image3.JPG
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where imagel.jpg and image2.jpg are external of the Juggled file and image3.jpg isinsideit.
SO just add <#00> between files

P ease download the examplefile.

104. How can | create ICON files *.ico ?
We recommend you use

Axialis lconWorkshop
http://www.axialis.com

It's brillant.

105. Do you have JStart for the Mac ?
No because you don't need it. Y ou can use ActionScript

Read this

Create an AppleScript that opens the file and simply call the AppleScript from Flash using an
fscommand.

here is the script:
copy and paste the following into the AppleScript editor

tell application "Finder"
activate
select file "yourfile.mov" of disk "Y ourDisk"
open selection
end tell
(simply change the name and extension of the file and disk to meet your needs and leave the " ")
then save the script (i used classic applet and it worked well) as: "your_applescript”
For this solution to work correctly (simply) you need to make a disk image, name it and drop your files
inside. Be sure that the "YourDisk" string matches the exact name of the disk image you have just
created.

codein FHash:
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on (release) {
fscommand("exec", "your_applescript");

}

the AppleScript and files should be in the same folder for the sake of simplicity (once you get it
working, then you can play around with changing the location of your 'support' files and the qualified
path within the script

If you want more details on this search FlashKit forums

http://www.flashkit.com/board/search.php?& action=showresults& searchid=941512

Just to add to the above.

The applescript must be saved as an application, set to & run onlya€™, and with the extension visible.
It is handy to keep the files in the & fscommand&€E™ folder, so you must call it too:

tell application "Finder"
activate
select file "your_file.pdf" of folder "fscommand" of disk "Your_CD_image"
open selection

end tell

Savethis as, for example, &€ your_applescript.appa€™

and the button code must read:

on (release) {
fscommand("exec", "your_applescript.app");

}

106. Does the JMAPI tool work for Lotus Notes R5 which is not MAPI compliant ?
No JMapi only supports email clients that are MAPI compliant.

107. I'm having problems reading the JMV.ixt to retreive the status of the Movie, using JMovie and
Jugglor together. Can you help ?

Yessure.
Use the LoadV ariables command to load the text file

i.e
loadV ariables("IMV .txt", this);
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Also read

JMovie Help File -> Additional Features -> Retrieving status with IMV .txt
P ease download the example file provided.

108. How do | create a photogallery using Flash ?
Hereisagreat tutorial.

http://www .kirupa.com/devel oper/mx/photogallery.htm

109. What is Jugglor?

Jugglor turns Projector filesinto full-fledged programs. It modifies existing projector files by making the
projector file full screen, makes the escape key the key to exit the file, changes the icon for the file and

disables the menu that comes up when you right click. It then packagesthis all up again into an EXE and
aDLL.

Read more about the features here :

http://www.jugglor.com

110. I am having problems using the MainRatio and selecting a print area using Flash MX. | need
some help.

Please take alook on the example file provided. It includes all the sourcefile.
Remember to extract all the filesin the default directories.
111. Is there are Mac verion of JWeb ?
You really don't need to use a Mac version just use
getURL ("http://www.flashjester.com™)
but if you are facing some problems, you can use Applescript
set theURL to "http://www.flashjester.com.com"
teII_ application "Finder"
activate

open location theURL
end tell

112. How can a READ variables from My Documents folder ?
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Y ou need to use the MY DOC% commmand

which will give you accessto

C:\Documents and Settings\UserName

Look at example file provided and please read the

JSave Help -> Setting up JSave -> Additional Commands

113. Is there a Mac version of JEmail ?

You better off using the getURL (mailto:support@flashjester.com) but if this doesn't work you can use
AppleScript

open location "mailto:someone@somewhere.com”
114. How can | add copy protection to my Projector files ?
Take alook at
PC Guard for Win32 on http://www.sof pro.com/
their software works with Juggled files.

It gives you MUCH more control and security features you can ever imagine.

115. I show my Flash documents via the Flash projector (.exe) on a classroom screen using a Dell
AV projector. So there is no acess to the Web and programming a popup window with a URL will
get me nowhere. Instead, I'd need to launch window content | have prepared in advance.

Can JProWeb find a document on my hard drive or does it only accept URL's, and if so, is there a
"work-around" this?

Y es sure you can load local html files using JProwWeb
Download an evaluation copy from
http://jproweb.flashjester.com

See the following examples

Standalone
C:\Program Files\FlashJester\JT ool s\JProwWeb\Mx\Example 1

With Jugglor
C:\Program Files\FlashJester\JT ool s\JProwWeb\Mx\Example 2
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Read the help file also
C:\Program Files\FlashJester\JT ool s\Source\JProWeb.hlp
Setting up a JProwWeb Command

Hope this helps.

116. Is it right that JSave can only write 255 charachters to a text file?
Yesitislimited by the length of the command line.

We recommand our latest JTool called JSystem.
http://jsystem.flashjester.com

It has a command called

SaveToFile

which has no limit to the size.

JSystem Help -> FSCommand List -> File Manipulation -> SaveToFile

Thiswill help

117. 1 was trying out your JWeb and wondering if there is anyway to set the browser window to open
maximized?

Yesitis.

Y ou will have to use JStart and the /maximised command.

Download an evaluation copy from

http://jstart.flashjester.com

and then look

C:\Program Files\FlashJester\JT ools\JStart_JWeb_JEmail.hlp

JTools Settings -> JStart - Opening afile Maximised...

In the File paramater add the URL instead of afile name.

118. What are Flash Tools ?
Flash Tools are third party softares that give you that extra functionality and customisation to the Flash
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SWF format. We provide such tools.
Y ou can find other such tools here
http://www.swftools.com

119. What does SWF to EXE mean ?

Basically it means converting your SWF to an application that can be run on any machine. These are
usually called Projector files.

To do thisin Flash you would go to
File -> Publish Settings

The advantage in using a Projector file isthat it has the Flash Player built inside it. So you don't have to
worry about end users not having the flash player install. Minimise the extra support for your clients.

120. How can | play a Macromedia Flash animation in PowerPoint?
Please read this
http://office.microsoft.com/en-us/assi stance/HA 010348071033.aspx
and
http://www.ellenfinkel stein.com/powerpoint_tip.html#flash
121. How can | open a new window like a popup from a Flash file inside a html file ?
Visit... http://www.flash-db.com/PopUp/
Create the window with the features you want or don't want!, generate the code, and simply copy &

paste the generated code on your Flash button. No html stuff envolved here. Everything's in the Flash
movie.

122. How can | put carriage returns into a text file using JSystem -j:sy:savetofile command ?
Simple add the chr(13) to your variable
i.e
TheString="Linel'+chr(13)+'Line2'
or ashorter way to insert new lineis:
TheString="Linel\rLine2’;

See the exampl e file below.

Page 27



FIaShJeSter Flashjester FAQ.

the ultimats place far flashing tools

123. Here are some additional tips when using JStart provided by Joe B.
Thanks
1) Publish asa EXE not SWF. SWF or CTRL+ENTER emulation will not work.
2) Do not include path (c:\fscommand\...) in the fscommand to launch the executable.
3) Do not include path (c:\fscommand\...) in the "Application=" statement of theini file.
4) EXE that you publish should bein the parent of the fscommand directory.

124. How do | find out the CD-Rom Drive letter because my links work on hard drive, but not when |
put it on CD?
Y ou need to use JStart with parameters and rather than defining a full path (e.g. D:\files\mymovie.mpg)
you need to put in the relative path (e.g. if your JStart and SWF are in D:\ , youd use
"filesmymoviempg"). If you are using Jugglor, try using the Current Directory feature or you can use
the LOCAL% command (see Jugglor Help file -> Tips).

125. | brought JStart and have successfully used it in my Flash MX movie to launch a PDF within its
application and also another .exe file. However, this CD needs to be cross platform. | know that |
can build an "applescript" that | can launch from an fscommand in Flash (although I'm not all
together sure what Applescript is or how to use it....). However, what | wonder is, how would that
affect my button? Would | have to run some sort of automatic test of the user's computer to see
whether they're using Mac or PC before the flash movie even launched? | just wondered how I could
have both of the fscommands in my Actionscript: Like "Do this if they have a PC, and do this if they
have a Mac." Is that possible? I'm really not too good with Actionscript.

You will have to create 2 different FLA's one for the Mac and PC and publish them as Projector files.
The PC FLA with JStart commands and the other with Applescript as described below.

http://www.flashjester.com/?section=fag& cPath=28 41#232
For creating a hyrid CD and Autoruns for both platforms read this

http://www.flashkit.com/board/showthread.php?s=ffal834a93eabd8f 5¢c4c8f9e97f 34191& threadi d=5003
26

Hope this helps.

126. Do you offer any custom solutions?

We can create and produce a screen saver to your specifications and requirements. Please contact us for
more detail s on support@flashjester.com

127. Can | use the copy and paste commands in Flash using Actionscript? We want to copy text in
the clipboard and paste it in the Flash file?

Y es sure this possible.
See you can use the

CopytoClipboard
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and

GetFromClipboard

See

JSystem Help -> FSCommand List -> File Manupulation -> CopyToClipboard / GetFromClipboard

See the exampl e file below

128. How | could create copy and paste buttons for input text fields (as some novice users of
software would not think to use ctrl+c / p or right click copy/paste)?

Flash Actionscript doesn't support this. Y ou can use our JTool - JSystem to do this.
See
JSystem Help -> FSCommand List -> File Manupulation -> CopyToClipboard / GetFromClipboard

Look at the example file provided below.

129. What is the best way to optimise flash to video ?
FlickerLab have written a very good article on this.

Click on
http://www.flickerlab.com/flashtovideo/
130. | want to read all the files names from a given directory in Flash Projector. How can | do this ?
Y ou can use JSystem to read a folder and much more.
Download an evaluation copy from
http://jsystem.flashjester.com
Then read the JSystem Help file
Home > Command -> ReadFolder
look at the example files provided.

131. How can | reduce the size or optimize the size of my SWF ?
Please look at the following tools
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Flash Optimizer
http://www.flashoptimizer.com

Sparkle SWF Optimizer
http://www.flashkeeper.com/so.htm

Swift Optimizer
http://www.swishsoft.com/swiftoptimizer.htm

Optimaze!
http://www.erain.com/products/optimaze/
132. How can | create a Flash MP3 player ?

Please visit this website, it gives you an indepth tutorials how to do this.

http://www.kennybellew.com/tutorial/

133. How can i browse SWF file in Windows Explorer in the thumbnails view ?
SWF Live Preview 1.0

SWF Live Preview is amed to help you preview Macromedia Flash files using standard built-in
Windows Explorer. Excellent design, easy-to-use interface, powerful features and unique capabilities
make SWF Live Preview indispensable application. And it is free of charge! You won't find anything
similar!.
http://www.eltima.com/downl oad/swf-live-preview/

134. When | execute JSAVE does the function return a value to show it is finished? ResultVar?
No JSave cannot do this.
BUT you can look at JSystem - SaveToFile command.
http://jsystem.flashjester.com
Download the evaluation copy and look at the help file.

135. How can | keep all these JProWeb and html files into one EXE ?

Please read this

http://www.flashj ester.com/index.php?section=fag& cPath=14 56 74

136. How do you make those litte icons in the address bar, you know to the left of where you put the
address?
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Take alook here

http://www.favicon.com

137. Is it possible to build dynamic JSTART statements. For instance | have a number of different
.pdf's that are opened from different sections in my flash app. It would make my life much easier if it
were possible to build a function on my _level0 movie to run a JISTART command and just pass the
file name when calling the function.

i.e.: function openDoc(docName){

fscommand ("exec", "JSTART"+ docName +" /error=error");
Yesit'spossible, you will need to use JStart with Jugglor.

Read this

http://www.flashjester.com/index.php?section=fag& cPath=14 56 26#282
138. How can | use JPrintor and Jugglor together?

Take alook at this section

http://www.flashjester.com/index.php?section=fag& cPath=14_47

139. What can Jugglor be used for?

There are many different uses for FlashJester Jugglor. By clicking below you can see alist of possible
uses for Jugglor.

http://www.flashjester.com/index.php?section=tricks jugglor_jugglor30plus
140. Do you have any Flash Tips ?

Y es go to Macromedia Support Area

http://www.macromedia.com/support/

Kirupa
http://www .kirupa.com/

FlashKit
http://www.flashkit.com

We recommend you also to our links section

http://www.flashjester.com/index.php?section=links
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141. How do you configure Creator for a silent install ?
We have tried (Creator -> Build -> Top Left -> Uncheck all expect for Welcome, Destination and
Message Dialog) but it won't let us uncheck the Welcome Page and Message Dialogs.

Y esthisis not possible with Creator, you will have to use another third
party installation to create asilent install.

Read the following
http://www.flashjester.com/index.php?section=fag& cPath=6_10
and here arelist of FREE Installers
http://www.flashjester.com/index.php?section=fag& cPath=50#225

or if you have Wise or Installshield you can use them.

142. On one machine when | use JProWeb it opens up the notepad instead of the browser with all
the JProWeb settings ?

Check isthefile association of *.HTA and *.HTML files, thisis what JProwWeb uses too.

Y ou should open thisfile with |E .

143. Why doesn't the following flash exec fscommand work ?

fscommand(“"exec","mydoc.pdf")
Flash Exec Fscommand only supports EXE's and no other type of extension. You can use JStart to
overcome this problem.

Try it

http://jstart.flashjester.com

144. 1 would like to use the In-Memory file support in Jugglor, where | can hide the text file in
memory away from the user, now can | load that file using JSystem and the LoadfromFile command
?

Yesyou can, you just add the prefix
INMEM %,

S¢)

"Filename"

will be

"INMEM %Filename"
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145. Does Creator support Dual Monitor ?
Not currently, the new version 2.0 will support dual monitor.

146. 1 am having problems carriage returns and linefeeds with JSave ?
We found the problem.
After tracing the encoded string, it converted it into_d and _a.
Looking at the EncodeForJugglor function, :
s=ord(c).toString(16);
if (ord(c)<10) s='0'+s,
Result +=" '+s,
Te second line should be: if (ord(c)<16) s='0'+s;
SO
s=ord(c).toString(16);
if (ord(c)<16) s='0'+s,
Result +=' '+s;
We have updated the Jugglor and JSave Help file.
147. 1 need help using Jugglor and JMapi together to generate an email sent to an address entered

by the user using a form the Projector file AND attaching a document.

Is there a way to use the JMapi tool that will allow sending an email attaching a document but
allowing the user to enter the email address with a form (located in the Projector file)?

Yessurethisis possible.
Please look at the example file below.
148. How can | convert my Powerpoint Presentations into SWF files ?
Flash Spring
http://www.flashspring.com

Open Office - Impress - FREE
http://www.openoffice.org/

IceSlide
http://www.iceweb.com
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PowerConverter
http://www.presentationpro.com/products/powerdelivery/PowerCONVERTER.asp

149. How do | convert my Flash movie to a DVD ?
Y ou can use Macromedia Director
Read this
http://www.macromedia.com/devnet/mx/director/articles/flash_dvd.html
150. How do i open a word or pdf document from my flash file thats on my website ?
Use
getURL ("your word or pdf document path”, " _blank™);

That'sit, no extratools required.

151. | have 2 Excel documents that | am putting on a Flash CD with about 20 Word and 40 PDF
documents. Everything works fine except the 2 Excel documents don't open. Excel starts up but |
get a

"filename.x|s" could not be found.'

error.

| can open the file by clicking on the file and | have double checked the spelling and location.

JSTART.exe "/Financial_Forms/document.pdf"

Are there any special problems with .xls documents?

Y ou have forward slashes, you should always use BACKWARD SLASHES
i.e
JSTART.exe "\Financial_Forms\document.pdf"

That will do the trick.

152. How do | use JSave to save more than one variable and then how by using loadvariable
command to split and get them to load them?

Here

Variablel=xyz& Variable2=abc& etc.
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Then the loadvariable command will split them automatically
153. How do | change the Flash Cursor or something people call it the Flash Pointer?

First of all create the image you want and save it asan mc cal it "my_cursor"”.

Then drag an instance of this mc just off the side of the stage and give it an
instance name of "my_cursor”

Copy the following code into the first frame
Mouse.hide();
my_cursor.onMouseMove = function() {
this._ X = _Xmousg;
this._y = _ymousg;
updateAfterEvent();
¥

We is aposted example-
http://www.nepeanmedia.com.au/flash/flas'my_mouse flash_8.fla
154. How to a convert my Flash SWF file to Video ?
Hereis an excellent site that describes how to convert the SWF to Video
http://www.flickerlab.com/flashtovideo
155. Do you have any Flash Tutorials for me ? | am a beginner
We don't but these guys certainly do
http://www.sephiroth.it/tutorials.php
http://www.actionscripts.org/tutorials.shtml
156. How do | use Flash to connect to mySQL ?
Read these
http://www.webmonkey.com/webmonkey/programming/php/tutorial s/tutorial 2.html
http://www.actionscripts.org/tutorial s/beginner/Integrating_Flash_and_mySQL/index.shtml

http://www.sephiroth.it/tutorials.php

157. 1 am having problem using JProWeb. i get the following error
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"This file does not have a program associated with it for performing this action. Create an
association in the Folder Options control pane.

158.

159.

Check that the file association of *.HTA and *.HTML files, thisis what JProWeb uses too.
Y ou should open thisfilewith |IE .
Windows Explorer -> Tools -> Folder Options-> File Types-> HTM Application

How can | print a document i.e Word, PDF or Text file?

You can use the /Print command that comes with Start it prints any document that supports DDE
printing.

Please read

JStart JWeb JEmail Help File-> JTool settings -> JStart - Using the Print Command
and download the example file given.

How do | print a PDF file from Flash Projector ?

JPrintor will not do this. Y ou need to use JStart please follow this link

http://flashjester.com/?section=fag& cPath=28_41#352

160. Can JStart and Flash MX or Flash 8 work with Jugglor ?

161.

Y es sure you can.

http://www.flashjester.com/?section=fag& cPath=14_26

How do | Launch Windows Explorer to open at a certain folder and drive ?

Y ou will need to use JStart

1. Create anew JStart link in JHel por

2. Select "Use parameters’

3. Inthe File box type WIN%\EX PLORER.EXE. This declares the program to be run

4. In the Arguments box type in location that you want Explorer to open up in eg. d:\temp

When JStart is then run using these parameters, it will run Windows Explorer with the directory
D:\Temp in the main view.

Now if you wanted to open up Windows Explorer in the current directory where the Projector file
residesi.e in the CD-ROM or a sub-directory on the CD-ROM then you will have to use Jugglor along
with JStart.

1. Download Jugglor from http://www.jugglor.com
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2. Create the new JStart link in Jugglor - JTools
3. Select "Use parameters’
4. In the File box type WIN%\EXPLORER.EXE. This declares the program to be run
5. In the Arguments box typein LOCAL% (if in asub directory i.e subl then use LOCAL %subl)
6. Copy and paste the command into the Flash FLA file.
7. Export the SWF and then patch it (Jugglor - JTools - Patch Movie).
8. Create a Projector file and assign thisin Jugglor - Flash Details - Flash Projector file
9. When you press build it will compile ONE Juggled file containing JStart and the Projector file. So all
you haveto do is distribute onefile.
We recommend you download the sample file from
162. Why don't the zip file links to your downloads don't work on Firefox?
Thisisthefirefox bug. It can't read zip files. However, all other files download fine.
Y ou must download and install addon
https://addons.mozilla.org/extensions/morei nfo.php?application=firef ox& category=Popul ar& numpg=10
&id=201
to fix this problem.

After installation, restart firefox and load page again. Right click on the link and select Save Link with.

163. | am having problems saving text to my XML file using JSave. Seem | am having problems with
the double quotes.

Pease download the following example file. This example does exactly this.

164. | need help using JProWeb. | need to open a borderless window url from a Projector file ?

First of all read the help file given.

Start -> All Programs -> FlashJester -> JTools -> JProWeb -> JProweb Help
Setting up JProweb Command -> Setting up for Flash MX

Follow the step by step.

Then look at the example files given

C:\Program Files\FlashJester\JT ool s\JProWWeb\M x

Also read the online FAQ

http://www.flashj ester.com/index.php?section=fag& cPath=28 49
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Hope this helps.

165. The code works just fine in v2.1, | don't know if it's because of the version change or what.
This is our code :
MakeXMLMap();// our function to make xml content=gXMLDoc.toString(); //make

a string out of our xml document //write it down to temp.xml
fname="temp.xml";

fscommand("exec",EncodeForJugglor(’j:sy:savetofile:"+fname+","+content+
,Resultvar'));

Is there something wrong with this code or is the new version clash with Jsystem? Other
functionality of Jsystem works just fine (Save/load dialog)

Each " symbol in the content must be encoded with two " symbols, because one symbol will terminate
the string.

166. | have a main projector file. Now | want to use addtional SWF's to load my web pages and links
with JProWeb. Is this possible ?

Yesit sureis.
See the example below.

Please please please. Go through the 2 FLA's files so you can understand how it all works. Look at the
directory structure and why its that way.

167. | get the following message on my Flash web page.
"Click to activate and use the control"

How can i remove it ?
Read thisfor all your answers

http://www.amarasoftware.com/flash-problem.htm
or

http://activecontent.blogspot.com/

168. How do a convert my DVD to Flash FLV ?
To turn your DVD into a Flash FLV then following these instructions.

1. Copy the .VOB files from your DVD to your hard drive. DVD video
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iIsMPEG, so change the file extension to nameofvobfile MPG.

2. Use this freeware software called DV Dx.
DVDx alows you to convert your own DVD to VCD2.0/SVCD1.0/AVI/ WMV
in one step (Including multiplexing, splitting). It produces very
good quality moviesin AVI/MPEGLYMPEG2/WMV 9 format and you don't
need to have 5GB free on your hard disk !

Download it from here

http://prdownloads.sourceforge.net/dvdx/DVDx_2 5 1 setup.zip?download

3. Openin Flash 8 Video Encoder, create flv file.

169. | have a Flash Projector EXE file, | don't have the oringal FLA, is there anyway to recover the
SWEF from the EXE ?

EXE to SWF ?
Y esyou can.

Look at these tools

SWF2EXE
http://www.flashkeeper.com/fk/swf2exe.htm

SWF Scanner
http://www.livetronix.com/products/swfscanner/

170. 1 am looking for a method to print (whether it be a local file, or a frame in Flash) from a Flash
projector. The project | will be using this for will be a Kiosk which will print maps to a local printer if
the user so chooses.

The application | am building will be a fullscreen Flash application and we would like to bypass the
printer dialogue box when the user touches the "Print" button within the Flash app. (ie. Press button
once > Out comes a page)

Does JPrintor allow me to do this?
For Local File Printing

We recommend you use JStart with the /print command. This will print a doc or pdf file without any
dialog boxes.

Read this

http://www.flashjester.com/?section=fag& cPath=28 41#352
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and look at the examplefile given.
Frame Printing

To print a screenshot then use JPrintor. It will by pass the Printer Dialog, just make you don't have this
option checked

Other -> Show Printer Dialog

171. How do | open a powerpoint presentation file *.pps using a Flash Projector file?
Y ou can do this using JStart.

http://jstart.flashjester.com

See the exampl e file beloiw

172. We are having problems opening a Powerpoint File pps or ppt file in a Flash Projector using
JStart.

We get the following error

"This file does not have a program associated with it for performing this action. Create an
association in the folders options control panel.”

| have installed the Powerpoint 2003 Viewer on this machine which doesn't have Office 2003 -
PowerPoint. On the other machines with Office 2003 it works fine.

Thisis a PowerPoint Viewer issue and not a JStart.

The installation doesn't add the PPS or PPT file association in the folders option in the Control Panel.
Y ou have to-do this manually.

Read thisif you want to do this

http://ask-leo.com/what_does this file does not_have a program_associated with it_mean.html
But this doesn't make sense as you can't do thison all your clients machines.

So we need to find a workaround.

PowerPoint had an option called 'Package for CD'

1. Open the PPS file you want on the CD.

2. PowerPoint -> File -> Package for CD

3. Copy to Folder..

4. Change the nameif you want.
5. Press OK.
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Then copy the folder if just created. i.e.

My Documents\PresentationCD

to you working folder.

You will notice that in thisfolder it has ALL the files you require to open a PowerPoint file regardless to
whether the end user has PowerPoint. The PowerPoint viewer filesare al here.

Double click on the play.bat and you will see it open up.

Now you need to go to the JTools section in Jugglor and use JStart. There are 2 methods which we can
use:

1. Open the bat file play.bat
2. Construct the command line in JStart that opens the viewer and PowerPoint file

i.e pptview.exe /L "playlist.txt"
Open Jugglor.

Jugglor -> JTools -> + -> JStart
Use Parameters

Method 1.

File
local %PresentationCD\play.bat

Default Directory
|ocal%PresentationCD

Method 2

Now if you don't want to see the MS-DOS black box appear before the presentation starts then we an
eliminate the use of the bat files so we have

File
local %oPresentationCD\pptview.exe

Arguments
/L "playlist.txt"

Default Directory
|oca %PresentationCD

REMEMBER : PresentationCD isthe folder where all the PowerPoint files are.
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That's it.

Press the OK button and Close the JTools window.
Press the bottom Copy button next to the Arguments edit.

The paste thisinto your FLA file.
It will look something like this.
1.

on (release) {
fscommand("Exec”,

"JSTART _20local_25PresentationCD_5Cplay.bat 20 20 2Fdir_3Dlocal _25PresentationCD");
}

2.
on (release) {
fscommand("Exec",

"JSTART_20local_25PresentationCD_5Cpptview.exe 20 _2FL_20_22playlist.txt 22 20 2Fdir_3Dlocal
_25PresentationCD");

}

Publish it and bring it into Jugglor and Build the project.

Now if you have mutliply PowerPoint files, then you don't need to create another folder with the view
inside, but just another playlist.txt file and change the name of the PowerPoint file inside it.

i.e
playlist2.txt

insideit just has
FlashJester2.pps

Please please download the example file to see if working. It has all the source files you require.

173. How do | use JSave and XML in my Flash Projector ?

We've added as much power as we can to JSave with all the features we have put into it but at the end of
the day it isatool to help your creativity and do with it what you wish. And that is exactly what Nicolas
S Roy, Interactive Developer for Logient (www.logient.com) did.

Using our JSave example file that comes packaged with JSave, he modified it to save XML files on the
hard drive!

He has also kindly given us the code so that you can implement it in your Flash files!
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function jSave (srcText, fileName) {

/I Thisisthe procedure that

/] saves the text

x="1"

y="1%

/] srcText isthe text you want

/ to save

tempstr = srcText;

z = length(srcText);

result ="";

Load = z;

while (Number(x)<=Number(2)) {

if (substring(tempstr, x,y) eq" ") {

result = result + " 1";

X = Number(x)+Number(y);

} eseif (substring(tempstr, X, y) eq chr(10)) {
result = result + "%CR";

X = Number(x)+Number(y);

} eseif (substring(tempstr, X, y) eq chr(13)) {
result = result + "%CR";

X = Number(x)+Number(y);

} else{

result = result + mbsubstring(tempstr, X, 1);

X = Number(x)+1,
}

}

X=X;

y=y

r = result;

Il SaveFileisthefile nameyou

// want to save the text as.

r2 ="jsave.exe" + mbchr(9) + fileName + ".txt" + mbchr(9) + "srcText=" +r;
fscommand ("Exec", r2);

}
}

174. Will | have to include a copy of JAvi for each Avi | open with it?

Yesthat is correct. For each movie you have you will have to create ajavi.exe and javi.ini.
Now if you have 100+ thisisnot agood solution.

To avoid this you can use Jugglor and JAvi together, where it will only require 1 copy of Javi.exe which
Jugglor automatically adds to the final exe.

With Jugglor you have a choice whether you want to

1. Keep the avi filesinside the final Juggled file
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2. Keeo them outside the Juggled file where you will have to use the local% command. See

JAvi Help -> Flash Support -> Using the LOCAL % command

See the example below.
For more information on Jugglor go to
http://www.jugglor.com

175. Do you have a SWF to FLA tool ?
Look at
Sothink SWF Decompiler MX 2002 Pro
http://www.sothink.com/flashdecompiler/index.htm
Sothink SWF Decompiler MX 2002 Pro is a tool to browse, view and parse Shockwave Flash movies
(.swf files). It can extract sounds, images, movie clips from a Flash movies. What's more, SWF
Decompiler can decompile the action scripts in a Flash movie and turn them into neat and readable code.
New version supports Flash MX format
and
IMPERATOR FLA generates FLA-files (readable with Flash MX(6) or higher) from the selected input
SWFs (compiled with Macromedia Flash) and thereby makes it possible to alter the content of a SWF
even when the corresponding FLA got lost. Furthermore it gives you the opportunity to extract al
included media-files (pictures, sounds and videos) so you can edit them with other programs.
http://ave-imperator.com

176. Can | recover my FLA from a SWF file ?
Y es you can well part of it.
Read this
IMPERATOR ?FLA generates FLA-files (readable with Flash MX(6) or higher) from the selected input
SWFs (compiled with Macromedia Flash) and thereby makes it possible to ater the content of a SWF
even when the corresponding FLA got lost. Furthermore it gives you the opportunity to extract al
included media-files (pictures, sounds and videos) so you can edit them with other programs.
http://ave-imperator.com

and

Sothink SWF Decompiler MX 2002 Pro
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http://www.sothink.com/flashdecompiler/index.htm

Sothink SWF Decompiler MX 2002 Pro is a tool to browse, view and parse Shockwave Flash movies
(.swf files). It can extract sounds, images, movie clips from a Flash movies. What's more, SWF
Decompiler can decompile the action scripts in a Flash movie and turn them into neat and readable code.
New version supports Flash MX format

177. When | double click on a Flash SWF file on my PC nothing happens ?
I've installed the latest Flash Player but still nothing.

It works fine on Internet Explorer
There are 2 things you can do here.

1. Publish the SWF file as a Projector file using Flash.
2. You will need have SAFlashPlayer.exe which actually comes with Flash and plays the Flash file.
C:\Program Files\Macromedia\Flash XX X\Players\Release

Double click on this and then close it. Now your SWF files will be assigned to the SAFlashPlayer.exe
you clicked on.

If you want to load SWF's file in different Flash Players i.e. MX, MX 2004 or 8 then find the
appreciated SAFlashPlayer.exe.

Below you will find alink the Flash 8 - SAFlashPlayer.exe

178. What tool can we use for an installer?

Inno Setup is by far the easiest installer to use. You can go from installing it to having your installer
done in ten minutes if it's simple. Writing an installer involves editing a simple text file that is similar to
an INI file. The included editor has syntax highlighting and a great help file. It has a lot of features and
should cover most situations. If you need more functionality it has Pascal scripting. It is open source and
very professional.

http://www.jrsoftware.org/isinfo.php

NSIS (Nullsoft Scriptable Install System) was originaly written by Nullsoft, the guys who wrote
Winamp. It createsreally SMALL installers -- afull featured installer has a 34k overhead. Thisis (in my
opinion) it's main advantage over Inno Setup. NSIS is open source and has a lot of documentation.
Writing an installer takes more work, since you have to write the install script by hand. If you have a
complicated install procedure or need the smallest possible installer, NSIS is for you. It has some nice
features like multiple compression methods. If it doesn't have built in functionality that you need, it can
be extended easily with DLLs
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http://nsis.sourceforge.net/
here are some more

http://www.thefreecountry.com/programming/setup.shtml

179. We have Jugglor and Jtools.

The program will be run from the CD. The main uses of JTools will be to open PDFs and open
specific directories in Explorer.

| cannot get JTools to work?
Below are the settings | am using. Please tell me where | am going wrong.
Open PDF:

File: C:\Program Files\Adobe\Acrobat 4.0\Reader\AcroRd32.exe
Arguments: LOCAL%\Reading_Room\Reading_Room.pdf

OK first of all, make sure you are doing this in Jugglor and not JHelpor. To open a PDF file you don't
have to specify the AcroRd32.exe al you need to do is specify the *.pdf file.

S0 select JStart, set to Use Parameter and in File you should have
L OCAL%Reading_Room\Reading_Room.pdf
YOU DON'T haveto add the extra\ as you have between LOCAL % and Reading_Room.

Then press OK and the Copy button and paste into the Argument section in your FLA file, export it as a
SWF, then patch it to create a Projector file.

180. | need help using JStart with Flash MX or Flash 8. What to do ?
Read the help file first, located here
C:\Program Files\FlashJester\JTools\JStart_JWeb JEmail.hip
Setting up JTool links -> Setting up for Flash MX
Also look at the example files provided here
C:\Program Files\FlashJester\JT ool s\Examples

F5-Flash 5
MX - Flash MX

Use the MX examples for Flash 8 also.

Page 46



FIaShJeSter Flashjester FAQ.

the ultimate place for flashing tooils

Thiswill help you get started.

Now if you don't want the files you open to go in the background when you click outside it we
recommend you use Jugglor and JStart together.

Read this
http://www.flashjester.com/index.php?section=fag& cPath=14_56_26#268

Jugglor
http://www.jugglor.com

Thiswill help you get started.
181. | want to create my own Flash CD Player. Can you help ?
Y es, download an evaluation copy of JCD from
http://jcd.flashjester.com
Wefirst of all we suggest you look at the 3 example files given.
Look here
C:\Program Files\FlashJester\JT ool S\JCD
Thiswill help you get started.
182. How do | Load a HTML file, edit it and then Save it back as a HTML file in a Flash Projector ?
Y esyou can use FlashJester JSystem - SaveToFile function todo this

In additional to the EncodeForJugglor command you will also need to use another function called
EncodeDQuotes.
i.e

fscommand(*exec”,
EncodeForJugglor('j:sy:savetofile:"local Yotest.html " ,"'+EncodeD Quotes(mainstorage) +" ,ResultVar'));

and the function to encode

function EncodeDQuotes(x:String): String {
var c:String; var EncodedQuotes=";
for (var i=0; i<length(x); i++) {
c=x.substr(i,1);
if (c=="") c+=""; // double each "
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EncodedQuotest+=c;

ieturn EncodedQuotes,

Please look at the Flash 8 example file to see it working.
183. Can | view IPIX files from my Flash Projector file ?

Y esyou can do thiswith our JTool - JStart
http://jstart.flashjester.com
Theini file should look something like this
i.e
[START]
Application=.\ipixvieweripixviewr.exe
Parameters=..\files\bed.ipx
ipixviewer.exe is astandalone IPIX viewer from
http://www.ipix.com/products_standal one.html

In the parameter section you specify the location of the ipx file.

Now it is very important that you also keep a copy of 1px32_56.dll in the same directory as the viewer
exe.

Please download the example file to see it working.

184. Why should | pay for JTools when | can use the START and Batch commands for free?

1. When using the start command or batch files, an MS-Dos box appears, this can look very
unprofessional and can be off putting for the user. With JTools thereisno MS-DOS box.

2. JTools works on Windows 95/98/NT/2000/ME/XP/Vista
3. The JTools are simple to set up with the help of JHelpor.
4. Itsaclean and professional solution

5. Each JTool (JWeb, JStart and JEmail ) are only 30kb in size

185. Can | automatically build these Juggled files without any interaction in Jugglor. | would like the
user to select a few settings in my Flash file and then build the new Juggled file based on these
settings.

Y esyou can. Read the following
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Jugglor Help -> Advanced Techniques -> Importing & Exporting
thiswill help you get started.
If you would like more technical help then you can hire our Development Team to help you further.

http://hire.flashjester.com

186. | am using Jugglor to create a presentation on a CD. It's an auto-run flash projector file (.exe),
but the file is really big. it takes a long time to load, and my client wants a "loading" screen.

Would Jugglor give me the ability to have a "loading" screen come up while the rest of the exe was
loading in the background.

Try using the feature that is built into Jugglor already.
Build -> Message during extract
Simple.

187. How do you execute a flash projector file when inserting a CD ?

Say your Flash projector is called 'project.exe’, you would create a plain text file called "autorun.inf'
containing the following:

[autorun]
open=project.exe

Y ou can do thisin Notepad.
Then you write thisfile to the CD on the same level asthe .exefile.
It can be bypassed by the user if they hold down the shift key after inserting the CD.

Thisisfor Windows. If you want to do the same for Macs, you'll need to look at the documentation that
comes with Toast.

188. How do | extract swf files from a flash file or even a flash file from a website?
Use this extraction tools.

http://www.19.5degs.com/swfextractor.php#swf-extractor

189. How can put a Flash SWF or a Flash Projector file on a memory stick, flash drive or usb flash
drive and automatically auto launch the flash file when inserted into the flash drive ?
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First of all we recommend you convert or publish the flash file as a Projector file, so it has the Flash
Player built in, as many end user's PCs will not recognise a SWF file.

Then create a plain text file called "autorun.inf' containing the following:

[autorun]
open=project.exe

Y ou can do thisin Notepad.
Then you write thisfile to the CD on the same level asthe .exefile.
For more information on this please go to

http://www.saml ogic.net/arti cl es/autorun-usb-flash-drive.htm

190. Is there a way to clear the cache for the player... or load the entire site and it's contents into the
player's memory. If | test it from my local drive, it works fine... On a CD-ROM, the entire site gets
stuck and it chugs along incredibly slow.

The CD-ROM is composed of multiple SWFs constantly being loaded and unloaded. On a CD-ROM,
for the PC, is the stand-alone player losing memory or something?

Yes, this is because you are running the flash file from the CD-ROM. There are memory issues when
running projector files from a CD-ROM which Adobe have acknowledged (see technotes on the website
for further info), so animation and sound will not play too well.

See:

http://kb.adobe.com/sel fservice/viewContent.do?external | d=tn_16591& slicel d=2

We suggest you use Jugglor to 'Juggle’ the flash projector file and add the additional swf files in the
'‘Additional Files section in Jugglor.

Y ou can also take advantage of Jugglor's other cool features, edit/remove right click/change icon, menu
bars etc.

Once you press "Build it" it packs and COMPRESSES (sometimes the Juggled file is smaller than the
original) al the filesinto one EXE i.e Juggled file.

Well now when you run the Juggled file, the original projector and all other file included will
uncompress onto the users hard drive i.e Windows/Temp directory.

Thiswill now give you the smooth playback you originally had.
Please download an evaluation copy and try it for yourself and see the difference in speed.

http://www.jugglor.com
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Remember if you are using the LOADMOVIE command and you want to access files outside of the
Flash Projector file then you will need replace it with a new LOADMOVIE command using the
LOCAL%.
Seethe
Jugglor Help -> Advanced Techniques -> Using LOCAL%
There you will find an example file also.
Alsoread this
http://www.flashjester.com/index.php?section=fag& cPath=14 55#47
Good Luck
191. How do | build a hybrid CD for both Mac users and PC users?

Read here

http://www.flashkit.com/board/showthread.php?s=ffal834a93ea5d8f 5c4c8f9e97f34191& threadi d=5003
26

also read this
http://kb.roxio.com/content/kb/ET6000102
and

Using Maclmage to create a cross-platform, auto running CDrom from a PC - tutorial (also known as a
hybrid CDrom)

http://www.kook.com.au/kook/hybrid.html
and
Preparing Flash Video, Audio and other .SWF Files for CD Rom Projects

http://www.wildform.com/support/tutorial s/flashvideof orcdroms/

192. I'm looking for a tool or some way to save files to disk from inside Flash.

| want to save dxf files straight from a CD on to the hard drive. Do any of
your tools do this?

We recommend you use an installation tool to transfer files across to your user's machine

Take alook at
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Inno Setup

http://www.jrsoftware.org/isinfo.php

193. | want my main application to be on the end user's machine, but | want the rest of the media to
be on the CD-ROM. How can | have access to these from my Juggled file ?

We've just added a CDROM % command that supports this.
Please read the
Jugglor Help -> Advanced Techiques -> Using CDROM % command

Also look at the example file provided.

194. | had to do a flash presentation that will be put on a CD-ROM and sent to clients.

I've used Jugglor to 'Juggle’ and customise the orginal flash projector file. How do | make the flash
presentation play automatically from a CD?

Take alook at:
Using the Autorun feature on a custom CD
http://kb.adobe.com/selfservice/viewContent.do?external ld=tn_12011& slicel d=2

and
http://kb.adobe.com/selfservice/viewContent.do?external | d=tn_15212& slicel d=2

From Microsoft

http://msdn2.microsoft.com/en-ug/library/bb776826.aspx

195. | can't get my projector file to work using the Local or Current Dir. command. | am launching an
AVI file from a button in my projector file. | thought by creating a single folder named c:\jug where |
could place my projector.exe, my jug.exe, and my AVI file, | could make it work, but it doesn't. Why?

To make it work you need to put a copy of JStart into the same directory as your Projector file and
Juggled file. Normally, Jugglor includes any JTools you've specified automatically and then when it's
run these are extracted to the temporary directory. Now, because you are not using the temporary
directory, it cannot find JStart. So, thisiswhy you must put a copy in there.

A current directory demo is now available for download which contains source files of an example of
launching AVIs, using JStart, from the current director.
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196. Can | use my custom DLL to talk to my Projector file?
Y esthereis away to do this with Jugglor and a custom DLL.

It's not for the faint hearted and non-experienced devel opers.

We can show you a few examples of how this can be done, but any support that is required from us will
be chargeable, asit consumesalot of our time, if it's our bug we will not charge for it.

Please download the examples files given.

There is a C++ and Delphi example. Please take a look at all the files very carefully to get a better
understanding.

197. 1 am confused, and have been reading up on the distribution of flashplayer within applications
such as Jugglor.

What is the legal issue here with using your application to distribute the Flash Player?

There are afew Points to consider

1. The Flash Player is defined as the Activex/OCX control that is installed/viewed through the browser.
If you are distributing this then you may require additional licensing. Read this
http://www.macromedia.com/licensing/

2. The Flash Player doesn't mean the Flash Projector.

3. Jugglor allows you to use the Flash Projector file and the SWF file. If you use the Flash Projector file
then there are no distribution or legal issues. We are the only third party tool that gives you the choice to
use the Projector or Flash Player as the engine.

Read this
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_13247

4. If you use SWF filesin Jugglor then Jugglor doesn't automatically add the FlashPlayer(OCX control)
inside the final Juggled file. There is an option to include the Install file. Again read the licensing
agreement from Macromedia.

5. Jugglor doesn't 'hack' into the original projector file, it creates a shell around it enabling/disabling
features. So if you change the icon of the Juggled file you are changing the icon of the Jugglor Engine
and not the final projector file.

6. We've been developing Jugglor for the last 10 years. We are in constant touch with Adobe and their
developments.

If there were any issues with Jugglor we are sure Adobe would have brought them up. Also take a look
at our client list.

Further reading

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?d=tn_13247
http://www.flashjester.com/index.php?section=tricks_jugglor2_reason
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We hope this clears up afew things.

198. Can I distribute my Juggled files freely ? Are there any restrictions ?

199.

No, you can distribute as many as you like, it's unlimited and no restrictions apply.
But you cannot distribute Jugglor itself. If you have purchased one copy of Jugglor then you are only

allowed to install it on 1 developers machine. If you have mutliple developers then you need a multiple
user license. Please email us for more details on sales@flashjester.com

Do | need some sort of license to distribute the Flash Plugin/ Flash ActiveX Player?
YES

Y ou can apply for aflash player/plug-in distribution license. It's an instant process

done online. Once completed you will be given linksto ActiveX and plug-in installer

files which you can include on your CD. Then all you need is a splash screen where you
can ask the user to install whatever's necessary.

If that's an option for you, then go to:

http://www.adobe.com/licensing/distribution/

and visit thelink : "License Flash Player only”

p.s

Another option is using a Flash Projectorfile EXE where the user does not need the player because upon
export it wraps the player around the file making it atotally stand alone application.

200. After successfully installing the trial version of FlashJester Jugglor v.3.0, | get an error message
when running the application.

"Error loading type library/DLL."

This also probably causes the errors when | want to save the project files:
access violation at blablabla in module Jugglor.exe

OK, you need to install the latest version of the Flash Player.
Goto

http://www.flash.com

and then restart Jugglor.

That will do the trick.
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201. What is the limit on file size for additional files? | have to package an installer with my .exe and
| keep getting the error: "Append file(s) too big." Is there any way around this?

Thelimitis 2GB.

The same error will be shown if some of the files have zero length.

202. When | compile my Juggled file | get the error "Stream write error". Why does this happen?

Most commonly, this means that your hard disk isfull. Y ou can help solve this by deleting old or unused
files from your hard drive. This error might also occur if you compile to a removable storage drive and
thereis no disk present.

203. | downloaded my new version of Jugglor and then uninstalled the trial version and installed the
full version.” The prompt still comes up to tell me | have so many days left. Have | ignored
something to delete?

Y ou have to enter your registration details in Jugglor -> Help -> Registration

204. There are boxes within Jugglor to write error messages. What happens if | don't fill these in?
Jugglor will use the default error messages built into the software.

205. | keep getting an error message when | try to use Jugglor that says "Append file size too big" Is
there a limit on the file size | can create?

Y ou have afile with zero length. Take alook at al the files used in your project.
Look at the'Additional Files section and check in there also.

206. How do | load an AVI (or Mp3, MPEG video file, etc.) SPECIFICALLY in the Windows Media
Player?
This can be done by using a simple JStart command combined with adding a Windows Media Player*
shortcut to the additional filesin Jugglor. If you go to the directory where the Windows Media Player* is
installed on your machine you will see alist of filesit needsto run. From here, add Mplayer2.exe to your
additional files. Thisis a shortcut that will find and run the Windows Media Player* from wherever it is
installed on your users system.

Then just go to add another JTool, specify the AVI (or Mp3, MPEG video file, etc.) and choose the
shortcut you included in the additional files. This will then launch the Windows Media Player*. To
actualy load the fileinto Media Player, you must put it in the Arguments line of the JT ool setup.

207. Why doesn't the FS COMMAND - Exec work to open a normal executable file in a
"Juggled-movie"?
When you run a Juggled file it uncompresses the projector file into the Win/Temp directory. So this
means if you run the Exec command it will try to look for the *.exe in the Win/Temp directory. Now
you can do two things here:

Include the *.exe in the Additional Files section
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or

Use JStart and the LOCAL% to run files from where the Juggled file was launched from.

208. How can | make my Flash file support a Joystick or a Gamepad ?
See

Jugglor -> Setup Settings -> Joystick/Gamepad

No coding involved. It allows the user to Disable Joystick/Gamepad support. Other options allow you to
provide Cursor Position ,Cursor Speed, Mapping Mode and Flash Variables control to the
Joystick/Gamepad.

<b>Cursor Position</b> : The mouse cursor position will correspond to the position of the
Joystick/Gamepad. With this option enabled the position of the Joystick/Gamepad will determine the
position of the mouse cursor. If your Joystick/Gamepad is in the centre position, the mouse cursor will
be at the centre of the screen. If your Joystick/Gamepad is at the top position, then the mouse cursor will
be at the top of the screen.

<b>Cursor Speed</b> : The Joystick/Gamepad will control the movement and speed of the mouse
cursor. Basically the Joystick/Gamepad will act as your mouse, if you move your Joystick/Gamepad
forward it will move the mouse cursor upwards, if you move your Joystick/Gamepad backwards, the
mouse cursor will move downwards. The Joystick/Gamepad will thus act as your mouse.

<b>Mapping Mode</b> : Allows you to use the Joystick/Gamepad to simulate user-defined keyboard
buttons on Joystick/Gamepad movement and buttons. Diagonal movement will be presented as a two
key sequence combining the keys corresponding to the main directions (up/down/left/right).

<b>Flash Variables</b> : This mode is where all the data is put into Flash variables.Joy1X, JoylY,
JoylZ, JoylR, Joy1Buttons, JoylPOV for Joystick 1 and Joy2X, Joy2Y, Joy2Z, Joy2R, Joy2Buttons,
Joy2POV for Joystick 2. The X, Y, Z and R coordinates are normalized in the range -1 .. +1 The buttons
are a binary combination of the pressed state of the buttons - bit O is button 1, bit 1 is button 2, etc. The
POV values are in the range 0..35900, where 9000 is 90 degrees, 18000 is 180 degreess etc. 65535
means no direction.

Download the example file to see how the Flash Variables work.

209. What is Flash Remoting?

Adobe Flash Remoting MX provides the connection between Adobe Flash and your web application
server, making it fast and easy to create Rich Internet Applications. With its powerful yet ssimple
programming model, you can easily integrate rich Adobe Flash content with applications built using
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Adobe ColdFusion M X, Microsoft .NET, Java, and SOA P-based web services.
Read more about it here.

http://www.adobe.com/products/flashremoting/

210. Will all my Flash Remoting code work when | have Juggled my Flash Projector or SWF file ?
Yes, it will work, for sure.

If it works in anormal projector file then it will work when you have Juggled it. Jugglor will not disable
any of these features.

Just make sure all the links are absolute (full addresses).

211. | have used the Flash Projector to create a CD. On my final frame | have an exit button
which works well. Also, on the final frame | want the CD to close automatically
after 10 seconds. How do I do this?

//add the script bellow to your final page.

t1 = getTimer();
onEnterFrame = function(){
t2 = getTimer();
t3 = t2-t1;
if (t3>=10){
delete onEnterFrame;
fscommand("quit”, "");
}
}

212. | tried to call a page named Magic.html in the same folder as the Exec file. So | put Magic.html
on the get URL and it doesn't work. Also, when | try the same thing with my Projector, it works.
Why?

Y ou will either have to add the html file inside the Juggled file in the Additional files section or Use the
LOCAL% command. Thiswill alow you to access files from where the Juggled file residesiin.

Check here for more info:

Jugglor Help -> Advanced Techniques -> Using LOCAL %

213. Why is my FLV in Flash 8 not loading when | use it with Jugglor? It works fine on a normal
projector file.

If the FLV file resides outside the Juggled File (i.e Final Projector File) then you have to add the
LOCAL_25 command in front of the path of the FLV to tell Jugglor where to look.

1. Click on the FLV Playback object in the FLA.
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2. Parameter -> contentPath

Y ou might have something like this
data\videofile.flv

which now needs to be
local_25data 5Cvideofile.flv
where

_25mean %

_5C mean\

Please remove al UNDERSCORES from the filename. The underscore will confuse Jugglor and will not
recognise the statement.

More on this can be found in

Jugglor Help -> Advance Techniques -> Using LOCAL %
If you leaveit as

data\videofile.flv

then it is looking for the FLV inside the Juggled file. Which can be added into the Additional Files
section.

If you still have problems. Please add the FLV Playback object on or after the 5th frame, giving Jugglor
timetoinitialise.

Please look at the example file provided.

214. How can | create my own custom FLV Player ? | would like to be able to skin the flash file. |
would also like to allow the user to select different FLV files. Is this possible?

Yesthisis possible. You will need to use
Jugglor

http://www.jugglor.com

and

JSystem

http://jsystem.flashjester.com
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It resizes at runtime time al so.

215. External FLV files won't play in a juggled projector. Our projector runs next to a folder called
\"assets\" which contains several FLV movies. These are played through the MediaDisplay
component.

my_media.setMedia("assets/m7.flv","FLV");

for FLV files and

my_media.setMedia("assets/music.mp3","MP3");

for mp3 files
Y ou need to add the LOCAL _25 command :

assetym7.flv

S0

local_25assetym?7.flv

Note that we don't need to add \ or / before assets
Now we need to change/ or sometime users use\
but changeitto 5C

so we have

local_25assets 5Cm7.flv

and finally we have

FLV
my_media.setMedia("local_25assets 5Cm7.flv","FLV");

MP3
my_media.setMedia("local_25assets 5Cmusic.mp3","MP3");

See
Jugglor Help -> Advanced Techniques -> Using LOCAL%

for further details.
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216. I'm working on a project that has about 20 flv files that are pulled from a directory and displayed
within a swf. Sometimes,| click the button and a flv plays perfectly. Other times | can hear the audio
track of the flv then get a delay (sometimes long) before the video appears. And, other times the
audio plays fine and the video never appears.

This will eventually end up on a cd, but right now I'm just testing from the projectors and swf files on
my local drive. I've tested it on several different computers and it misbehaves on them all. I'm not

sure how to solve this problem, since it seems to behave quite erratically. Can someone point me in
the right direction?

Yes, this is because you are running the flash file from the CD-ROM. There are memory issues when
running a projector file from a CD-ROM which Adobe have acknowledged (see technotes on their
website for further info).

The machine doesn't have enough memory to play it from the CD-ROM itself.

Hereis a suggestion.

Use the hard disk memory, this can be achieved by using one of products called Jugglor.
http://www.jugglor.com

It will compress the main PC projector file in a new Juggled Projector file. When the user executes this
file it will uncompress itself to the windows/temp directory hence the hard drive. Now you will get a
better and smoother playback. You can keep the FLV on the CD-ROM and use the LOADMOVIE
command along with the LOCAL% to load these files. Y ou can aso pack the FLV's into the Juggled file
using the Additional File section.

Jugglor Help -> Advanced Techniques -> Using the LOCAL%

it has worked for many of our clients.

Download a FREE 30 day trail and seeif it worksfor you.

Email support@flashjester.com if you have any further questions.

217. How do | disable the right click menu in Flash?
From a Flash Projector file you can use Jugglor

http://www.jugglor.com
Jugglor -> Setup Settings -> Default Flash Right Click Menu -> No right menu
From a Flash file on the web, please read this

<a class=txtmainorange
href="http://groups.google.com/group/macromedia.flash/browse_thread/thread/9c0d8a403388567c/2e74
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a4aB001720f2#2e74a4a8001720f2" target="_blank">How to hide the right click popdown menu</a>
That will help you get started.

218. Does Jugglor support Flash FSCommands?
Yes, all FSCommands that are built in Flash will work in Jugglor.

219. | have a strange problem, Jugglor does not read the function stop().

Move the stop() or any other commands to the 3rd Frame then it will work. Our guess is that it's on the
first frame.

Jugglor needs to initialise and take some time hence the move of all commands after the 3rd frame.
Try it.
220. Is it possible to change the words 'Close’ and 'Minimize/Restore' - on right click - into other
languages?
Y esyou can.

Double-click the text to the right of the checkboxes for the right-click menu.

Setup Settings -> Add to Right Click Menu

221. | just purchased Jugglor and when | press the flash projector/movie file it only lets me select
.exe files, | dont get it. | want to select SWF files.

Y ou have probably purchased the Standard Edition.
The Standard edition doesn't allow you to use the transparency feature, which require the SWF files.

Now for all other projects we recommend you publish your Flash file as a Projector file since it has the
Flash Player and your end users will not be required to have the Flash Plug-in.

If you wish to use the transparency feature and use SWF files then you can upgrade to Pro by paying the
difference.

Email support@flashjester.com with your registration details.
Hope this helps.
222. How do | close a Juggled file?
Use the normal actionscript code
on (release)

{ fscommand("quit");
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223. What is the latest EncodeForJugglor function?
Here we go, please download the text file below.

224. How do | start up my Flash Projector minimized, is this possible?
Yesyou need to add the following command
fscommand("exec", "jcommand:minimize")
on or after the 5th frame.
See the example file given.

225. How do | disable the right click menu in my SWF Flash File?

The right click menu in the SWF flash movie can be disabled using the menu attribute, and setting in
html embed code as below

<EMBED src=mymovie.swf type="text/html; charset=is0-8859-1" quality="high" menu=false
bgcol or=#000000 WIDTH=120 HEIGHT=30>

It will not disable the full right menu, asit will still show the two menu options on the right click

226. All the projector "exe" are bigger than before, nearly double the original size of the one made
with Flash 4 or 5.
Is this due to a different flash engine (MX) or is there something else?

Yesit's due to the engine.

The standalone player SAFlashPlayer.exe is 800K B.

:\Program Files\Macromedia\Flash MX\Players

If you are not using any of Flash MX features then | suggest you use F4 or F5 projector files.
To create aFlash 5 projector file you first need to run

C:\Program Files\Macromedia\Flash 5\Players\FlashPla.exe

and load swf from File - Open. Thiswill also now load all SWF filesin the Flash 5 player.
To switch back to Flash MX then double click on

:\Program Files\Macromedia\Flash M X\Players\SAFlashPlayer.exe
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227. As usual, these 3rd party applications cause animations to run slower.. like a 30 FPS movie
would look like 24 FPS..?

Jugglor our third party tool DOES NOT cause the animation to run slower. Why? Because we don't use
the Flash Plugin to play the animation we use the built in flash player that comes with the projector file.
Hence if you use Jugglor it will play at the same rate.

Why not try it if you don't believe us?
Download a FREE evaluation copy from

http://www.jugglor.com

228. In my root movie, | load several movies on seperate layers once the root movie has started. |
create a projector, but if the movies | am calling aren't in the folder with the projector they won't play.

| want to create the projector so it includes everything. So | can avoid putting several .swf files on a
CD along with the projector.

Is there a way to make the projector totally self contained?

Yes, use Jugglor's 'Additiona files' feature. Add your SWF files in there and Jugglor will create one
EXE.

229. Why should | use Jugglor rather than SWF Studio or Flash Studio Pro or any other tools on the
market?

OK, let me break it down for you slowly.

1. Jugglor isthe ONLY tool that use the Projector file as the Flash player, the rest use the OCX control.
So what does that mean | hear you say. Well, you don't need to distribute anything ELSE when you
distribute your app, as the Flash Player is built in. Y ou will not have bulky applications with OCX, DLL
dlipped inside of it. Which means less headaches from your end user. Let me give you are an example
and what has happened in the past. You have distributed your app using the other tools and have the
Flash 5 OCX control inside. Fine. Flash MX comes out and there is a new plugin. Your end users are
using Flash MX and they run your app with the Flash 5 plugin. It overwrites their Flash MX, plugin.
They ring you!!! Using Jugglor and the projector gives you peace of mind. No matter what Flash Plugin
your users have, your Juggled file will not interfere with their system settings.

2. Jugglor has been around for 10 years. Meaning it's very very stable, tried and tested. We were the
origina creator of such atool.

3. By using the Flash OCX control the playback is much slower than if you use the projector file. This
has been proved and admitted by one of the competitors.

4. Much smaller applications can be built using Jugglor. We also use compression techniques on the
final projector. Please compare the output with the other tools.

5. Great support, of course.
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6. Easy to use.
D)

Please, please compare and test all the products yourself and don't just take our word for it, we are
biased.

230. Why are all my external applications (html, .pdf, etc.) loading behind the Flash .exe window?
Make sure in the Jugglor settings "Window Size and Position” -> "Always on Top" is unchecked.

231. Why does my Juggled file flicker when | first run it ?

1. Make sure you are using the latest version of Jugglor.
2. Do NOT put in a FS command "full screen/true” in the Flash FLA file.

232. 1 don't seem to be able to get any URL links to work in the juggled file using Flash MX and the
GETURL command?

Simple

on (release) {
getURL (" http://www.flashjester.com™);

}

See the exampl e provided.

233. | have a flash .exe that is 750x435. | want a projector that runs fullscreen, but keeps the original
file at the 750x435 size. Basically, | just want jugglor to put a fullscreen border around my original
file. How do | do this?

Y ou need to use the FSCOMMAND - ALLOWSCALE

fscommand("allowscale’, false);

234. Are there any restrictions or royalty requirements on using Jugglor or the Jtools for commercial
use?
No restrictions. Depending on how many people you have working for you that will be using the tools
make sure you have the correct license.

That'siit.

235. | have disabled the Windows keys on my Juggled file but when | press the Windows key and
"U" the Utility manager appears?

Whilst Jugglor can disable the Windows key and different combinations that it can be used in, the Utility
Manager is still one that can be loaded up. This is something to do with the way Windows works and
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cannot be stopped at present.

236. | was wondering if any of your products have the ability to reduce the

published file size of a Flash .exe or .swf file? | was looking at your web site and didn't see anything
specifically about this but thought | would ask you directly instead. Thanks.

Yes, Jugglor has a built in compression ability. This is just one of Jugglors feature. All projector files
used in Jugglor are automatically compressed. When you run each of the Juggled files they uncompress
automatically. If you use the additional files optionsin Jugglor it will also compress these files too.

237. 1 am trying to change the title bar caption but can't find this option anywhere in the application
or help. It just defaults to the flename. Can you point me in the right direction?

The New Juggled filename will be the name of the title bar caption. Change this to whatever title bar you
want.

238. The cursor keeps appearing in the middle of the Projector file when playing. It's annoying as |
always have to move it out the way. Can | do anything about this?

Yes you can. You can choose to hide the cursor in the 'Setup Settings' tab, stopping the cursor from
appearing over the top and in the middle of what you are viewing.

239. Can | read and write to the Windows Registry using a Flash Projector?
Y esyou can.

Please look at the Jugglor Help File -> Additional Features -> Read/Write to the Windows Registry

P ease download the examplefile.

240. How big can a Flash movie be?
Read this

http://kb.adobe.com/sel fservice/viewContent.do?external | d=tn_14437& sliceld=1

241. 1 am using the getURL command to download a zip

getURL(http://mww.mysite.com/myfile.zip', " _blank™);

This works fine, then sometimes the dialog that pops up goes behind the projector file.

How can | stop this ?

You can by just putting the Flash projector through Jugglor and Jugglor will take care of the rest. No
specia commands needed.

Look at the examplefile given.
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242. Can | use the GETURL to open a local file? Something like a pdf file?
Y esyou can, just specify the filename
i.e.
getURL (‘file.pdf'," _blank");
Thiswill open the pdf filein abrowser.
See the example below

The only disadvantage of using this method isin IE it will ask the user if they want to show the active
content... etc. Depending on the user's security settings.

To avoid this and any browser issues we recommend you use JStart, which will open up in the default
application rather than the browser.

Look here
http://jstart.flashjester.com
and the online FAQ, you will have to use the LOCAL command.
http://flashjester.com/?section=fag& cPath=14 56 26
243. We cannot find a way to create our own .Ing-files in Jugglor. We need the install dialogues to

be in Greek and Swedish along we the default languages. WeA¢a,-4, ¢ve tried all text editors we
can think of, but no luck.

Yes, surethisis possible.
Open Jugglor and create a new project.

1. Build -> Build Installation

2. Dialogs -> Language -> Press the + button

3. Enter anew namei.e. Greek and press OK.

4. Make sure Language is selected that you have created.

5. Now double click on any text in the work area where is shows an image of the Installation sections.
Change the text and press OK.

5. Save the project. It has now create a*.Ing file in sub directory called \Language where the project has
been saved.

6. Now if you want this language file to appear on al new projects, then copy this*.Ing file to

C:\Program Files\FlashJester\Jugglor v2\Language
7. Now start anew project and it will appear in the Language Dialog when you press the + button.

That'sit.
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244. 1 am using the Additional Files section to add SWFs, but the Juggled file won't load them. |
thought they were included in the Juggled file?

Y es, anything you add into the Additional Files section of Jugglor will all be compressed into the final
Juggled exefile.

Now when you run the Juggled file it will uncompress all the files into the Users Temp directory. This
may take a few seconds to uncompress.

Thisisthe Jugglor initialisation process. If you have the loadmovie command on the 1st Framei.e.
loadmovie(myfile.swf,1);

then it will not load due to the initialisation process. So in order for this to finish we ALWAYS
recommend that you put the LoadMovie command on the or after the 5th Frame.

Please try this.
Also.

1. If you have the SWF files in a sub folder then don't forget to create the sub folder in the additional file
section. Y ou can do this by pressing the "Create a New Folder" button.

2. If the SWF files are large then set the Progress bar option on when extracting
Build -> Message during extract

Thatsit redly. Giveit ago.

245. My LoadMovie command on my Flash Projector was working fine until | put it through Jugglor.
What happened?
I have the following:

loadMovie("library\20060916154752.jpg");

Ok you have to add local_25 in front of the filepath and change the back slashes (\) to 5C if you're
using any.

o

loadMovie("library\20060916154752.jpg");

will now be

loadMovie("local _25library _5C20060916154752.jpg");

and
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loadMovie("myfile.swf");

will now be

loadMovie("local_25myfile.swf");

IMPORTANT : Remember also not to add the loadmovie command on the 1st frame, add it on or after
the 5th frame.

For more information about this go to

Jugglor Help -> Advance Techniques -> Using LOCAL %

246. Why doesn't my LoadVariable command work after | juggled the Flash MX/2004/CS3 projector

file?

This is because the way Jugglor works. Jugglor packs the projector file and any additional files into the
final Juggled file. When you double click on the Juggled file it uncompresses into the Windows Temp
directory. Hence the LoadVariable will not work as it's looking for the text file in the Windows Temp
directory. So we have the following options

Jugglor -> Additional files

Please add the text file in the Additional Files section and that will solve your problem.

In addition to this you can use our newest feature

LoadVariable LOCAL%

Where you add LOCAL% to the beginning of the file you are about to access. So if you have the
following

loadV ariablesNum(" INetCheck.txt", 0);

then this should now be

loadV ariablesNum("local_25INetCheck.txt", 0);
Where 25 standsfor %

the same applies to

loadV ariables("data.txt", _root.vars, ")
whichis

loadVariables ("local_25data.txt”, root.vars, "")
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The LOCAL_25 works with any ActionScript method or function that deals with afile
path.

IMPORTANT : Please remember not to use the loadvariables command in the first 10 frames (or so),
because the Jugglor will not be recognize the prefix.

Please download the example file to see how LoadVariable and LOCAL_25 work.

247. | have gone through building a projector file, but it still does not link to my external swfs. They
are added as additional files.

Add the LoadMovie command after the 2nd frame and not the first. This might help you.

See the exampl e file below.

248. | am having problems using the new LoadMovie command with LOCAL%.
| had the following
on (release) {
_root.myMovie.loadMovie("mySWF_1.swf", 1);
}
When | click myButton the movie loads and runs GREAT......
Now | would like to modify the above code so Jugglor can do it.
Here is my modified Jugglor code:

on (release) {
_root.myMovie.loadMovie("local_25mySWF_1.swf",1);

}

This doesn't work. What am | am doing wrong?

Please remove all UNDERSCORES from the filename before you start to add the local_25 command.
The underscore will confuse Jugglor and will not recognise the statement.

So you should rename the SWF to
mySWF1.swf
and then you will have

on (release) {
_root.myMovie.loadMovie("local_25mySWF1.swf",1);

}
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249. How do | access My Documents folder ? | have a text file in there | want the user to read.
Please look here

http://www.flashjester.com/index.php?section=fag& cPath=28 394260

250. How can | align my Flash file just on the 1st Monitor rather than stretching on both my monitors
?

In Jugglor go to

Jugglor -> Setup Settings -> Windows Settings -> Alignment -> Align to primary monitor.
251. How | can get the resolution of a Window?

Y ou can get this by using Actionscript

System.capabilities.screenResolutionX and System.capabilities.screenResolutionY

252. | have 2 monitors hooked up and | want to run my flash .exe file (with a fullscreen
FSCommand) on Screen 2 instead of Screen 1 without changing the display settings. Does anybody
know how to do that?

The only way to do thisisto use athird party tool like ours.
FlashJester Jugglor supports multi-monitor using your Flash Projector
Download a FREE evaluation copy from

http://www.jugglor.com

and then go to

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support ->
Show the window on Monitor No -> 2

Thats it, no coding required.

253. | am making an autorun CD to open a flash .exe file, which has one movie clip playing inside.

Currently, | have created a flash project of the size 800*600 set fscommand to fullscreen and
Stage.scaleMode = "noScale"; so that my movie does not get pixelated if the screen resolution is
more than 800*600.

Since my major concern is to prevent the movie from getting pixelated | have created a few more
applications with different stage sizes like 1024*768 and
1208*1024.
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Now what | want is that once the autorun CD starts it detects the user screen
resolution and based on that opens the corresponding .exe file. | have the
javascript to detect the screen resolution, but what i don't know is where should |
place that script and how do i call the .exe file?

Y ou can get this by using Actionscript

System.capabilities.screenResolutionX and System.capabilities.screenResolutionY

Another option would be to use our third party tool Jugglor to automatically set the users display to say
800x600 or 1024x768, this means you will need only one Flash exe. Once the Flash file has been closed
it will then set the screen resolution back to the original resolution. Similar to the way games work.
Download a FREE evaluation copy from

http://www.jugglor.com

Jugglor -> Setup Settings -> Windows Settings -> Full Screen Resolution

Try it.

254. | need to show my flash movies in full screen mode spread (spanning across) across multiple
monitors. Does any of your software allow for this?

Y es FlashJester Jugglor allows you to do this.
Download an evaluation copy from
http://www.jugglor.com
then go to
Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support -> Use (Stretchto) all monitors
Build the project and thats it.
255. Is there Dual monitor support in Flash?
Flash doesn't support Dual Monitor.

But FlashJester Jugglor supports Dual Monitor with Flash files. You can have different Flash files
appear on dua monitors and also you can Clone Monitor the same screen on all monitors.

Download a FREE evaluation copy from
http://www.jugglor.com
and go to

Setup Settings -> Windows Settings -> Multi monitor Support
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Try it and seeit in action.

256. Is the Mouse Wheel supported with Jugglor?
Jugglor itself doesn't support the Mouse Wheel but the new Flash 7 Player does.

Read below

http://www.communitymx.com/content/article.cfm?cid=A3BDC567C4BE81CE

257. | want, to get information from an external source and store it in a local txt file, so the latest
price info can be used when offline. Any ideas as to how this can be done?

Yes, just use the LoadV ars object.
Something like this
var my_lv:LoadVars = new LoadVars();
my_lv.onLoad = function(success.Boolean) {
if (success) {
trace(this.toString());//show me the text
//do soemthing else here like load the text into a text field
} else{
trace("Error loading/parsing LoadVars.");
}

|
my_lv.load(" http://www.yousite.com/yourtextfile.txt");//just use the URL to your text file here
Or yOu can use some server side scripting i.e php, asp etc.

Once you have read the text, you can either save the text into a text file using JSave or JSystem -
Savetofile command

http://jsave.flashjester.com

http://jsystem.flashjester.com

Or even simpler use the Read/Write to the Windows Registry feature
See

Jugglor Help -> Advanced Techniques -> Read/Write Windows Registry
That will help you get started.

258. Can Jugglor use the LoadMovie command to get SWF files from the internet?
Y es sure you can. Just specify the URL,
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i.e
loadM ovie(" http://www.flashjester.com/downl oad/temp/test.swf",1);

See the example below to seeif isworking.

259. I'm having trouble with Jugglor 2 pro, | have it setting the screen resolution of user's computers
to 800x600, on some machines this works fine, on others (laptops) it seems to centre the flash in the
middle and fill the rest with black - it tries to force the screen resolution (it flickers on and off) then
just leaves it the same. The screen resolution was at 1024x768 to start with, and has no problems
displaying at 800x600 if you set it manually.

Is there another way to do this? or is there an option/setting i have missed?
Please try to update the video drivers on the laptop.

260. | have a Flash Game file that | want to be displayed in 16 bit color and not 32 bit for speed
enhancement. Is this possible ?

Y esyou can do thisin Jugglor.
Goto

Jugglor -> Setup Settings -> Windows Settings -> Full Screen Resolution -> Select Size of Screen ->
Force 16 bpp

Force 16bpp - Forces the color resolution to be set at 16 BitsPerPixel - Color quality to 16 bit. Used by
game developers to speed up the FPS.

261. | have more than 2 monitors | want my Flash file to be displayed on. Does Jugglor support this?
Y es Jugglor supports Multi monitor in Flash. See

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support -> Use (Stretch to) all monitors

262. | have Flash MX on my machine but | want to create a Flash 5 Projector. How can | do this
without reinstalling Flash 5?

First make sure you have Flash 5 on the machine. Then locate

\Program Files\Macromedia\Flash 5\Players\FlashPla.exe

Open it and then close it. This will set the Flash 5 Player as default. Click on an exported Flash 5 SWF
file from Flash MX and now it will open up the Flash 5 player. Then go to File -> Create Projector. Now

if you would like to create a Flash MX Projector just use the Publish command and check the Window
Projector checkbox.
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263. For FSCOMMAND - Exec to work with Flash MX, | heard you have to create a FSCOMMAND
directory. Is that true ?

If you are using Jugglor and the JTools then you don't need to create the FSCOMMAND directory.
Jugglor will take care of this.

Now if you are using the JTools without Jugglor then yes you do. Please read the JStart JWeb JEmall
help file for further information.

See the JStart Jweb Help file -> Setting up JTools link -> Setting up for Flash MX
and please take alook at the examples provided

:\Program Files\FlashJester\JT ool s\Examples

264. 1 am now using Flash MX Projector files, but none of my previous JTools links work? Why is
this?
Thiswill not work due to the changes made by Macromediain Flash MX.

You will need to recreate the links by pressing the Copy button again in the JTools section and paste
accordingly into the FLA file and export it back as a Flash M X/6 Projector file.

Remember you will not need to create the FSCOMMAND directory for the JTools to work, Jugglor has
taken care of this.

265. Where can i get the latest Flash Projector files from? | want to update my Flash Players for my
current version of Flash.

The Flash Players are not automatically downloaded by Flash you have to do this yourself.
Go here

http://www.adobe.com/support/flashplayer/downl oads.html

266. Can people tell its a projector file?
Using Jugglor's many features, your Projector file can be disguised so well that no-one will know it isa
Projector file. With options like changing the icon, the user will click on it to start the Projector file
thinking that it isit's own program. Then, by choosing how your Projector file is displayed you can put it
in awindow, changing the caption, size and removing the right click and main menus.

267. What is a projector file?
Using Macromedia Flash 3, 4, 5 or MX, you can create animations and export them to Shockwave Files
(SWFs). The SWF can then be made into a stand-alone Projector file, a single executable file created by
opening an SWF in the Shockwave player and then choosing " Create Projector” from the file menu. Also
in 4 (5 & MX) you can go to -> File -> Publish Settings -> Windows Projector(*.exe).Go to
www.flash.com
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268. We have some sensitive data and wish to keep these files away from the end user in our Flash
Projector. We don't want our users hacking into this data from the Flash Projector or SWF file. How
can we protect oufiles, whether they be a SWF, FLV, XML, JPG or TXT file?

Please look at the

NEW Security Feature - In Memory File Support
http://www.flashjester.com/index.php?section=tricks_jugglor2_security
then once you have Jugglor on your machine

Jugglor Help -> Sections -> Additional Files -> Additional File -> NEW Security Feature - In Memory
File Support

This will enable you to add ANY sensitive data that you have into the Additional Files section of
Jugglor. Thiswill then compress all these filesinto ONE exe.

When the Juggled file is executed all assigned memory files will be in memory and accessible to Jugglor
only. All other non memory files will be uncompressed into the Windows Temp directory.

Thiswill give security to your Flash Projector and Flash SWFfile.

Please download the example file below, it shows an SWF and XML file being loaded while in memory.

269. How can | add additional security features to my Juggled file ? i.e Give x amount of licenses
etc.

Take alook at

PC Guard for Win32 on
http://www.sof pro.com/

and

Silicon Reams - Armadillo Support - Realms delivers a new technology that drives global sales while
protecting your digital assets with SoftwarePassport.

http://siliconrealms.com/index.shtml
their software works with Juggled files.
It gives you MUCH more control and security features you can ever imagine.
270. Does SharedObjects work with flash files once they have been Juggled?
YES, it does. From the example we have tried it works just like it doesin a projector file.

When you create a new projector or Juggled file the objects will create a new cookie for that specific
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file, so it will not have variables from a previous SWF or Projector file, you have to use that exact file
where you stored the variable to.

Please download the example file to see it working with Jugglor.

Another very good example of SharedObjectsis

http://www.adobe.com/devnet/flash/arti cles/addressbook.html

from Colin Moock (a Flash Guru)

IMPORTANT - Hint :

For people using SharedObjects, it is critical that you specify a value for the optiona localpath
parameter to the getL ocal method.

For example, use

so = sharedObject.getL ocal ("objectName”, "/");

instead of

so = sharedObject.getL ocal ("objectName™);.

It'sasmall but very important difference. Here'swhy...

To avoid name collisions, Flash looks at the location of the movie that is creating the shared object
(normally the host domain and directory). This is done so that shared objects with the same name will
not conflict with another.

To find out more on Shared Objects read

http://www.macromedia.com/support/flash/action_scripts/local_shared object/

271. Does SharedObjects work with Projector files that are Juggled ?
Yessureit will work the same as a Projector or SWF file would work.

See the example file below.

272. Can | skin a Flash file?

Y es Jugglor allows you to skin your Flash files. We call it the Border Skin Designer. Here you can select
from 100+ pre built skin files or create your own, it's very easy to use.

Please read the help file on this section.
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Jugglor Help -> Sections -> Setup Settings -> Windows Options -> Border Skin Designer

273. Where are the skin files ?

They are located at
C:\Program Files\FlashJester\Jugglor\Border Skins\Border Skin Files
You will aso find the source files here
C:\Program Files\FlashJester\Jugglor\Border Skins\Source
This gives you an idea on how the skins files were created.
274. Is it possible to use transparency in Flash?
Yesit'spossibleif the transparent color in the Flash fileis just one colour and not different shades.
Go to the Flash Details Section in Jugglor

If you wish to add Dynamic Shaping / Transparency features you must select the Flash SWF file as this
will not work on the Flash Projector (.exe) file.

Jugglor createsit's own executable file which you can use.
ActiveX Settings

Read the Help file

Jugglor Help -> ActiveX Settings

Y ou can find many transparency examples here.

Jugglor -> File -> Open Packaged Project

C:\Program Files\FlashJester\Juggl or\Examples\Ambulance
C:\Program Files\FlashJester\Juggl or\Examples\Dynamic Shape Commands Example 1
C:\Program Files\Fl ashJester\Juggl or\Exampl es\Petz
C:\Program Files\FlashJester\Juggl or\Examples\Slug
C:\Program Files\Fl ashJester\Juggl or\Examples\Throwing Clock

Thiswill help you get started.
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275. My transparency is not working on my Flash file? Why?
Ok first of al please make sure you are using Jugglor v3. It support CS3 and Vista.

Also please please make sure you have the latest Flash 9 player on your machine.
Check what version you have here

http://www.adobe.com/products/flash/about/

Make sure you have 9.0.47.0 or above.

If not please download the latest here

http://www.adobe.com/support/flashplayer/downl oads.html

276. How can | trap the Escape Key in Jugglor?
You haveto use

fscommand(‘trapallkeys, 'true’);
See

http://kb.adobe.com/selfservice/viewContent.do?external | d=tn_14280& slicel d=2

Please download the example file to seeiif it's working.

277. How do | use Jugglor and JEmail together with Flash 5?

Jugglor will automatically add JEmail.exe into the Juggled file when you create the JEmail command in
the JTools section in Jugglor.

Remember once you have copied and pasted the Flash 5 command from the Jugglor -> JTools section
and then published the Flash 5 projector, the next step is to Patch the projector file using the Patch
command.

See Help file for more details and download the example below.

278. How do | use Jugglor and JEmail together with Flash MX?

Jugglor will automatically add JEmail.exe into the Juggled file when you create the JEmail command in
the JTools section in Jugglor.

Then just press the copy button and paste it ino the FLA file and publish it as a projector file and use this
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in Jugglor.

See example below.

279. What should | use as a character for a line break inbetween
my variables? \r does not seem to work.

Hereisan example

on (release) {

inputemail = "sales@ryko.com’;

inputsubject = "Ryko Color Designer"”;

inputbody = ("Name: "+userName.text+"\rAddress: "+userAddress.text+"\rCity:
"+userCity.text+"\rState/Prov: "+userState.text+"\rZip/PC: "+userZip.text+"\rCountry: );

function EncodeForJugglor(x) {
Result ="";
for (i=0; i<x.length; i++) {
¢ = x.substr(i, 1);
if ((c=="")or (c>="d) and (c<='Z) or (c>='A") and (c<="Z")) {
Result +=c;
} else{
hex = ord(c).tostring(16);
if (length(hex) == 1) {
hex ='0'+hex;
}
Result +=" '+hex;
}
}
return Result;
}
fscommand(“exec"”, EncodeForJugglor(JEMAIL.EXE  \"'+inputemail+\" \""+inputsubject+'\"
\""+inputbody+\""));
}

or if not using the EncodefForJugglor function
i.e
"Thisisline one\rThisisline two"

P ease download the example file to see it working.
280. | have developed a flash based drawing package for my company.
The users can create their own drawings using this package, but | have no way to let them save

portions of screen as image files in their hard discs for exchange. Every user using the flash based
drawing tool should be able to save any number of drawings as image files on their machines.
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Will JPrintor enable me to achieve this functionality?

Y esyou can achieve this using JPrintor and Jugglor.

Please look at the example files that come with JPrintor. They will give you a better understanding of
how it works.

281. | have a problem using JPrintor and Jugglor with MX

| need to save as a file, rather than print, but make sure
this saves to the same directory that the projector runs from.

Here's the code:
filesave="screenshot.jpg" rect=(flashrect) title="Screenshot"

Can you help?
Y es you need to use the LOCAL % command.

So it now should read
filesave="local %screenshot.jpg" rect=(flashrect) title="Screenshot"

Please take alook at the examplefile.

282. How can | hide the JPrintor program from the user?

You can use Jugglor. Thisis another program in the FlashJester series that can take your Projector files
and turn them into fully stand-alone programs. It can change the icons, hide the right click menus, turn
off the sound, as well as being able to include al the programs it uses (including the JTools) in the one
executable file. For more information about Jugglor, take a look at the FlashJester website at
http://www.jugglor.com and download the examplefile.

283. Can you please show me an example how to use the fullscreen option in JPrintor with Jugglor
?

All you do is select

Jugglor -> JTools -> JPrintor -> Screen Rect -> All screen

Please ook at the example file provided.

284. How do | use the command line parameters with my external application using Jugglor and
JStart?

Create the JTool command in the Jugglor in the JTools section

File
externalapp.exe

Page 80



FlaShJeStel' Flashjester FAQ.

the ultimate place for flashing tooils

Arguments
'hello’

then copy and paste into the FSCOMMAND EXEC command in the FLA file.
The externalapp.exe is actually inside the Juggled file, added in the 'Additional Files section in Jugglor.

To load an external app that resides in the same directory as the Juggled file then use the LOCAL%
command

i.e

File
local %external app.exe

See the exampl e file provided.

285. | would like to keep my JProWeb files as one exe. Is this possible?
Y esyou can use

Jugglor
http://www.jugglor.com

and JProWeb together.

Please look at the example file below.

286. You need to go the section below
FAQ -> JTools -> JSave
http://www.flashj ester.com/index.php?section=fag& cPath=28 39

287. 1 want to make a rescource CD and we want to build it in flash and be able to open and also
download, from the CD, pdf and doc files etc.

We have to update this CD quite often so we will use an xml file to store the names and info and just

re-burn a new copy. If | use your product will | have to modify the SWF/EXE everytime | update my
xml file?

We recommend you use Jugglor and JStart together.
Jugglor
http://www.jugglor.com

Will give you more control of the Projector file. i.e customise it, not alow the files you open to go into
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the background, stay on top etc.

JStart
http://jstart.flashjester.com

Will allow you to open up the files from the CD.

To see Jugglor and JStart working together please ook at the FAQ and the examples given
http://www.flashjester.com/?section=fag& cPath=14 56 26#268

Now if you want the user to be able to save these files from the CD onto their machine use JSystem
http://jsystem.flashjester.com

and the copyfile command.

Look at

http://www.flashj ester.com/?section=fag& cPath=28 60#274

Download the evaluation copy and look at the example files given.

If you are using XML files, first read this

http://www.flashjester.com/?section=fag& cPath=14_59

Yesitspossible.

No you don't need to modify the EXE just the XML file. If you keep the XML file inside the Juggled file
(i.e Usethe Additional Files section in Jugglor) then you just need to rebuild the project.

Simple.
Hope this helps.

288. How do | launch a PDF file that doesn't go behind the maxmised projector file when | launch it?

Ok, you will need to use Jugglor and JStart together, to have better control over the Projector and PDF
file.

Also set
Jugglor -> Setup Settings -> Don't go to foreground on click.
The PDF file can be inside or outside the Juggled file.

Please download the example file below.

Page 82



FlaShJeStel' Flashjester FAQ.

the ultimate place for flashing tooils

289. | need help using JStart and Jugglor, help?
Please read the following Help file

C:\Program Files\FlashJester\JT ools\JStart Web_JEmail.hlp
Setting up JTool links -> Using Jugglor

and also read

C:\Program Files\FlashJester\Jugglor\Jugglor.chm

Advanced Techniques -> Using LOCAL% -> Using LOCAL % to launch other
applications

Download the example file below

Thiswill help you.

290. | cannot get the FSCOMMAND Exec to work with my Flash MX file, | want to run a setup.exe
and a pdf file?

Due to the changes in Flash M X, you now have to create an FSCOMMAND directory. Jugglor creates
this directory automatically for you.

Now you can do 1 of 2 things.
1. Add the additional file setup.exe into the Juggled file in the Additional files section in Jugglor.

2. Or if you don't want to add the exe file into the Juggled file then you will have to use JStart with the
LOCAL% command and Jugglor together. Download the trial version of JStart from

http://jstart.flashjester.com

Please take alook at the help file and example files provided.

Start -> Programs -> FlashJester -> JTools -> JStart_ JWeb_ JEmail.hip
Setting up JTool links -> Using Jugglor

Y ou can also read the Jugglor Help file

Start -> Programs -> FlashJester -> Jugglor -> Jugglor.hlp

Advanced Techniques -> Using LOCAL%

Please download the example file below to see how it works.
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291. | need to generate, from Flash MX, an exe file that will be able to open several PowerPoint
Presentations for a client and keep the exe file still running in the background if the PPS is closed.

Yes you can use Jugglor and JStart together, to have better control over the Projector and PowerPoint
file.

Y ou will need to publish aFlash Projector file from Flash.

Flash -> File -> Publish Settings -> Windows Projector
Download a copy of Jugglor from

http://www.jugglor.com

then go to

Jugglor -> Setup Settings -> Don't go to foreground on click.
The PPS file can be inside or outside the Juggled file.

Use the LOCAL% command if the file is outside the Juggled file.
For more info about LOCAL % see

Jugglor Help -> Advanced Techniques -> Using LOCAL%

Also

Start -> Programs -> FlashJester -> JTools -> JStart_JWeb_JEmail.hlp
Setting up JTool links -> Using Jugglor

Please download the example file below.

292. Can we open any file dynamically? Say a PDF, as we have over 100 PDF's and don't want to
create ini and jstarts.exe each time?

Yesthisis possible, you can ONLY do this by using JStart and Jugglor together.
Few Points.

1. When you use JStart and Jugglor together then you don't need to useini or jstart.exe files, or create an
fscommand directory anymore, it's much easier.

2. You will need to use the LOCAL% command with JStart to locate the LOCAL directory, i.e the
directory where the final projector file (juggled file) is stored to locate the PDF file.

For moreinfo read the Jugglor Help file

Jugglor Help -> Advanced Techniques -> Using LOCAL%
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3. For dynamic variables you will need to use the EncodeForJugglor command
Jugglor Help -> Advanced Techniques -> EncodeForJugglor

4. If you have a SPACE in the directory or file name then you must replace it with "1
5. Use/ and not \ for file paths.

6. Use the JTools help file to help you create the JStart command

Program Files\FlashJester\JT ool s\JStart_JWeb_JEmail.hlp

JTools Settings -> JStart - Jugglor and JStart Examples

7. Create al JTool commands in Jugglor -> JTools section. Add any statement just to let Jugglor know
to add JStart.exe inside the final Juggled file.

Now look at the example file provided.

Hope this helps

293. We have a problem in printing 195 PDF documents from a flash MX projector, and nobody
wants to hardcode this, so is there a way to dynamically create these links

Yesthisis possible, you can ONLY do this by using JStart and Jugglor together.
Few Points.

1. When you use JStart and Jugglor together then you don't need to use ini or jstart.ex files, or create an
fscommand directory anymore, it's much easier.

2. You will need to use the LOCAL% command with JStart to locate the LOCAL directory, i.e the
directory where the final projector file (juggled file) is stored to locate the PDF file.

For more info read the Jugglor Help file

Jugglor Help -> Advanced Techniques -> Using LOCAL%

3. For dynamic variables you will need to use the EncodeForJugglor command
Jugglor Help -> Advanced Techniques -> EncodeForJugglor

4. If you have a SPACE in the directory or file name then you must replace it with "1
5. Use/ and not \ for file paths.

6. For Printing you need to add /print at the end of the JStart command. See
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C:\Program Files\FlashJester\JTools\JStart_JWeb JEmail.hip
JTools Settings -> JStart using the Print Command

7. Create all JTool commands in Jugglor -> JTools section. Add any statement just to let Jugglor know
to add JStart.exe inside the final Juggled file.

Now look at the example file provided.

Hope this helps

294. | am having problems using the LOCAL% command with Jugglor. Do | need to include the
JStart.exe in the project ??

If you create the JTOOL command in Jugglor -> JTools then Jugglor will automatically add the JTool(s)
you have used into the Juggled file.

So you don't need to add JStart.exe into the Additional Files section nor the root of the Juggled file.
It doesn't matter whether you are using Flash 5 or MX it works the same way.
Download the demo file to see this working.
295. How can | create a function in my Flash MX file to open several pdf files dynamically?
Y ou will need to use

JStart
http://jstart.flashjester.com

and

Jugglor
http://www.jugglor.com

Then please download the example file below and take a careful look at the FLA and the * jjf file.

Y OU MUST add the EncodeForJugglor function to encode the command line.

296. Can you show me how to use the Jugglor and JStart to launch a browser that has links to files
on my CD-ROM?
Please see the example below

297. | have one projector file (main movie.exe)which loads external swf's (all in MX). One of them
contains a few Word documents. I've tried to use JStart to load them,but without result.
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Does the Jstart work with external SWF (not EXE) files, that are compressed into one projector file
(with Jugglor)?
Y es. See the example below. It launches a PDF file within the Juggled file from an external SWF which
was added in the additional files section in Jugglor.

298. | have used Jugglor to launch an InstallShield 'setup.exe’ using fscommmand exec
successfully. Now, | need to launch 2 different InstallShield programs from the same Projector file
(both named 'setup.exe’).

When launching 1 program from a projector file | place the 'setup.exe’ in the Jugglor root. When
trying to launch 2 programs, | seperated them into their own subdirectories (since the InstallShield
setup files have the same name.)

In my Flash movie, | used the fscommand exec parameters ‘/folderl/setup.exe’ and
‘folder2/setup.exe’.

However, my juggled file will not execute either program unless the executable is in the Jugglor root.
Am | doing something wrong or is this an impossible task using Jugglor?

PS: | also tried '../folder/setup.exe' , "./folder/setup.exe’,

and 'folder/setup.exe’ b/c | thought | might have specified the wrong path. | also tried each of the
three current directory settings with each scenatrio.....Nothing works!

Currently you use

on (release) {
fscommand(“exec", "c2c\\setup.exe");

}

Thisiswrong for Flash M X, the right form of the command would be:
fscommand(“exec", "c2c_5Csetup.exe”);

"\" iscoded as" 5C"

299. | am having problems using Flash MX, Jugglor, JStart and the Current Directory?

The problem is that | don't want to add the SWF files | am using in the project inside the Juggled file.

Do | use the LOCAL& or the Current Directory feature ?
Thisisalittle more tricky.

1. You have to use Ini files but you don't have to create an FSCOMMAND directory.
2. Set Current Directory to the 3rd option - The Juggled exe file location will be the current directory.

3.Place the orginal projector file in the same directory as the Juggled file.
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Download the example file to see how it all works.

300. A 'Juggled' intro FLASH MX Projector file which loads the first presentation screen (with menu)
as an SWF file which is loaded from a button using the 'loadMovieNum' command into _levelO.
From this, subsequent screens are loaded from the menu into various other levels using the
‘loadMovieNum' command.

| therefore have an SWF file which is loaded into _level20 (essentially a
'popup’ over the main screen at _levelO).

| have a button in this _level20 swf file from which | need to open the PDF
file.

All these SWF files are at the root level of the CD.

Can you please advise as to the best way to get these PDF files to open.
Is there an issue with using JSTART in SWF's loaded into different levels?
Do | have to put the PDF files in a seperate folder?

Do | have to use the fscommand folder?
Do | have to use .INI files?

Ok, we need to clear up afew things.
Lets start fresh.
Create anew directory called CD.

Add the Juggled file in there, (so change the build path in Jugglor) and all
the additional SWF's and PDF filesin there.

DO NOT ADD THE ORIGINAL PROJECTOR IN THERE, asthiswill activate the current
directory feature.

We will use the new LOCAL% command in the 'loadM ovieNum'
See

Jugglor Help -> Additional Features -> Using the LOADMOVIE command with
Jugglor

Read this section and change your FLA's to add the LOCAL % command.
i.e

loadMovieNum("loadstart.swf", 1);

will be
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loadM ovieNum("local _25loadstart.swf", 1);

IMPORTANT: In order for the LOCAL % syntax to work, the LoadM ovie command
should not be in the very beginning of the animation, because the engine

hooks would not be active yet.

IMPORTANT !l PLEASE DO NOT USE UNDERSCORCE'S _IN YOUR FILENAMES ASTHIS
WILL CONFUSE JUGGLOR. SO PLEASE REMOVE THEM.

Then in the loadstart.swf add

JSTART _20loca_25jstart.pdf

which was created in Jugglor -> JTools

local %j start. pdf

and press the copy button and paste it into the loadstart.fla.

> |sthere an issue with using JSTART in SWF'sloaded into different levels?
No.

> Do | haveto put the PDF files in a seperate folder?

No, you can if you want. Just add the folder's path into the command.
> Do | have to use the fscommand folder?

No, not if you use Jugglor and any of the JTools.

> Do | haveto use.INI files?

No.

Download the example file and see how this works.

301. I am trying to Juggle a Flash projector file that is using an fscommand to run an external
executable file.

The projector file runs fine and opens the executable file before Juggling (the .exe file resides in an
fscommand folder).

However when Juggled, the .exe does not launch. | have added the .exe to the additional files, with
and without a folder called "fscommand”, to no avail.

Add the file inside the Juggled file using the Additional Files section in Jugglor.
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Thereisno need for the FSCOMMAND directory.

Then in the Jugglor -> JTools section Add

JStart nameofap.exe

Press the copy button and paste it into the FLA. Publish it and useit in Jugglor
See examplefile.

302. Why doesn't the patch command work with Flash MX files?

Y ou don't need to patch Flash MX projector files. We are using a different approach here in Flash MX.
Y ou only need to patch the Flash file if you are using Flash 5.

303. | have two CD type marketing pieces created to work separately.

Now, | would like to create a splash screen or one CD that gives people that use the CD the
capability to view one or the other.

How do | go about doing that? | have Jugglor Pro 2 and am using flash2004

You would create one Flash Projector file (call it CD1) that has menu options to execute the 2 main
Projector files (CD2 and CD3).

You bring CD1 into Jugglor, then go to the JTools sections of Jugglor and create a JStart link to open
CD2 and CD3. Y ou will have to use the LOCAL% command with JStart.

For moreinfo read this

Jugglor Help -> Advanced Techniques -> Using LOCAL% -> Using LOCAL% to launch other
applications

Also there is a step by step instruction on
JStart IWeb JEmail Help -> Setting up JT ool links -> Using Jugglor

Download the example file to see aworking version.

304. I'm having a bit of trouble using JSTART and Jugglor when there's a space in the filename. I'm
using a command line ZIP tool that takes in 2 parameters - a name for the zip file to create, and a
folder to zip. It is launched like:

n ll*ll

zipper "zipfile

The file "zipper" exists on the desktop (for example) which means | have to use the JSTART
command:
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fscommand('exec’,_root.EncodeForJugglor(JSTART '+folderPath+"\\zipper "zipped" "*"));
When this command runs | get an error popup that says "Could not open c:\documents".

Is Jugglor having trouble with the space or is the text in the popup limited? Either way - do you have
any ideas for resolving this?

Thanks.
We've found the problem

If something has to contain spaces, it must be enclosed with
We fixed the command:

fscommand(‘exec’,EncodeForJugglor('fJSTART "'+fol derPath+"\\zi pper" "zipped" el
[dir=""+folderPath+""));

That will do the trick.

305. | downloaded your free JWeb application (JHelp), and it works great, except when | try to
attach this method to Dynamic Text links inside of flash. The link is not viewable. Could you please
help?

Y ou will have to use Jugglor and JWeb together to get this to work.

Y ou must use the EncodeForJugglor function provided in the FLA.

By adding the JWeb command in the JTool section it just tells Jugglor to add JWeb inside the final
Juggled EXE.

Please take alook at the example file below and build the Jugglor Project file.

306. | have a Windows Projector (.exe) created in Flash MX and exported as Flash 6. | am using
Jugglor to remove the border/titlebar etc, and | am trying to use JWEB (from within Jugglor) for a
web link contained in the projector. However, it isn't working. | have seen some reference to using
.ini files for Flash 6 (?), and that | don't need to patch the movie. Is there a comprehensive list of
instructions to tell me how to do this.

If you are using Flash M X, Jugglor and JWeb then you don't need to
1. Useini files

2. Create a FSCOMMAND directory

3. Patch the Flash movie.

Jugglor takes care of this.

Please download the example file to see this working.
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307. Hi,

| have a projector in fullscreen mode where I'm using getURL("site.htm", charly) to pop the HTML in
a browser window.

Everything works fine, but when I click back on the projector the window with site .htm goes behind
it.

Is there code that | can use attached to a button in my Flash file which will set this window I've
popped up to have focus again?

Yesit'spossible. You will have to use Jugglor and JWeb together.
http://www.jugglor.com

http://jweb.flashjester.com

Jugglor has an option called

"Don't go to foreground on click™

Please take alook at this example provided.

308. When | click build | keep getting the message "Flash ActiveX Installer not found. Do you want
to find it yourself?" - should | be concerned? Doesn't it install automatically?

You can find the Active X installer here

C:\Program FilessMacromedia\Flash M X 2004\Players\Release\Install Flash Player 7.exe
or download the latest from the Adobe website.

http://www.adobe.com/shockwave/downl oad/al ternates/

Please read the Adobe Player Licensing

http://www.adobe.com/licensing/distribution/

Or you can select the

Use |E to download and install the control from internet

Which is amuch better solution.

309. How do | change the title caption of the Juggled file at runtime?
Jugglor v2 supports this feature.
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SetCaption
Allows you to change the caption of the Window Caption of the Juggled file.

Syntax - Active X :
fscommand(" setcaption”,"title");

Syntax - Projector MX:
We recommend you use the EncodeForJugglor function if you are using dynamic text or just use the
FSCOMMAND Generator if it'sfixed. i.e

fscommand(*exec" ,encodeforjugglor("j:setcaption:titl€"));

Syntax - Projector Flash 5:

fscommand(*exec","jcommand:setcaption:title");

Title* : The window title caption

310. Is there an event which notifies me when the ticker application is docking?

Yes, seethe
Jugglor Help -> Advanced Techniques -> Using FSCommands -> Dock Events
SetDockNotificationK ey

This command provides the ability to know where the Flash file is Docked to when using the Ticker

Settings .

Syntax - ActiveX :
fscommand(" SetDockNotification”,"Key,VariableName");

Key The variable will receive a number (as string) - the docked state when it changes Left="0";
Top="1"; Right="2"; Bottom="3"; Unknown (Quitting)="4"; Float="5";

fscommand('SetDockNotificationKey','N"); or
fscommand('SetDockNotificationKey','55") // 55 is the key ASCII code.
Which key will be used to signal a change in the docking state.

Please download the example fileto seeit in action.

311. Can | pass parameters to my Juggled file? | want to have 2 different versions without having 2
different Juggled files ?

Yesthisis possible.

See
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Jugglor Help -> Advanced Techniques -> Command Line Parameters to Juggled File
Command Line Parameters
juggledfile.exe /joe /bloggs

These parameters are then passed straight to variables at _root level when the Flash file starts. So, for the
above example it would be:

paraml = "joe"

param?2 = "bloggs"

Thiswill alow you to set different modes in the Juggled file rather than having different versions of the
Juggled file.

Syntax
JuggledFile.exe /paraml /param?2 /param3 etc...

Many parameters can be sent to the Juggled file. You can use the variable ParamCount to count the
number of parameters sent.

Please download the example file to see it working

312. How do | use the Balloon Message Hint fscommand in Jugglor with my SWF file?

Syntax - Active X :
fscommand(*balloon”,"message,title,icon,sound”);

Y ou must also set

Setup Settings -> Icon Tray -> Always sit in Icon Tray

See examplefile.

For further information see

Jugglor Help -> Advanced Techniques -> Using FSCOMMAND -> Balloon Message

Remember you only need to use the EncodeForJugglor function if you are using a Projector file rather
than a SWF file as your Flash file in Jugglor.

313. What is the minimum playback spec for a Flash MX Projector PC file?
The minimum requirements for the Flash Player are listed at

http://www.adobe.com/products/flashplayer/productinfo/systemreqs/
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314. | wonder if I can monitor the Juggled application being closed?

I'd like to present a "Some changes are not saved. Save them?" dialog if a user tries to close the
application.

Is it possible? If so, how?
Yesnow it is. We've added thisin Jugglor v.3.0.

Syntax - Projector :

Flash MX', MS2004, 8, CS3
fscommand("exec”,"jcommand_3aSetQuitNotificationKey_3axXXX't"");

or
fscommand(“exec","j_3aSetQuitNotificationKey 3axXXX't"");
fscommand(“exec","j:SetQuitNotificationKey: XX X™);

Syntax - Active X & Projector:

Flash MX2004, 8, CS3

Engine.SendJCommand(" SetQuitNotificationKey: X X X");

where XXX isthe ASCII number of the key (two or three decimal digits) - 3 is coded as 03.

After this, al quit commands will not be executed, but the above key will be sent to Flash. Then, if the
Flash script decides to quit, it can be done by

fscommand('exec','j_3aguit');

See the CS3 exampl e file provided below.

315. | cannot get the Quit command to work with Jugglor 3.0 and CS3 Projector files.
Please help.

Ok you can use
fscommand("exec", "jcommand_3Aquit");
or

fscommand(“exec", "j_3Aquit");

Take alook at the attachment example.

316. My XML file doesn't load when | Juggled my file using Jugglor?
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Y ou need to add the local% command infront of the xml filename.
So if we have

xml.load("saved.xml")

we need to add local 25

Xml.load("local_25saved.xml")

where local 25 mean local%

For more information on this please read

Jugglor Help -> Advanced Techngiues-> Using LOCAL%

and download the example file given.

That'sit.

317. I'm having a few *simple* problems loading an XML file into a Flash projector that has been
juggled.

I'm using the standard Flash methods for loading XML so that the contents are read in as an XML
object.

I'm using an absolute path to the XML file similar to:
C:\Inetpub\wwwroot\xml_files\topic_02.xml

When | compile and run the EXE I'm not getting anything being read in as the XML object although
the movie thinks that the content has loaded?!?

Any pointers?

Jugglor cannot read this path, the path needs to change dlightly.

Now because you are using the absol ute path

C:\Inetpub\wwwroot\xml_files\topic_02.xml

you don't need to use the LOCAL % command as this gives you the path of the Juggled file
so thiswill be

¢_3A _5CInetpub_5Cwwwroot_5Cxml_5Ffiles 5Ctopic_5F02.xml
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If you don't know the full path i.e the drive then you will have to use the local_25 command
so if the Juggled file was in structure in the following way then

juggled.exe
<data>
test.xml
then you will have
local _25data 5Ctest.xml
where
<gpace>is_20
(is_3A
\is 5C
_is_5F
more information about the local% can be found here
Jugglor Help -> Advanced Techngiues -> Using LOCAL%

or use the EncodeforJugglor function

http://www.flashjester.com/index.php?section=fag_search& search=encodefor#361

318. How can i dynamically load variables into JEmail i.e Email, Subject and Body and when | press
create it automatically creates an email using the users email client

Yesthisis possible, you can even load text inside the body now with Email.

See the exampl e file and build the project.

Remember to download the latest version of JTools -> JEmail v 1.4, first.
319. How do | add a minimize button to my flash projector file?

Y ou can use Jugglor to do this.

http://www.jugglor.com

Download a FREE evaluation copy and read the help file

Jugglor -> Advanced Techniques -> Using FSCommands -> Minimize

Minimize
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The Minimize command minimizes the projector player.

Syntax - Active X:
fscommand("Minimize");

Syntax - Projector MX:
fscommand(“exec","jcommand_3Aminimize");

Syntax - Projector Flash 5:
fscommand("exec","jcommand:minimize");

See the exampl e file provided below.

320. We're running Jugglor to package our player and movie swf. If | create the projector with
Jugglor it takes 100% of the processor but seems to play OK. If | create the projector .exe with
Flash8 or FlashMX or some other builders - it runs with a minimal processor (10-30%). Is there a
build option that might be affecting this or a way to diagnose why this is happening?

Y es that's right because the SWF file uses the ActiveX Player to play the Flash file and the Projector file
using the built in Flash player which is faster and better.

We only recommend you use SWF filesin Jugglor if you are using the transparency feature.

To read more on this see below

http://www.flashjester.com/index.php?section=tricks jugglor3_reason

http://www.flashjester.com/index.php?section=faq_search& search=fps#348
321. How do | add a maximize button to my flash projector file?

Y ou can use Jugglor to do this.

http://www.jugglor.com

Download a FREE evaluation copy and read the help file

Jugglor Help -> Advanced Techniques -> Using FSCommands -> Maximize

Maximize

The Maximize command maximizes the projector player.

Syntax - Active X:
fscommand(“fullscreen”);

Syntax - Projector MX:
fscommand(“exec","jcommand_3Afullscreen™);
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Syntax - Projector Flash 5:

fscommand("exec","jcommand:fullscreen”);

See the exampl e file provided below.

322. Why is my Juggled file running slower compared to my Flash Projector file? The FPS seems to
have dropped.

Let us explain by looking at the following
Normal Flash Projector runs 47-48 FPS
Juggled Flash Projector runs 47-48 FPS
Juggled Flash SWF runs 31-32 FPS

If you use a Flash Projector file in Jugglor then as you can see from the above the FPS is the same, asit's
using the Flash Player built into the Flash Projector. Juggling the Projector file has no effect on the FPS.

Now the Juggled Flash SWF uses an SWF file which then uses the ActiveX Engine i.e the Flash OCX
control to play the Flash File. Hence the small size. It is a known fact if you use the Flash OCX control
then the FPS is reduced.

So the conclusionis

1. That it's better to use Flash Projector and not an SWF in Jugglor.
2. When you bring a Projector file into Jugglor it doesn't reduce the FPS.

Hope this clears up afew things.
323. How can | see whether a Juggled file is focused or not?
Y ou can use the GetFocus command.
Jugglor Help -> Advanced Techniques -> Using FSCommands -> GetFocus

Also download the example file below
324. | have created a projector file in MX and | created a stand alone with

Jugglor but buttons with the following commands do not work.

on (release) {
fscommand("quit");

}

on (release) {
nextFrame();
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fscommand(“fullscreen”, "false");

}

on (release) {
prevFrame();
fscommand(“fullscreen”, "true");

}

The movie hangs up and | have to use Ctrl+Alt+Del to end it.
Y ou need to use our own commands see

Jugglor Help -> Additional Features-> Full Screen/Maximise and Minimize

and download the examplefile.

325. Can | use JShapor on its own?
No, JShapor only runs with Jugglor.

326. | have a juggled file that works on the machine that | created it on,but no other machine. The
error occurs after selecting a button to which a "Jstart command" is attached to open up a .pps file. |

am using Flash MX and Jugglor. Why would this error occur on every machine, and work perfectly
on one?

The error reads: Create MPEG 32 task- CMD is not successful.

On Microsoft's website it says that the error message occurs because the Mciqgtz.drv file is absent from
your system folder. The Mciqtz.drv is a driver for ActiveMovie. Or, if the installation of a third-party
party program, such as Apple QuickTime for Windows, makes modifications to the [mci extensions]
section in the Win.ini file. The [mci extensions] section determines the driver that the movie file format
uses. The native media player in PowerPoint must use the MPEGVideo driver, which makes a call to the
Mciqgtz.drv. If this setting has changed, the problem occurs.

http://support.microsoft.com/default.aspx ?scid=kb;en-us; 212409

327. | have Jugglor, and | am using the JSave feature to create a text file. The saving works fine in
Flash MX but when | convert the files
to Flash MX 2004 Professional it will not save. What has happened?

If you are using this statement in the EncodeForJugglor function
hex = ord(c).tostring(16);

then change it to

hex = ord(c).toString(16);

as MM have made afew syntax changes to their Actionscript.
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328. Can | use the LoadMovie command to load my SWF files without adding them into the Juggled
file?
Y es, we have just added support for the LOCAL % command.

If you want to load test.swf that is in the same directory as you Juggled file then you will have
something like this

LoadMovie("test.swf",1);

You will need to add local_25 in front of the swf filename
S0

The command to load test.swf now will be:
LoadMovie("local _25test.swf",1);

IMPORTANT ! PLEASE DO NOT USE UNDERSCORES IN YOUR FILENAMES AS THIS WILL
CONFUSE JUGGLOR. SO PLEASE REMOVE THEM.

Please read:

Jugglor Help -> Additional Features -> Using the LoadMovie command with Jugglor
and

Jugglor Help -> Advanced Techniques -> Using LOCAL%

Remember aso not to add the LoadM ovie command on the 1st frame, add it on or after the 5th frame.

329. Does Jugglor work with Flash MX 2004 Professional? | have used it in the past with Flash MX
with no problem.

Yessureit will work!! Try it for yourself.

330. I'm using Professional with JSystem and I'm trying to read a folder's contents which contains
unicode filenames e.g.A'‘a€3AApA«A»AeApA'AEZAeAYsAAYs - 2006-09-09 16-22-12.xml and
AcAjAcAVLA'aESAcAYAAZAAEIAAL - 2006-09-11 10-23-32.xml but the result that comes back is

Jugglor and JSystem do not support unicode names. It will work for russian strings if the windows
default system codepage is russian.

331. I want my Flash movie to be displayed on my second monitor. Does Jugglor support
Multi-Monitor in Flash?

Yesthisis anew feature introduced in Jugglor. See below for more information

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support
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332. I'm working on a Flash Projector CDROM with around 10 FLVs in Flash 8 Professional. These
FLVs are loaded dynamically into the SWF projector using actionscript and the FLVPlayback
component.

There are 10 buttons to load each movie into the same FLVPlayback instance. However, when |
click the button to view/load the FLV, sometimes the video does not display, but the audio can be
heard playing. Furthermore this is happenning erratically and randomly. It seems to get worse as the
CD has been playing for a longer period.

I've been told that this memory issue was solved with the release of Jugglor v2.2. I've downloaded a
trial version of Jugglor today, but all the FLV files are not loaded into the SWF. All your examples
and tutorials say we should use LoadMovie command, but in order to load FLV dynamically in Flash
8, | have to use this script:

flvPlayback.contentPath = "videos/01-intro.flv";

So should | and can | install your Jugglor upgrade to accommodate this script from Flash 8, or is it
simply a matter of using the CDROM% command and _5C to replace the path above?

Y es that's right you have to change the path so you have
<b>flvPlayback.contentPath = "videos/01-intro.flv";</b>

1. You need to add LOCAL_25 in front of the path to tell Jugglor to look in the local path. i.e the same
path as where the Juggled file has been launched from.

More on this can be found in

Jugglor Help -> Advanced Techniques-> Using LOCAL%

2. All forward slashes must be changed to backslashes so

\ and changethe\to 5C

3. You haveto, in the filename, change this syntax to _2D

so putting all the above together we will have the following :
<b>flvPlayback.contentPath = "local_25videos 5C01 2Dintro.flv";</b>

Try this.

333. I have the following
LoadVars.load("mytextfile.txt")

This was all done with MX2004 and Jugglor 2.1 and it all worked fine and dandy. I've upgraded to
Flash8 and the latest version of Jugglor and the text saving still works, but the loadVars bit doesn't -

Page 102



FlaShJeSteI' Flashjester FAQ. @

the ultimate place for flashing tooils

I've tried making a new LoadVars example to see if that works and it doesn't - help!

It stems from the fact that the Juggled file is not run from the location you execute it from, but the
windows temp folder instead, thus any linkages you may have had to do a normal

LoadVars.load("mytextfile.txt™)
and no longer point to the right location.

You have to use the dightly awkward local_25 to prefix your linkage to the "mytextfile.txt" in this case
and replace any "\" with _5C meaning you can not haveany " _" in your file link.

S0 just change where you have

LoadV ars.|oad("mytextfile.txt")

to
LoadVars.|oad("local_25mytextfile.txt")

and you should be fine.

334. How can | create a screensaver from my flash files ?
Y ou can create a screensaver from a Flash SWF or Flash Projector by using FlashJester Creator

http://creator.flashjester.com
Download afree evaluation copy from here

http://creator.flashjester.com

335. Can | create install programs in French with Creator?

Apparently, you can create French versions of screensavers with Creator. Under the
Ac¢a-A“dialogsA¢a -Ae setup, you can import a language from wherever Crestor was installed. You
guys can support German, English, French, Intalian, Polish, Portugese, Spanish and Dutch, and
moreover, can run all of these simultaneously if you want A ¢4, -&€celetting the user choose at run time.

336. Why are your prices higher than other products in the market?

While our prices may be higher than some competitive products, our quality is also higher. . Compare
our product to the rest of them and you'll see what we mean. Many only have the basic features and we
have many more. We've spent so much time in developing, designing, testing and improving Creator.
Quality is the key. We could have released something along time back , say 2 months after Flash 3 was
released, but then it would have been like the rest of the stuff which is out there. We've hired quality
programmers and designers for this specific project and good programmers and designers aren't cheap.
People who want the best product possible will be our main clients. Now if you can't afford it, you can
go for the Creator Express service, where you send us the necessary files and we create the screen saver
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for you. It isonly $99! and you'll get your money back if you decide to upgrade to Pro or Standard at a
later date.

Pro - With Pro you get unlimited licences so you can freely distribute any screen saver you make as
many times as you want. This is more suitable for the large business and is aimed higher pricewise at
$595.

Standard - More suitable for the smaller business or individual, this package offers the same features as
pro, and you can create as many screen savers as you wish. However, you only have licences to
distribute 10,000 copies of each screen saver. Because this is amed at smaller businesses and
individuals, we have set the price at $395

Also one thing we should point out is that around 40% of profits will be plugged back into the company
for further developments on Creator and other products such as Jugglor and we have many more ideas!!

Charging your clients $500 minimum for a screen saver, will soon pay off Creator, with 2 screen savers.
| am sure many people out there will have fun making screensavers and aliving from Creator.

S0 does this seem too high now ? All comments are welcomed about the price. Please email us with your

opinions.

337. What is a Projector file and where can | get one from?

You will need a copy of Flash from Adobe, www.flash.com. Once you have created your SWF file,
double click on it, then go to the top menu, File -> Create Projector. That'siit.

338. | am considering purchasing your product instead of upgrading to the latest version of
Screentime which will only cost me $99, US.

Please tell me why your product is better than Screentime for Flash.

Thank you for showing an interest in Creator. Why are we better than Screentime? Well hereisalist of
features Creator supports.

http://www.flashjester.com/index.php?section=tricks _creator_features

aso

We don't advertise on your screensaver that Y OU create. No branding from us.

Y ou have much more control over the setup box.

Supports al Windows OS

Screentime doesn't have an Installation file. No readme files are installed hence no license agreements
can be read and used.

Plus many many more.

Join our many happy customers.

Page 104



FIaShJeSter Flashjester FAQ. @

the ultimate place for flashing tools

http://www.flashjester.com/index.php?section=clients
Just found some news about Screentime take alook

http://board.flashkit.com/board/showthread.php?hreadid=349733

339. | tested my screensaver on my new machine with a resolution of 1280 x

1024. The screen saver was created on a machine with 1024 x 768 pixels. When i click on the
"settings" menu in the screen saver dialog (display properties), | get the settings panel, but the font |
used is larger than it should be. My http, mail address and the copyright note are larger than the
panel is. How can | solve this problem?

It's the font you have choosen. Make sure you select one of the default fonts as the end user must have
thisfont.

340. | like the list of images that can be imported, but the only one you have missed out is * .gif?

Ok, because of the licencing laws, if you use GIF imagesin any app you have to pay UNISY S for using
GIF images because they have been copyrighted the LZW compression it uses. What a bummer !l We
are not prepared to pay this price, as we believe it should be open standard, and will not play or pay no
part in thisinjustice, Who is doing whom a favour ??

341. I'm interested in making screensavers using your software. At the moment I'm not sure if | need
a license to distribute more than 10,000. Is it possible to buy Creator Standard and then upgrade to
Pro if the need arises by paying the difference?

Sure you can buy Creator Standard now and then upgrade to Creator Pro at a later date. That is not a
problem.

342. I've created my screen saver using Creator, now | want to use a third party installation tool i.e
Wise or Installshield. Is this possible?

Y es, absolutely. There are 3 steps which you need to follow.

1. If you look in your build path you will find a sub directory called \screensaver, in there are 2 files.
One is the actual screensaver file *.scr and the second is the registry file *.reg. You will have to make
these entries built into the installation.

2. You will need a copy jesterss.dll which can be found in

/Program Files/FlashJester/Creator/Engine

Copy thisfile into the System32 (WinNT/Win2000) or System directory (Win95/98/ME).

3. Thereis also one other registry entry you have to make

HKEY_CURRENT_USER\Control Panel\Desktop\SCRNSAVE.EXE

set this to the path where the screensaver will be installed on the user machine. This is usually the
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SYSTEM 32 directory.

IMPORTANT : If the name of the screensaver is more than 8 characters, which is usually the case, you
need to take the first 6 characters of the name of the screensaver, remove all spaces and then add ~1 to
the end.

So for example

Name of Screensaver - The FlashJester Screensaver.scr
would be

THEFLA~1.SCR

Thiswill set the current screensaver to your new one.

343. Does the end user need the Shockwave Flash plugin installed on their machine?

No, the user requires no plugins whatsoever. All they need is your finished file made with Creator and
then as long as their machine is switched on, it can be seen with no problem.

344. Testing the screensaver in display properties on Win NT worked fine, but when screensaver
launches after a predefined timeout, an error dialog box containing "Exception EFCreateError in
module JBall.scr at 0000D68A. Cannot create file D:\NT40\ __ 3ESolutions_temp\jball.exe" appears.
How can | fix this?

Change access privileges for SY STEM to full access.

345. When | add a link to a web page on a Flash 5 projector, on building my screen saver, it doesn't
load up after clicking on it when the screen saver is working. Why?

The reason this happens is two-fold. First, you would have been using the 'Get URL' function within
Flash and second, you were probably running under Windows NT. There is a problem within Flash that
causes this error when running under Windows NT but there is away to get around this. By using JStart,
one of the JTools , you can be sure that every user that has a copy of your screen saver being able to
view and fully interact with the screen saver, as designed, under whichever platform they are using. So if
you are putting the screen saver on the internet for example, you will not know which platform
everybody is using, so to be sure to avoid this problem that will frustrate NT users to death, simply use
JStart to do the job of linking to web pages.

Y ou can download an example on how to use this function.

346. Could you use an .rmf file as well as a midi file? Could you possibly use the beatnik plugin?

We don't have the developers kit in order to do this. When it's more available then maybe, but again we
see no advantage here... this only increases the engine size, it's much easier to grab amidi file off the net
than aRMFfile.
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347. 1 am using a Flash MX projector file, will it work with Creator?
Yes, it will make sure you have the latest version of Creator, 1.3 or above.

348. I'm putting together a screensaver just now that includes a 1 minute video animation. I'm
wondering if it's possible to include the flv as a component that streams from a file that's installed
locally alongside the screensaver, rather like external swfs that can be included in the installer and
referenced using LoadMovie.

Yesit's possible with Creator. Y ou need to add the FLV in the additional files section in Creator.
P ease download the example file below to see it working.

Y ou will need to Build the project from the *.jcf given in Cresator.

349. How do | create a Flash projector file?

You need a copy of Flash to create an .SWF file (Shockwave Flash). Y ou must have a copy of Flash to
turn the .SWF file into a projector file. To do this, run the .SWF in the Flash viewer and choose Create
projector from the file menu.

350. Do all the projector files have to be in full screen mode?

No. The great thing about the FlashJester Entertainor is that it will automatically change the full screen
setting to true, turning al Flash projector files to fullscreen.

351. Does it support the playing of MP3s?
No, but future versions will.

352. Where can | get the Flash files from?
The Flash files are created using Adobe Flash. See http://www.flash.com

353. Are the JTools difficult to use?
No. We have kept the parts you need to edit very minimal and simple.

354. What happens if the user doesn't have, say, a default internet browser?

This is another feature of the JTools. In the INI file, there is another line you can fill in which is the
message that appears if the browser, e-mail editor or program cannot be found.

355. I've put the command in my Flash file and exported the SWF and patched it. But nothing
happens when | click on the button. What's happening?

Y ou need to put a copy of nameofjtool.exe in the same directory as your SWF or projector file. This can
be found in the directory you installed JTools to (e.g. c:\program files\FlashJester\JT ools\Source)
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356. | created my links with an unregistered copy of JTools but when | registered and installed the
full version why does it still say the evaluation message on my links?

This is because you need to copy JStart.exe from your source directory i.e program
files\flashjester\jtool s\source again to the directory of your project. The version you have in your project
folder is still an evaluation version.

357. How do | use the patch command (Flash 5 only)?
You ONLY NEED TO DO PATCHING FOR Flash 5 fileand NOT 4, MX or MX 2004.

First you need to create all your JTool commands in JHelpor pasting them into the FSCommand box for
each JTool link. Then you need to export the movie in SWF format. Now go to JHelpor and select patch
movie. An open dialog will appear alowing you to search for the movie you wish to patch. Find the
movie you just exported and press ok. Your movie will now be patched. After it is, al the JTool links
will work correctly but you will need to patch the SWF everytime you export it.

358. | had no problem placing my film in a projector but | have a problem closing it. The film starts
automatically when the entry is called. I'd like it to close when | call another entry. Instead the film
stays on top of everything else untill it finishes. | created another Javi.exe + INI with the command
‘close’ but the film is still on top and it creates a pop-up window of the same film. | can't find anything
in the arguments for close movie. Could you tell me the proper command?

Y ou need to use the following command

[AVI]
Address=
Parameters=closeal|

Thiswill do the trick. See the example below.

359. Does JAvi work with Flash 5?
Yes, JAvi works with all versions of Flash, including 3,4 and 5.

360. Why do | need JAvi when JStart can launch an Auvi file?
JAvi adds loads more. It isits own player, alowing for atotal customisation of play and look.

361. | have an AVI file on my CD-ROM. How can | access this file without adding the AVI into the
Juggled file?

You'll not be able to have access to the current directory where the Juggled file resides in, because the
projector file uncompresses to the Windows Temp directory, so using FSCOMMAND - EXEC -
sample.avi means \WINDOWS\TEMP\sample.avi. To solve this problem you will have to use the
LOCAL% command.

362. When | start an .avi file there is no audio...the video plays fine but no audio? Why?
Y ou will need to stop the sound in your projector file before you load the Avi file. Flash uses the Wave
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Device to play its sound and so does the Avi player. So add the Stop All Sound command in the Flash
file.

363. My Avi launches fine in JAvi but when the user moves to another section in my Flash file the
Avi keeps playing. Is there any way | can close all open Avis on a keyframe or button?

Yes, we have a specific command for this you'll be happy to hear. Simply create a new JAvi link in
JHelpor. Do NOT select any Avi file but go into the argument settings of the command and go into the
"Others" section and select the option "Close al other JAvi windows". Click on the Ok button in the
settings box and then Ok again in the Add JTool link. Then copy this command onto the button or
keyframe of your choice and on activation thiswill close any open JAvi windows.

364. I'm using JEmail + JHelpor to launch an email app from a projector on CD.

I've created the .EXE and INI files and stored them correctly in the fscommand folder. Everything
works fine if the default email application is not running. However, if it is running, or an email
window is open behind the projector, and | click an email link in the projector, the new email window
opens behind the projector. | need these in the front, as the movie is full screen, and it looks as if the
buttons just don't work....

The only way around thisisto use Jugglor and JEmail together.

Y ou will have more control over the Projector file and how it appears.
Read this

http://www.flashjester.com/?section=fag& cPath=14 56 21#85
Download the example file and you will see it working.

Jugglor
http://www.jugglor.com

365. | am using JHelpor to install the proper fscommand to launch my default email client, but | can't
get it to do anything.

1. | have a copy of JEmail in the same directory as the projector file.

2. 1 am using Flash MX, so your site says it is not necessary to patch the file.

| have even created a special test movie with nothing in it except one button that has the
fscommand/JEmail actionscript assigned to it as an "on release" action -- still nothing. | get no error
messages - nothing.

Here is the actionscript from my test file:
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on (release) {
fscommand(“"exec", "JEMAIL scott@scottlent.com \"Does 1this 1thing Iwork?\"");

}
No, thisisthe old method for Flash 4/5 files. Y ou have to use the new method involving ini files. Please
read the JStart Web JEmail.hlp file
Start -> Programs -> FlashJester -> JTools
Please download this example file for further information.
366. Can JEmail and Jugglor work together?

Y esthey can.

<a href="http://www.flashjester.com/?section=fag& cPath=14 21" target="_blank">Click here for
further information</a>

367. Why do | need to use JEmail when | can use the

getURL(mailto:support@flashjester.com)?
GetUrl doesn't work all the time. Please read below

>>

Mailto attempts to launch the user's default mail program, but unfortunately there's no way to ensure the
user's system is set up properly, so there's no guaranteeit'll work in all situations.

There is aknown issue in Windows where, if the user's system is set up with a browser other than IE, the
browser can't launch from a projector. The developers have confirmed that Macromedia owns this issue.

Sincerely,
Adam Burtch
Macromedia Tech Support/Flash

>>
Still not convinced then look at
http://groups.google.com/groups?g=geturl+mailto+projector&ie=UTF-8& oe=UTF-8& hl=en

JEmail works on all operating systems

368. | have a Flash X main projector file which loads an additional SWF file. | would like this SWF to
have the JEmail link. How can | do this ?

It works the same way as running JEmail from a projector exe.

p.s You need to useini files and create a sub directory called FSCOMMAND.
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See the examplefile.

369. How do | create multiple, individual email links using JEmail/JHelpor
in the same Projector?

| am using Flash MX 2004
For multiple recipientsin the same email just add them to the Address section in the ini file, separated by

Address=support@flashjester.com;sal es@fl ashj ester.com;info@fl ashjester.com

But if you want to create a new email for each user then you will have to create another copy of
jemail2.exe jemail2.exe etc. and in the FLA file refer to jemail2.exe

370. When copy pasting into the Body field it did not keep paragraph breaks. How do | have the
body stay in multi-paragraph form?
You can try coding the new-line chars as %0D%0A, sometimes the email clients will not understand
this, it depends on them. So it will not work 100% of the time.

371. Is there another way than copying jemail.exe into jemail2.exe etc for multiple email adresses?
I've got about 100 different email links, and don't want a hundred versions of JEmail on my cd with
the projector..

Yes you can by using Jugglor and JEmail together, where Jugglor will automatically add ONLY one
copy JEMail.exe inside the Juggled file.

Read this
http://www.flashjester.com/?section=fag& cPath=14 21

Jugglor
http://www.jugglor.com

372. Does anyone know how to send an email containing flash? So that when a user opens their
email they see the flash movie in their email.

It used to be possible but now most of the mail clients block it, and due to all the security issues from
spyware because of worms, most of the users did upgrade their system so the chances to get the user to
seeit are minimal.

Read this

http://www.webreference.com/multimedia/flash/email/index.html

373. What does the patch command do in JHelpor?
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When you create JTool links in Flash 3, it uses tabs so the JTool knows what the parameters it should
use to run are. You cannot use tabs in Flash 4 as they will be automatically removed. The patch
command will fix this however, making sure that your JTool links do work.

374. Is there a simpler way to set the JTools up, other than JHelpor?

Yesthereis. Jugglor, another program in the FlashJester range allows the almost automatic set up of the
JTooals. It can also make your projector files into fully-fledged programs with features including no right
click menus, option to change the icon, compression and many more. Visit http://www.jugglor.com for
more info.

375. Is there a way to send a command equivalent to the "Esc" key to the movie from one of the
Flash buttons in the presentation?

i.e.

When the user clicks on one of the flash buttons the movie gets a "quit" command from the button?
Y es you can use the closeall command.

JMOVIE.exe closeadll

Try that.

376. How do | set my movie file to FullScreen?
Y ou need to add the Parameter

fullscreen
in the argument.
Open JHelpor

Press +.

. Select IMovie from - Avaible JTools
Use Parmeters.

. Enter the filename of movie.

Press.. in Arguments.

Position & Size -> Full Screen.
Press OK.

Press OK.

. Press COPY.

©CONOUTAWNE

So now you have something like this
[MOVIE]

Address=mymovie.avi
Parameters=playfrom=0 fullscreen

Page 112



FlaShJeSteI' Flashjester FAQ. %

the ultimate place for flashing tooils

Now also read the IMovie Help file
Start -> All Programs -> FlashJester -> JTools -> IMovie -> JMovie Help
to help you.
Also look at the following example
C:\Program Files\FlashJester\JT ool s\JMovie\JMovie Flash MX Examplel
and change this examplefile to run in fullscreen.

377. How do | create dynamic movie file names using JMovie & Jugglor ?
Y ou have to use the EncodeForFunction.
See the example file below which will explainit all.

378. Everything works correctly, but when | play a movie, the sound is all messed up?
Y ou need to set the sound to A A ¢AY4directsound deviceA A ¢AY2 and not waveout

379. | can't find the commands to start, stop or pause movies from a Flash file (the movie itself runs
fine with JMovie).

For these commands to work you will have to use IMovie and Jugglor together. The Play, Pause, Stop
and Close commands have been added in recently.

Please download the example fileto seeit in action.

380. Why do | need JMovie when JStart can launch Quicktime, AVI or Mpeg files?

JMovie has much more features. It is it's own player alowing total customisation of play and look. It
takes advantage of the Windows Media Player.

381. | have a movie file on my CD-ROM, how can | access this file without adding the file into the
Juggled file ?

You'll not be able to have access to the current directory where the Juggled file resides in, because the
projector file uncompress to the Windows Temp directory, so using FSCOMMAND - EXEC -
sample.avi mean \WINDOWS\TEMP\sample.avi. To solve this problem you will have to use the
LOCAL% command.

Please take alook at the examplefile.

382. Some of my users cannot view the movie file. It appears incorrectly on the screen, or blank.
The user will need to have the latest version of Windows Media Player 7.1 installed on their system.
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Y ou can download the latest version of the Windows Media Player (for the ActiveX control). Also you
need to make sure that they have the video codecs used in compression of your video installed. If you
are distributing your files on CD-Rom, then it might be advisable to put a copy of the Windows Media
Player installation on your CD.

383. Every time | try and change the video dimensions or click the "Relative to Flash" box in
JHelpor, I am unable to view the video when | create a Flash projector. I'm using FlashMX. I'm
wondering if all this is just because this is the demo version?

The 'Relative to Flash' feature only works with Juggled files. Download the following example

384. | need the video to play within the interface, at the specified size and position. This | can do and
the JMovie.exe comes up fine in front of the fullscreen flash exe, however when | click on to the
flash interface, the JMovie window plays behind the flash exe?

Ok, first of all you will need to use Jugglor and JMovie to have better control over the movie.

Download an evaluation copy from here

http://www.jugglor.com

Make sure you recreate all your commands within the JTools section in Jugglor.

Jugglor -> JTools

Once you have created the commands then press the Copy button and paste into the FLA file.

Use the LOCAL% command if you are using files the are outside the Juggled file.

Now in Jugglor set the following :

Jugglor -> Setup Settings -> Don't go to foreground on click -> Checked

Thatsit really.

Please download and look at the example file provided. This example also uses the additional SWF file
which is included in the Juggled file which launches the Movie file. (you don't need to use additional

SWF files)

p.s Read the IMovie Help file if you get stuck.

385. JNetCheck doesn't seem to work on my network. Is there anything else | can try?

Y es, sometimes if you are working in a Proxy environment it will not work. So we suggest you use the
/url command, where you specify a URL to see if you get an outside link.

JNETCHECK /url=www.flashjester.com
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would be

IJNETCHECK 20 2Furl_3Dwww.flashjester.com
where

20is

2Fis/

3Dis=

inthe FLA filefor Flash MX users

Please take alook at the sample below

386. How do | work around the fact that JNetCheck needs to write to a txt file so flash can check the
variable, without installing anything to the hard drive? In other words, can you use JNetCheck when
running your projector from the CD?

Y es, you can by using INetCheck and Jugglor (http://www.jugglor.com) together.
Y ou have to include the INetCheck.exe which can be found in

‘\Program Files\FlashJester\JT ool s\Source

in the'Additional Files section in Jugglor.

When you build and then run the Juggled file, it will uncompress al it's content inside the Juggled file to
the Windows/Temp directory. Hence INetCheck.exe will be able to write the status to the harddrive

Other things to remember.

1. You haveto use

fscommand("Exec", "JNetCheck.exe");

2.1t's

loadV ariablesNum(" INetCheck.txt", 0)

you don't need to add the FSCOMMAND as a sub directory.

3. IMPORTANT. You must add the

fscommand("Exec", "IJNetCheck.exe");

in or after the 10th Frame, so it give enough time for Jugglor to initialise.

Please take alook below at the example provided.
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387. How do | print my Flash file from my web page?

| have created a button in my flash file for printing. I've attached a
print function, but it prints over 20 pages.

| want this button on the screen at all times and want to click on the button and print whatever
screen it is now sitting on.

JPrintor is not the tool for this. JPrintor is only for offline CD-ROM type work.
The answer to your problem comes from the PrintJob Class in Flash Actionscript.
See below for some simple code. Basicaly what itisdoingis:

1. Creating a new PrintJob instance

2. Checking if the user clicked "OK" on the print dialog

3. Adding content to the print spool

4. Sending it to the printer

5. Deleting the PrintJob instance

The method to noteisthe:

printJob_pj.addPage( "_root.MovieclipName", { xMin:0, yMin:0, xMax:570,
yMax:755}, { printAsBitmap:true}, 1);

Thisline tells the printJob:

what movieclip from the stage to print from  "_root.MovieclipName"

what bounding rectangleto use for printing  { xXMin:0, yMin:0, xMax:570,
yMax:755 }

Send the data to the printer as an image { printAsBitmap:true }

Which frame of the movieClip to print 1

See full code below.

/I create an instance of the PrintJob Class
var printJob_pj = new PrintJob();

/1 if user presses ok at the system default print dialog
if (printJob_pj.start())
{
[/l add frame 1 of theMovieclip to the print queue
printJob_pj.addPage( " _root.MovieclipName', { xMin:0, yMin:0, xMax:570,
yMax:755}, { printAsBitmap:true}, 1);

/I send spooled info to printer
printJob_pj.send();
}

/I clean up
delete printJob_pj
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By customizing this, you should be able to specify what to print in your movie. You may want to pass
_root._currentframe as the frame number to the above method to print the frame that the user is currently
on.

Read this also

http://sephiroth.it/tutorial s/flashPHP/print_screen/

388. | want to make a print button so it will print the whole page | am currently on. The page isn't all
flash, it's a html page with a flash button

So how can | print this page?

Y ou will need to make a call to the javascript in the external page for this. If you put something similar
to the following code on your button, it should print the webpage:

getURL ("javascript:window.print();");

This will make a call to the page that your flash file is stored in and call the print function. This will
most likely NOT print your flash content though.

| hope that this helps you out.

389. | have just upgraded my Flash CS3 to use the latest Flash 9 Player. I've noticed now when |
use the getURL command to open a PDF file while in fullscreen

i.e
getURL(file.pdf'," _blank™);

from my Flash 9 Projector fiile, the window minimises and out of fullscreen.
How can | prevent this ?
Y ou can use FlashJester Jugglor and JStart together. JStart comes FREE with Jugglor Pro.
http://www.jugglor.com
http://jstart.flashjester.com
Y ou basically replace the getURL command with the JStart command and let
In Jugglor you set the Window to be in fullscreen

Setup Settings -> Windows Settings -> Size options -> Fullscreen
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and

Setup Settings -> Don't go to foreground on click (scroll down the bottom right box)
Thereisatutorial here

JStart Help -> Using Jugglor With JStart

Please download the example file below to help you

390. How do i get the <b>FileExist</B> function to work with Flash 8 and below ?

Active X
fscommand(‘exec','j:sy:fileexists:"FileName",ResultVar’);

Projector Engine
fscommand(‘exec’,_root.EncodeForJugglor(’j:sy:fileexists:"FileName",ResultVar'));

Examples
Filename="c:\\myfolder\\projector.exe"
Please ook at the example provided below.
391. How do i get the <b>FileExist</B> function to work with Flash CS3 with Actionscript 3 ?
Due to CS3 and Actionscript 3 we've had to change a few things the way with code.
First have abrief ook at
Jugglor v3.0 Help -> Advanced Techniques -> FSCommands, Classes and Events
(until we update the JSystem Help files)
The same principles apply with JSystem.
Look at the FileExist example below.
From here you should be able to figure out how it works.
Hope this helps
392. If writing to the local HD, can user "browse" to the preferred directory location before saving, as

is familiar and common in Windows OS and traditional desktop applications? Or must they actually
type the full path to save it to a location of their preference

Y esyou can by using JSystem.

JSystem Help -> FSCommand List -> File Manipulation -> SelectFile
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Download the evaluation and look at
C:\Program Files\FlashJester\JT ool s\JSystem\Exampl e Files\Open_Save Dialog Example

or if you are using Flash CS3 with ActionScript 3 then download the example file below

393. | am having problems with the <b>SaveToFile</b> command with Flash 8 and below can you
please help ?

Y es sure. Please look at the example file provided. It has a Projector and SWF example file.sss

394. | am having problems with the <b>SaveToFile</b> command with Flash CS3 and Actionscript
3 and below can you please help ?

Yes, the scripting is much different than before. You no longer need to use the EncodeForJugglor
function and others.

The best thing isto download the example below.
Thisexampleisfor Jugglor 3.0 and above users.

395. | cannot open any of the help files .CHM in Vista ?
Y esthereis an issue with this. Please read the following
http://blog.crowe.co.nz/archive/2007/04/13/719.aspx

http://bl ogs.technet.com/seanearp/archive/2007/05/28/can-t-read-chm-compiled-hel p-on-vista-xp-2003.a
SpX

396. | am having problems with the <b>LoadFromFile</b> command using Flash 8 and CS3 using
ActionScript 2.0, can you please help ?

Yessure. Please look at the example file provided. It has a Projector and SWF examplefile.

397. Can | have my text file be ammended / appended too rather than replaced each time the
program is run? I'd like to run my program - have the X.txt file be created, store the data - then if
another user opens the program, add a second line of text to the already created X.txt file rather
than over writing the first line of text.

Y esyou can use the AppendTo function built in JSystem

Read the JSystem Help File

Home -> FSCommand List -> File Manipulation -> AppendTo
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398. | am having problems with the <b>AppendTo</b> command with Flash CS3. Can you help ?

Yes, the scripting is much different than before. You no longer need to use the EncodeForJugglor
function and others.

Y ou can no longer use Actionscript 2.0 with CS3, now has to be Actionscript 3.0. This is because of the
changes made by Adobe, we've had to rewritten our enginesto adjust for this.

The best thing is to download the example below.

This exampleisfor Jugglor 3.0 and above users.

399. I'm saving out text to a text file using Jsave.

In Flash when | do a trace of the text | have typed into the input field, the output panel reads
correctly eg &Studentld = John Doe

However when | Juggle the file with JSave then run the exe I find that only the text up to the space
has been written ie "John". Also all the remaining variables and their values are also not written.

If I do not use a space everything works fine.
Also if | edit the text file and put a space inbetween 2 words it reads back in fine.

Can anyone advise me why a space should make a difference and how | can rectify the process.

You MUST have double quotes around the ALL of the variables.
If you have double quotes in the variables aready, please remove them and use single quotes.

For example

jsave textfile savedvariables

should

jsave texfile + ™" + savedvariables + "
so

fscommand("exec", EncodeForJugglor('fJSAVE.EXE local %Results.txt CoursewareType='
+CoursewareType));

would be
For example

fscommand(“exec", EncodeForJugglor('fJSAVE.EXE local %oResults.txt "CoursewareType='
+CoursawareType +"));
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400. | am having problems with the <b>AppendTo</b> command with Flash 8. Can you help ?
This example will work with Jugglor 2.3 and 3.0.

401. | need some help and tips on how to display flash on a plasma TV? | have a Flash Projector
that will be on a Plasma TV as a presentation.

Here are afew tips

1. Publish the movie as a projector and then adjust the HD screen's settings until the
presentation fits perfectly.

2. It'smostly trial and error but eventually you get there.
3. Make sure you design for the proper resolution.
4. Add alittle extra space for a margin/border.

5. If you are designing for a Plasma TV that supports HD , then the resolution is 1920 x 1080, but may
vary according to the screen manufacturer, so always check.

6. Animate at 30 frames per second, it looks so much better.

7. Now if you don't want or cannot change the Flash file then you can use Jugglor to set these
automatically.

Screen Resolution
Setup Settings -> Windows Settings -> Full Screen Resolution

Fullscreen
Setup Settings -> Windows Settings -> Size Options -> Full Screen

Stretch
Setup Settings -> Windows Settings -> Stretch movie to fit window

Download a FREE evaluation from
http://www.jugglor.com

That should help.

402. 1 am having problems with the <b>LoadFromFile</b> command using Flash CS3 using
ActionScript 3.0 , can you please help ?

Y es since Actionscript 3.0 had been introduced we'd had to change a few things the way we code.

Please |ook at the example below and follow this example while we update the JSystem Help file.
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403. After clicking on any button that links to a website | have the following message popping up on
the top of my executable:

DDE:lexplore:WWW_OpenURL:A¢a,-As\Program Files\Internet Explorer\IEXPLORE.EXEA¢4,-Ae
-nohome

It should display the Title of my executable though.

Do you know how to fix this?

Yes due to recent changes in the CS3 we don't recommend you use getURL with your AS2 or
URLRequest in AS3.

We recommend you use JStart and Jugglor together

http://jstart.flashjester.com

and

So

getURL ("http://www.flashjester.com"," _blank");

would be

fscommand(“exec", "JSTART _20http_3A_ 2F 2Fwww.flashjester.com™);

Please look at the following AS3 example, the same appliesto AS2
404. How do | open the explorer window to view a folders contents ?

Look at the example file below. It opens C: drive. Edit the

cd\fscommand\Start.ini

if you want to changeit.

Y ou must have the fscommand folder and the folder structure. It's a Macromedia Security feature.

405. | have been using Flash 8 and now upgraded to CS3. Now when | publish my old projects to a
CS3 Projector file none of the Actionscipt/Jugglor commands work ?

Yes that is because your using AS2 with CS3 Projector files. This will not work. You will need to
publish the Projector as a Flash 8 Projector file.

Now you can only do thisif you are have Flash 8.

But here one way todo this without having Flash 8 installed.

1. Save the FLA has a Flash 8 Document in Flash CS3.
2. Publish the Flash files as a SWF, not a a projector.
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3. Open Jugglor -> Select Flash Projector/Movie file -> The saved SWF.
4. Then select 'Convert SWF to Flash Projector' -> Flash 8.
5. Now Build the project.

Remember AS2 and CS3 Projectors will not work with Jugglor. You can convert to AS3 and then use
CS3 Projector files.

406. How do | use the <b>CopyFile</b> function in JSystem with CS3 ?
Please |ook at the examplefile given.

Inthe Help fileis says

Active X
fscommand(‘exec','j:sy:copyfile:" SourceFileName"," Destination” true,ResultVar');

Projector Engine
fscommand(‘exec’,_root.EncodeForJugglor('j:sy:copyfile:" SourceFileName"," Destination” true,ResultVa

");

but the true shouldn't be there so remove it

Active X
fscommand(‘exec',’j:sy:copyfile:" SourceFileName"," Destination” ,ResultVar');

Projector Engine
fscommand(‘exec’,_root.EncodeForJugglor(’j:sy:copyfile:" SourceFileName"," Destination” ,ResultVar'));

407. When 1 Juggled my Flash file | find that the labels in my Flash Objects such as buttons, labels
seem to go transparent when it shouldn't.

What can | do to fix this ?
In Flash FLA file select the object and set the following

Properties -> Display -> Blending -> Layer

Do thisto ALL the Flash Objects.

408. What is Authenticode or Digital Signing ?
How will it help my Flash file ?

Authenticode is a very important program that Jugglor now supports. This guarantees that the code being
downloaded from the Internet has not been altered since its creation. It is then verified by showing the
downloader that the software is coming from the intended party. You are probably aware of the dialog
box that appears once you click to download a program from the net, either telling you who you are
downloading from if they've signed it using Authenticode, such as Microsoft, or if the content is not
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signed. In this case, the window says "can't verify publisher.” and this is when you can not be sure of the
content of the program about to be downloaded.

The support of Authenticode is a very important step as Juggled files are made to be easily distributed
via the Internet and they must be protected from tampering, such as viruses being added. From now on,
you are able to sign these items with Authenticode to give people a guarantee that the file's content is
what you say it is.

What software do | need to do this?

The software used to apply the Authenticode is located at Microsoft's site and is downloadable from:
http://msdn.microsoft.com/downl oads

Then on the right hand side click on

"Security -> Authenticode"

Choose which platform you are using.

Here you will find the software to add the Certificate to the Juggled files.

Where can | buy these Certificates from?

Verisign

The digital signatures required in processing the Authenticode cost's US$400 per year and can be
obtained from Verisign's web-site at

http://digitalid.verisign.com/devel oper/ms_pick.htm

Thawte

Service is only US$200 per year, renewal cost 1 Year: US$100 . We recommend using this. Y ou will
have to provide relevant information and documentation about your company, etc. Once you have done
all of thisit only takes a couple of daysto issueit.

http://www.thawte.com

Below you wil find a Juggled file that has been Digitally Signed.
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