
Flashjester  FAQ.

1. What is the minimum I need to fill in to be able to build my screen saver?
To make full use of the program, we suggest you fill in all the fields. However, if it is a quick start you
are after, you will need to fill in the following fields: 

Company Name 
Long Name 
Short Name 
Flash Projector File 
Setup Box Graphic 
Build Path 

Filling in any less than this will cause your screen saver not to be built.

2. What tools does Creator include?
The tools included can perform many tasks. As well as creating a screen saver from your projector files,
Creator can make a totally customisable setup box. Once your screen saver has then been made, you can
package it up using Creator's built-in install maker.

3. What is Creator?
Creator takes your projector files made in Macromedia Flash and turns them into screen savers.
However, unlike many other screen saver creation programs, there is no need to leave the program.
Creator includes all the tools you need to create, package up and distribute in one program.

4. I have a bitmap at the start of my screen saver. When the screen saver loads up, the animation
for this bitmap is slow. Is there anything I can do about this?

The screen saver takes a little time to load the whole projector file at the start. To combat this, you will
either need to put in some empty frames at the beginning or use as little vectors/graphics at the start as
possible. It should only take a few seconds to load but it is best to leave a short delay before the
animation starts.

5. When I put the web, e-mail and other labels on my setup box they don't show up. Why?
Ok. This simple mistake has been made by a few people and is VERY simple to get around. What has
happened is you have put the labels on the transparency colour, not the bitmap. The bitmap is the only
part that will show when the screen saver is built, so all labels will need to be placed over this. When
designing your setup box bitmap, it is a good idea to leave room for your labels.

6. In my screen saver, it loads separate SWFs onto the different layers. This all works fine apart
from the SWF at the start. This does not load up. Why is this and how can I combat it?

This is quite simple. What is happening is that for the first and maybe second frame of the projector file,
Creator is extracting all the files used in the screen saver. So when you call for the SWF, it has not been
unpacked yet. You can solve this simply by loading the SWF on the second or third frame.

7. What if I don't pick an icon?
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The default Creator icon will be used.

8. Can I use any bitmap for the setup box?
Yes. Creator supports bitmaps of up to 256 colours but if you have a 16 million colour bitmap you wish
to use, Creator will optimise it in 256 colours.

9. How customisable is the setup box?
Using a graphic, the setup box will form itself round the picture making a totally unique shape to each
bitmap used. Once the shape has been defined, you can select from a list of components to put in the
setup box including a web link, e-mail link, sound mute control, interaction control and midi file sound
control.

10. What if I want to use my own install maker?
When Creator builds the screen saver it creates two folders, install and screen saver. Install contains the
install file with the screen saver inside. The screen saver folder contains just the screen saver. You can
use your own install maker here.

11. What about the install maker?
Creator can package your screen saver up before you leave the program. You can edit all the dialogue
boxes that appear as well as the background of the installer. You can display a bitmap or gradient
background, you can change the main bitmap in the dialogue boxes, you can include and exclude
dialogue boxes and do many more things.

12. Will my screensavers run on Win ME/2000/XP ?
Only if you have version v.1.2. If you don't then you will need to upgrade to the latest version. The best
thing about this is that the upgrade is FREE.

13. Is it possible to build screen savers for use on the MAC OS platform?
No, sorry. It's a completely different ball game. We don't have the skill or resources to port to the Mac,
well not at the moment, anyway. We suggest you use ScreenTime for the Mac and ours for the PC
version. Spot the difference !!

14. What's the minimum spec I need to run Creator ?
A minimum spec for Creator is any Pentium machine, 16MB RAM, 3MB Drive space,
WIN/95/98/NT/ME/2000/XP

15. I am trying to use JWeb to add a link to a URL from within a screensaver file I built with Creator. 

I am using FlashMX, and when I go through Creator and build the install file, then install it and click
the link, I get this message: 

Page 2



Flashjester  FAQ.

Error no URL defined
First you must use JStart and not JWeb in order to launch web pages, due to the security in NT. We have
written code to overcome this problem in JStart. 

To create the command to paste into the FLA you MUST use Jugglor and the JTools section in there.
JHelpor will not work. 

Detailed instructions. 

1. In order to create a projector with a link to a live URL, that can be converted to a screensaver, you
need the following: Flash, Creator, Jstart, Jugglor 

2. With Flash, you create your FLA file. In your FLA file, you will need a button, to launch the URL. 

3. You'll need to create some code with Jugglor, to paste into your button Action window. If you open
Jugglor (you can download a 30 day free trial) and launch the program, go to the JTools section. 

4. From the JTools section, click on Jstart, and enter in your URL and error message. If you are using
FlashMX, make sure the FlashMX checkbox is selected and then click the Copy button. 

5. Go back to your flash file, and select your button. In the Actions window, select fscommand, then put
Exec in the first field, and paste in what you just copied, into the second field (this is assuming you are
using Normal Mode for your Actions window). 

6. Save your FLA file. Publish your FLA file as a Windows Projector. 

7. Quit Flash and Jugglor. Launch Creator. Follow the directions for importing your EXE (projector)
file. When you get to the screen to add additional files, you'll need to manually add a JSTART.exe file -
this is included in the C:\Program Files\FlashJester\JTools\Source\ folder on your Cdrive. 

8. Proceed through the Creator screens and Build your screensaver That should do it. 

Please look at the example file provided.

16. Where can I get cool midi files from for free?
Just pop on over to http://www.exrock.com. There's a lot there for you to use! And tell them the Jester
sent you.

17. Can I have both the Flash music file and the midi file playing at the same time?
Yes. You can play both or one or the other.

18. Can I use ANY flash projector file?
Yes, only PC versions though.

19. Does the screen saver support password protection?
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Yes

20. Why should I choose the FlashJester Entertainor?
The FlashJester Entertainor is one of the best Flash screen saver players about and has many different
features that are not in others. The FlashJester Entertainor allows you to add interaction to the screen
saver. By turning on the interaction, you can point and click at the screen saver. You can also turn the
sound to the Flash file on or off. By turning it off, you can also add another great feature to the screen
saver, playing a midi. The screen saver allows you to play any midi file along with the screen saver.

21. I have a few questions regarding installers. First, which specific WISE installer to you
recommend? Package Studio? Wise for Windows Installer? or Wise Installation System? Are they
all flavors of the same product? Are there any other less robust solutions that you might
recommend? For now, all I really need to do is create a simple installer that allows the option to
'Launch at Startup'. I'm sure WISE products can do this but I have no need for its many other
functions.

OK See the attachment. We've just created a simple Installation for you using the Wizard. It will install a
Juggled file in a c:\program files\pitball directory and add a link in the Startup directory as you required. 

We recommend you go for the 

Wise Installation System 9 - Standard Edition 

This is very powerful as it is. 

http://www.wise.com/ordercentermain3.asp?category=6 

We use an old version of Wise Install. It does the job and alot more.

22. I have a bitmap at the start of my Juggled file. When the Juggled file loads up, the animation for
this bitmap is slow. Is there anything I can do about this?

The Juggled file takes a little time to load the whole projector file at the start. To combat this, you will
either need to put in some empty frames at the beginning or use as little vectors/graphics at the start as
possible. It should only take a few seconds to load but it is best to leave a short delay before the
animation starts.

23. Can the user control how the animation is played?
That depends if you have the keyboard interaction on or not. If the keyboard interaction is turned on, the
user will be able to start and stop the animation by pressing the Enter button. They can also go forward
and backwards through the frames by pressing the left and right buttons. If you turn keyboard interaction
off though, these keys will not function.

24. What about my screensaver? Won't that interrupt it?
One of the options of Jugglor is that you can choose to disable the screen saver while the Juggled file is
playing. This can be done in the Flash Settings section.
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25. Do the users need the Flash Shockwave plugin to view the Juggled file?
No. This is the beauty of Jugglor. You don't need any plugins at all as Jugglor uses Projector files,
stand-alone programs in themselves, to create the Juggled files.

26. What files will I need to include with the file?
You don't need to include any files with the finished Juggled file since everything is packaged up in the
one EXE.

27. I have a lot of SWF movies which I load in using the Load Movie command. If I add them all into
the additional files section then the file is way too big and takes ages to load. Is there any way I can
get around this?

Yes. You do not have to put all your movies into the Juggled file. By using Jugglor's "Current Directory"
feature (in the build section), you can specify the directory in which the Juggled file will look for the
movies

28. I want to be able to secure some of the files that are inside my Juggled file, as when they are
extracted anyone can acess them from the Windows/Temp. So I am looking to secure it using
Winzip. I have JStart and Jugglor. Now how can I extract/uncompress a password protected Winzip
file ?

In Winzip you can use command line to extract compressed files see 

>> 
Extracting Files 
The command format is: 

winzip32 -e [options] filename[.zip] folder 
where -e is required. 

options 
-o and -j stand for "Overwrite existing files without prompting" and "Junk pathnames", respectively.
Unless -j is specified, folder information is used. Use -sPassword to specify a case-sensitive password.
The password can be enclosed in quotes, for example, -s"Secret Password". 

filename.zip 
Specifies the name of the Zip file involved. Be sure to specify the full filename (including the folder). 

folder 
Is the name of the folder to which the files are extracted. If the folder does not exist it is created. 

>> 
The above was taken from 
http://www.winzip.com/xcmdline.htm 

With JStart you can pass these parameter on i.e 

File 

Page 5



Flashjester  FAQ.

winzip32 

Arguments 
-e -s"flashjester" jstart.zip 

where 

the password is flashjester 
jstart.zip is the zip file inside the Juggled file 

Remember the zip file will uncompress into the Windows/Temp where all the other file are. 

Please download the working example and then build the project in Jugglor to see it working.

29. I'm using Jugglor and JSave together, and when I tell JSave to save to the text file the text file is
not there when I look. Where is it?

When you run a Juggled file, it extracts all the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you
run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the 

JSave Help file -> Setting up JSave - Additional Commands

30. I can save text using JSave with Flash MX projector files ?
Yes you can. You will have to use JSave and Jugglor together in order to do this. 

Remember to look at the ActionScript very carefully and don't forget to add the EncodeForJugglor
function. YOU MUST ADD THIS. 

Please download the example file to get a better understanding.

31. I'm using Jugglor and JSave together, and when I tell JSave to save to the text file the text file is
not there when I look. Where is it?

When you run a Juggled file, it extracts all the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you
run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the 

JSave Help file -> Setting up JSave - Additional Commands

32. Are they compatible with a Juggled file?
The JTools and Jugglor are best companions. By using the two, you can come up with a fully
functioning piece of software.
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33. What if I want to have more that one web/email/program link?
You'll only need to include one copy of each JTool you use as the parameters inserted in the Projector
file reuse these JTools. These are to be kept in the same directory as the projector file.

34. I am now using Flash MX/6 Projector files, but none of my previous JTools link work ? Why is
this ?

Yes, this will not work due to the changes made by Macromedia in Flash MX. You will need to
recreated the links by pressing the Copy button again in the Jtools section and paste accordingly into the
FLA file and exporting it back as a Flash MX/6 projector file. Remember you will not need create the
FSCOMMAND directory for the JTools to work, Jugglor has taken care of this.

35. For FSCOMMAND - Exec to work with Flash MX, I heard you have to create a FSCOMMAND
directory ? Is that true ?

If you are using Jugglor and the JTools then you don't need to create the FSCOMMAND directory. If
you are not then yes you will need to create the FSCOMMAND directories yourself. Please see
respective helps.

36. I have Flash MX on my machine but I want to create a Flash 5 projector. How can I do this
without reinstalling Flash 5 ?

First make sure you have Flash 5 on the machine. Then locate 

\Program Files\Macromedia\Flash 5\Players\FlashPla.exe 

Open it and then close it. This will set the Flash 5 Player as default. Click on an exported Flash 5 SWF
file from Flash MX and now it will open up the Flash 5 player. Then go to File -? Create Projector. Now
if you would like to create a Flash MX Projector just use the Publish command and check Window
Projector checkbox.

37. Why doesn't the Patch command work with Flash MX files ?
You don't need to patch Flash MX files. We are using a different approach here.

38. I want to run an AVI file but I don't like the default Microsoft AVI player. What should I do?
Well, if you have your own AVI playing program you can use JStart to get that to play your AVI. You
can however use our specially designed JAvi player. This will play an AVI file with the minimum
amount of effort. JAvi is totally customisable, with features including looping the AVI, closing when
finished playing, one instance and many more.

39. My Avi plays from JAvi fine on one machine, but doesn't on another I tested it on?
This is probably due to the codec that you have encoded your Avi in and it is not installed on the other
machine.

40. Can JAvi detect whether a codec is installed?
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The JAvi play cannot currently do this, but we are looking into it for the next version.

41. Is there any way I can include all the files in one EXE rather than distribute the AVIs, JAVI and
projector together?

Yes there is. You can use another product in the FlashJester range, Jugglor. With Jugglor, you can
modify how your projector file plays and acts, but the feature that you will find most useful is the fact
that you can have all your files, JTools and projector files in the one EXE. A free evaluation version of
Jugglor can be found on the FlashJester website at http://www.jugglor.com. 

For an example of Jugglor and AVI combined, check out the JAVI Example file included with this
installation of JAVI. If you want to see how this works then have a look at the JAVI Example file FLA.
There you will see all the links and how they work, and if you want to know how those links were setup
in JHelpor, the JHF is there as well.

42. How do I get JEmail working with Flash MX ??
See example below.

43. Why is the text in the copy box in JHelpor different to the text that is inserted in the FSCommand
box when I press CTRL + V?

The reason for this is because JHelpor works out the actual code needed for the JTool. As the projector
file doesn't accept spaces what you see in the Argument box is the code with the spaces. JHelpor then
modifies this to take out all the spaces.

44. Will I have to include a copy of JMovie for each movie file I open with it with Flash 5?
No. JMovie works with parameters meaning that you don't need to make copies, it will just use the one
copy to run all your links. In Flash MX you will have to create one instance for each movie you use. The
best thing will be to use Jugglor and JMovie then you will only need one copy of JMovie.

45. Is there any way I can include all the files in one EXE rather than distribute the movie files,
JMovie and projector together?

Yes there is. You can use another product in the FlashJester range, Jugglor. With Jugglor, you can
modify how your projector file plays and acts, but the feature that you will find most useful is the fact
that you can have all your files, JTools and projector file in the one EXE. A free evaluation version of
Jugglor can be found on the FlashJester website at www.jugglor.com. 

For an example of Jugglor and a movie file combined, check out the JMovie Example file included with
this installation of JMovie. If you want to see how this works then have a look at the JMovie Example
file FLA. There you will see all the links and how they work, and if you want to know how those links
were setup in JHelpor, the JHF is there as well.

46. Do I need JHelpor to set up JNetCheck links, the same as your other tools?
No, not at the moment. This is because you only need to simply run JNetCheck and do not need any
parameters to make it work. In the future, it may be necessary because of added features.
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47. I have JNetCheck set up, but what can I do with it?
Take a look at the Uses section of this help file and the example file that comes packaged as well. Try
experimenting with it also and if you come up with any good examples, let us know. Email
gallery@flashjester.com with your examples.

48. I'm looking into creating a CD that would contain a Flash projector file on it. On one frame of the
file, it would contain a print button, that would print the contents of the frame to a PDF file. Do you
have a tool that would accomplish this?

You can create the PDF files you need from the Flash file and save the save indivdual psf file then use
JStart to print the pdf file. 

Look at the help file 

C:\Program Files\FlashJester\JTools 

JStart_JWeb_JEmail.hlp -> JTool Settings -> JStart -Using the Print Command 

or 

You will need a PDF Printer Driver. 

Here one 

http://www.pdf995.com/ 

yu can find more by going to 

http://www.google.com/search?sourceid=navclient&ie=UTF-8&oe=UTF-8&q=PDF+Printer+Driver 

Basically you use the normal print command in Flash or you can use 

JPrintor 
http://jprintor.flashjester.com 

and instead of printing to a Printer you select this PDF driver.

49. Will I have to include a copy of JPrintor each time I want to use it in my projector file?
No. JPrintor works with parameters meaning that you don't need to make copies, it will just use the one
copy to run all your links.

50. What if the user doesn't have a printer?
JPrintor will not print if the user does not have a printer.

51. How do I use JSave with Jugglor with Flash 5?
JSave can be used with Jugglor in the same way that all JTools are set up. See the Jugglor help file for
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more information on setting up JTools.

52. What does all this coding mean?
To find out more about the coding used in the Flash file, have a look at the Flash manual or help file.

53. I have followed the steps in the step by step guide but it still won't save. What can I do?
Copy the "Save" keyframe over again, and make sure you replace EVERY Memo1 with your own
choice of variable for your text box.

54. I have tried typing into the text box but it only takes my first line I type. Why's this?
JSave only takes the first line you insert into the text file and will not take any characters after you have
pressed return.

55. I have typed in a long paragraph but it got cut off half way through. Is there a limit to the amount
of words you can type and save?

Yes. Flash is limited to just exporting 255 characters (this is even less taking into consideration the
JSave command and the parameters for where the text file will be stored.)

56. Because the Flash file is in Flash format, does that mean I will need to patch it as I have had to
with other JTools?

No, you won't have to. The special coding ensures that is not needed for JSave.

57. I'm using Jugglor and JSave together, and when I tell JSave to save to the text file the text file is
not there when I look. Where is it?

When you run a Juggled file, it extracts all the files and JTools it uses to a temporary directory. When
you run Save, it saves the text file to that directory. If you wish to save it in the directory in which you
run the Juggled file from you will need to use the LOCAL% Command. To find out more about the
LOCAL% command look at the 

JSave Help file -> Setting up JSave - Additional Commands

58. Where can I get Jugglor from?
You can download a free evaluation version of Jugglor from the FlashJester website at
http://www.jugglor.com.

59. Am I limited to certain shapes?
No, not really. It's up to your imagination and Flash.

60. Why can I see bits hanging around my Juggled file?
This is caused by discolorisation of the transparent color, probably due to when it was decreased from 16
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million colours. You can easily get rid of this by adjusting the tolerance control in the main JShapor
window.

61. Why have the Border, Caption and Size options been disabled in my Juggled file when I add a
JShapor command?

These are disabled because the skin you choose specifies the size and you will not need the borders and
captions because of the custom shape.

62. We need to launch Excel files out of the projector. The master 
CD works fine on my machine (winXP), but is erroring on WinME 
and win98 cpus. The projector launches Excel okay, but cannot 
find the files despite loading the application. 

Here is a sample ini file. 

[START] 
Application=../Excel Files/cash flow projection.xls

You are using fowardslash / when you are suppose to use backward slash \ 

So it should be 

[START] 
Application=..\Excel Files\cash flow projection.xls

63. I have a Flash MX projector file that uses the LOADMOVIE command to load additional SWF
files. Now I want these SWF files to load my Word, Pdf, EXE and other files. Is this possible ?

Yes, you can sure this is possible. 

Please download and carefully look the example file given.

64. Does the final flash file need to be an EXE for the JSTART commands to work or will an SWF
also work?

Yes it has to be a Projector file, it will not work on SWF files in a browswer due to security reasons,
unless you are using the LOADMOVIE command to load additional SWF files from a projector file. See
the FAQ above this one for more details.

65. I want the desk.cpl file (Display Properties) to launch when I click on a button in my movie. Is this
possible ?

Yes sure. You will need to write the following 

[START] 
Application=rundll32.exe 
Parameters=shell32.dll,Control_RunDLL desk.cpl 
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Please see the example file below.

66. How can I open a file Maximised or Minimised when it has been launched ?
JStart allows you to open any file Maximized or Minimized. i.e Word Documents, PDF's, PowerPoint
file etc. All you need to do is specify the name of the file you want to print in the File box then add the 

/startmaximized - to Maximize 

/startminimized - to Minimize 

command in the Argument Box 

Download the example file provided.

67. How can I automatically print a pdf file ?
JStart allows you to print any file that supports DDE printing. i.e Word Documents, PDF's, PowerPoint
file etc. All you need to do is specify the name of the file you want to print in the File box then add the
/print command in the Argument Box 

Please download the example file.

68. Can you show me how to use JStart to launch a browser that has links to files on my CD-ROM ?
See the example file below.

69. How do I print a text file within a Flash Projector file on Win95/98/NT/ME/2000/XP ?
Using JTools - JStart. 

1. Start JHelpor. 

2. Press the Add command + 

3. Select JStart from the list of JTools available. 

4. Select Use Parameters. 

5. Under the heading 'File' write 

For Win 95/98 machines. 

WIN%\write.exe 

For Win NT 

SYS%\write.exe 
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You will have to create 2 different buttons 

Click here to print if you are using Win 95/98 and 
Click here to print if you are using Win NT 

if you can't determine what Operating System the user has. 

6. Under the heading 'Arguments' write 

yourtextfile.txt /p /close 

where yourtextfile.txt is the name of YOUR text file, Remember to keep it in the same directory as the
projector file. Otherwise different if you know where the text file is. 

/p prints the text file 
/close closes write.exe 

7. Optional, enter an Error Message something like, 

'Whoops cannot print text file' 

8. Press OK 

9. Then the preview button to see it in action. 

10. If you are happy with the results then press the Copy button and then when in your *.fla copy the text
into the Arguments section using the FSCOMMAND , Exec.

70. Why do I need to use JWeb when I can use 

getURL("http://www.flashjester.com") 

?
The advantages of using JWeb rather than GetUrl, is that 

1. It will work on all Windows operating systems. 

2. The browser window will always appear on top of the projector file and not behind it. 

3. Each link you load up will open in the same browser window. 

4. It's FREE.

71. Does JWeb support the POST command?
No, you will have to use the POST command in GETURL in Flash.
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72. I have Flash and the web and e-mail links work fine when I create a projector file. Why do I need
JWeb and JEmail?

JWeb and JEmail's intended use was with Flash 3, as the projector files created in there had the web and
e-mail links disabled. JWeb and JEmail do also however work with Flash 4 or 5 if you so wish to use
them. One of the advantages of using JEmail for you e-mail links is that you can also specify the subject
of the e-mail. 

Something which you might have also have found between the two versions of Flash is that the projector
file player is actually alot bigger than its predecessor adding around 100kb more. If you are not using the
extra features in Flash 4 or 5, then it is advisable that you use Flash 3 and the JTools as each JTool is
only 20kb in size and you only need one copy of each no matter how many links you create using them.

73. How do I delete the Shockwave/JPEG/ Real audio files from my cache after I have view/copied
them?

The browsers will automatically clear files in cache after a certain amount of time, but with Woof you
can choose to delete these files. To do this, you must first search you desired path for the file type of
your choice. When the files are listed, you can use the check boxes at the side to choose which ones you
wish to delete. Once you have selected them, either right click on your mouse and select delete from the
menu that appears or go to the file menu and select delete. 

Also, after you have copied some files, Woof will then ask you if you wish to delete these. Selecting Yes
will delete them from the folder you copied them from. Selecting No will return you back to the list not
deleting any files.

74. Does Woof display Flash 3, 4 and 5 files?
Yes, it will display all flash files, no matter what version.

75. When I finish surfing the web, I load up Woof to copy the Shockwave files I have viewed online
to another director. However, when I search for them, they are not all there. Why does this happen?

When you browse the web, all the internet documents, images, Shockwave movies etc. are stored in the
temporary internet folders on your harddrive (cache). The maximum size that these folders can be are
defined by the internet browser. If it goes over this amount, it starts to delete old temporary internet files.
So, if you find that not all the Shockwave files that you view online are being kept, perhaps your
browser has set the size of the cache folder to quite a small size. You can simply change this by going
into the browser's properties and changing the size of these cache folders. Another, more simple way to
get round this is to use Woof just after you have viewed a Shockwave file. This will almost guarantee it
will still be in cache.

76. This preview window is too small to see the Shockwave in detail. Can I view it larger?
Yes you can. The point of the preview window is just so you get a rough idea of what the Shockwave
movie looks like. To view the Shockwave in a large window, right click on the desired Shockwave
movie, and select open. This will then open the Shockwave in the Flash Shockwave Player.

77. Do you issue an invoice that I can use officially in my country ?
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Yes, sure you can. You will be able to print the invoice online when you register the product. Look out
for Print Invoice option.

78. What services do you offer?
We offer the Creator Express Service which involves putting together your screen saver. You send us the
Projector File and the graphic for the setup box and we'll do the rest. We will convert it to a screen saver
using your graphic to make a custom designed and shaped setup box. This will then be packaged up in a
setup file all ready for distribution. You can get all this for just $99! You will be free to distribute your
screen saver as many times as you want. You will also get a massive $100 discount on Creator which is
normally $695, you get it for just $595!!!!! 
<a href="http://flashjester.com/services/creatorexpress/index.htm">Click here for more info.</a>

79. I can save text using JSave with Flash MX projector files ?
Yes you can. You will have to use JSave and Jugglor together in order to do this. 

Remember to look at the ActionScript very carefully and don't forget to add the EncodeForJugglor
function. YOU MUST ADD THIS. 

Also DO NOT USE underscores in your filenames.

Please download the example file to get a better understanding.

80. Can JWeb and Jugglor work together ? 
Can I make JWeb dynamic ?

Yes sure you can. 

<a href="http://www.flashjester.com/?section=faq&cPath=14_22">Click here for further
information</a>

81. I need help in using JWeb with Flash MX.
Please download the following JWeb example.

82. How do I save multi line text using JSave and Jugglor in MX ?
See the example below.

83. Why do I need to use JMapi when I can use JEmail of free ?
Well simple.

It allows you to do more than JEmail does.

1. Allows you to send attachments.

2. Works with ALL email clients. i.e Outlook, Outlook Express, Lotus Notes, Eudora and Netscape
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Mail. JEmail doesn't work too well with Lotus Notes.

3. Support Line breaks.

4. Much more stable.

See the example files provided.

:\Program Files\FlashJester\JTools\JMapi\MX

84. All I want is to put in a carriage return so I can get a space between lines in a standard txt file,
these created txt files will be used by another program. Is there a way or a work around?

Yes, you can by using the %CR command. See JSave Help file -> Setting up JSave -> Additional
Commands i.e %LOCAL, %TIME, %DATE for more info.

Please download the example file.

85. How can I open a new window like a popup from a Flash file inside a html file ?
Visit... http://www.flash-db.com/PopUp/

Create the window with the features you want or don't want!, generate the code, and simply copy &
paste the generated code on your Flash button. No html stuff envolved here. Everything's in the Flash
movie.

86. How far back has Windows Media Player been packaged with the windows operating
system(win95, win98, win2k)?  Does JMOVIE only work with certain versions of Windows Media
Player?


WMP - Windows Media Player comes with all the Windows operating systems.

JMovie is designed and will work with any WMP version, including the one 
used on Win95. In the end, it will work even without WMP installed, then 
it will use the old MCI interface. Some features may work not so well then.


87. What is the difference between the Standard and Pro version ?
Creator Standard
Create an unlimited number of screensavers but you can only distribute 10,000 of each screensaver you
create.

Creator Pro
Create and distribute an unlimited number of screensavers 

88. I have a Flash file which uses the FSCOMMAND - AllowScale=False. 

How can I make my movie files fixed within the Flash area on all resolutions ?
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You will need to use JMovie and Jugglor together for this. 

JMovie -> Position Size -> Relative to Flash - Checked 

JMovie -> Position Size -> Fixed flash size - Checked -> Enter in the size of the Flash file - Width x
Height 

Please download the example source file to see how this is achieved.

89. Is there are way to convert swf to fla ?
Look at

ASV
http://buraks.com/asv/index.html


90. I think I have an old version of the stand alon Flash Projector player. If there is - where can I find
it?

Yes sure go to the Macromedia site

http://www.macromedia.com/support/flash/downloads.html


91. I want the HTML out of the Juggled Projector while still being able to link to AVIs, PDFs, and PP
outside of the Juggled Projector and to not need FlashPlayer installed on the user's machine. Is this
possible?

1. Download Jugglor from www.jugglor.com 
2. Create the new JStart link in Jugglor - JTools 
3. Select "Use parameters" 
4. In the File box type LOCAL%MYHTMLFILE.HTM. This declares the html to be opened. 
5. Copy and paste the command into the Flash FLA file. 
6. Export the SWF and then patch it (Jugglor - JTools - Patch Movie). 
7. Create a Projector file and assign this in Jugglor - Flash Details - Flash Projector file 
8. When you press build it will compile ONE Juggled file containing JStart and the Projector file. So all
you have to do is distribute one file. 
9. Make the links to PDFs, AVI's etc. in the html files have no paths just the files name and maybe a
subdirectory if you can created one. 

We recommend you download the sample file from 


92. 1. I want to launch the cdplayer.exe in Win98/2000 ... or the wmplayer.exe
in WinXP with the same Button in a Flash projector application with JStart.

2. I want to start from a Flash projector file located in the data-section
of a CD-Extra the Audio-Tracks in the audio section of this CD.
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Can you tell me which commands for jstart I have to create.

And at least: How can I avoid the error messages, when the apllication (e.g.
wmplayer.exe) indicated in a Jstart command does not exist on PC?


We suggest you just specify the name of the *.cda file on your CD. This will
load the audio track with the default CD Player it has been assigned to.
This will be the best option

See example file.

93. Do you have JWeb for the Mac?
No we don't and you don't need it. You can use AppleScript

See 

tell application "Finder"
   open location "http://www.myurl.com"
end tell

Read the posting on FlashKit forums if you need more information.

http://www.flashkit.com/board/search.php?&action=showresults&searchid=941512



94. How do I save a text file to a floppy disk?
You will have to write something like this
 
EncodeForJugglor('JSAVE.EXE a:\\demo.txt 'Textbox1='+Textbox1)

See example file provided.

NOTE: Remember that flash uses the \ as a prefix for special characters. \n is a new-line for example. So
\ must be coded as \\. This is Flash, not JSave requirement.


95. How do I get access the My Application Data directory? I want to save a text file there?
You can now use the new command in 1.2

AppData%

which will give you access to

C:\Documents and Settings\UserName\Application Data folder.

Look at example file provided and please read the 

JSave Help -> Setting up JSave -> Additional Commands
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96. How do I get access the My Documents directory? I want to save a text file there?



You can now use the new command in 1.2

MYDOC%

which will give you access to

C:\Documents and Settings\UserName

Look at example file provided and please read the 

JSave Help -> Setting up JSave -> Additional Commands



97. How do I get access the Shared Object Directory, where the *.sol files are saved? I want to save
a text file there?

You can now use the new command in 1.2

MYSOL%

which will give you access to

C:\Documents and Settings\UserName\Application Data\Macromedia\Flash Player\localhost

Look at example file provided and please read the 

JSave Help -> Setting up JSave -> Additional Commands



98. I'm trying to get an exe to launch from a Flash MX projector file, and it's not working, did I do
something wrong here?

on (release) {
    fscommand("exec", "myprojector.exe");
}

For Flash MX the exe you want to launch must be in a folder called fscommand and that folder must be
located at the same level as your original file you are calling from. The folder name is not included in the
argument however, the script stays the same as listed above. 

Download the example file below.

If you want to launch other types of files i.e word, pdf etc take a look at
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http://jstart.flashjester.com

Please take a look at the example <a
href="http://www.macromedia.com/support/flash/ts/documents/fscommand_projectors.htm"
class=allocation target=_blank>files</a> provided and the Macromedia site.


99. How does one send data from a projector to an email without the use of an email client mucking
up your interface...?

You and use PHP and Flash to send emails.

See

http://www.sephiroth.it/tutorials/flashPHP/email/

100. Does JMapi support multiple attachments ?
Yes it's possible to have multiple attachments

You have to use the following syntax

Parameter3=FILE1<#00>FILE2<#00>FILE3

where FILE# are the paths of the files.

i.e

Parameter3=C:\Temp\image1.JPG<#00>C:\Temp\image2.JPG<#00>C:\Temp\image3.JPG

so just add <#00> between files.

That will do the trick.

101. Can you add HTML tags to the body of the email ?
Sure it's possible see the following example

[MAPI]
Address=support@flashjester.com
Parameters=test
Parameter2=<html><body>title : this is a test<br><br></body></html>
Parameter3=
Error=error

102. Can you load text into the body from a text or html file ?
Yes we've just added this into the latest version of JMapi.
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Syntax : FILE:<filepath>

Example 1
FILE:bodytext.txt
where bodytext.txt is in the fscommand directory

Example 2
FILE:..\bodytext.txt
where bodytext.txt is in the same directory as the projector file

Please look at the example file

103. I am using Jugglor and JMapi. I want to be able to have multiply attachments and also want to
load a text file in for the body part.

Is this possible ? 
Yes it is.

Body

Syntax : FILE:<filepath>

Example 1
FILE:bodytext.txt

where bodytext.txt is inside the Juggled file

Example 2
FILE:local%bodytext.txt

where bodytext.txt is in the same directory as the Juggled file

Multiply Attachments

You have to use the following syntax 

FILE1<#00>FILE2<#00>FILE3 

where FILE# are the paths of the files. 

i.e 

images\image1.JPG<#00>images\image2.JPG<#00>image3.JPG 

the ini file will look like this

Parameter3=local%images\image1.JPG<#00>local%images\image2.JPG<#00>image3.JPG 
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where image1.jpg and image2.jpg are external of the Juggled file and image3.jpg is inside it.

so just add <#00> between files

Please download the example file.




104. How can I create ICON files *.ico ?
We recommend you use

Axialis IconWorkshop

http://www.axialis.com

It's brillant.




105. Do you have JStart for the Mac ?
No because you don't need it. You can use ActionScript

Read this

Create an AppleScript that opens the file and simply call the AppleScript from Flash using an
fscommand.

here is the script:
copy and paste the following into the AppleScript editor

tell application "Finder"
  activate
  select file "yourfile.mov" of disk "YourDisk"
  open selection
end tell

(simply change the name and extension of the file and disk to meet your needs and leave the " ")

then save the script (i used classic applet and it worked well) as: "your_applescript"

For this solution to work correctly (simply) you need to make a disk image, name it and drop your files
inside. Be sure that the "YourDisk" string matches the exact name of the disk image you have just
created.

code in Flash:
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on (release) {
fscommand("exec", "your_applescript");
}

the AppleScript and files should be in the same folder for the sake of simplicity (once you get it
working, then you can play around with changing the location of your 'support' files and the qualified
path within the script

If you want more details on this search FlashKit forums 

http://www.flashkit.com/board/search.php?&action=showresults&searchid=941512

Just to add to the above.

The applescript must be saved as an application, set to ‘run only’, and with the extension visible. It is
handy to keep the files in the ‘fscommand’ folder, so you must call it too:

tell application "Finder"   
  activate
  select file "your_file.pdf" of folder "fscommand" of disk "Your_CD_image"
  open selection
end tell

Save this as, for example, ‘your_applescript.app’

and the button code must read:

on (release) {
    fscommand("exec", "your_applescript.app");
}




106. Does the JMAPI tool work for Lotus Notes R5 which is not MAPI compliant ?
No JMapi only supports email clients that are MAPI compliant.

107. I'm having problems reading the JMV.txt to retreive the status of the Movie, using JMovie and
Jugglor together. Can you help ?

Yes sure.

Use the LoadVariables command to load the text file

i.e
    loadVariables("JMV.txt", this);
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Also read 

JMovie Help File -> Additional Features -> Retrieving status with JMV.txt

Please download the example file provided.

108. How do I create a photogallery using Flash ?
Here is a great tutorial.

http://www.kirupa.com/developer/mx/photogallery.htm



109. What is Jugglor?
Jugglor turns Projector files into full-fledged programs. It modifies existing projector files by making the
projector file full screen, makes the escape key the key to exit the file, changes the icon for the file and
disables the menu that comes up when you right click. It then packages this all up again into an EXE and
a DLL.

Read more about the features here :

http://www.jugglor.com

110. I am having problems using the MainRatio and selecting a print area using Flash MX. I need
some help.

Please take a look on the example file provided. It includes all the source file.

Remember to extract all the files in the default directories.

111. Is there are Mac verion of JWeb ?
You really don't need to use a Mac version just use

getURL("http://www.flashjester.com")

but if you are facing some problems, you can use Applescript

set theURL to "http://www.flashjester.com.com"

tell application "Finder"
activate
open location theURL
end tell



112. How can a READ variables from My Documents folder ?
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You need to use the MYDOC% commmand

which will give you access to 

C:\Documents and Settings\UserName 

Look at example file provided and please read the 

JSave Help -> Setting up JSave -> Additional Commands 

113. Is there a Mac version of JEmail ?
You better off using the getURL(mailto:support@flashjester.com) but if this doesn't work you can use
AppleScript

open location "mailto:someone@somewhere.com"


114. How can I add copy protection to my Projector files ?
Take a look at 

PC Guard for Win32 on http://www.sofpro.com/ 

their software works with Juggled files. 

It gives you MUCH more control and security features you can ever imagine.

115. I show my Flash documents via the Flash projector (.exe) on a classroom screen using a Dell
AV projector.  So there is no acess to the Web and programming a popup window with a URL will
get me nowhere.  Instead, I'd need to launch window content I have prepared in advance.

Can JProWeb find a document on my hard drive or does it only accept URL's, and if so, is there a
"work-around" this?


Yes sure you can load local html files using JProWeb

Download an evaluation copy from

http://jproweb.flashjester.com

See the following examples

Standalone
C:\Program Files\FlashJester\JTools\JProWeb\Mx\Example 1

With Jugglor
C:\Program Files\FlashJester\JTools\JProWeb\Mx\Example 2
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Read the help file also

C:\Program Files\FlashJester\JTools\Source\JProWeb.hlp

Setting up a JProWeb Command

Hope this helps.



116. Is it right that JSave can only write 255 charachters to a text file?
Yes it is limited by the length of the command line.

We recommand our latest JTool called JSystem.

http://jsystem.flashjester.com

It has a command called 

SaveToFile

which has no limit to the size.

JSystem Help -> FSCommand List -> File Manipulation -> SaveToFile

This will help

117. I was trying out your JWeb and wondering if there is anyway to set the browser window to open
maximized? 

Yes it is.

You will have to use JStart and the /maximised command.

Download an evaluation copy from

http://jstart.flashjester.com

and then look

C:\Program Files\FlashJester\JTools\JStart_JWeb_JEmail.hlp

JTools Settings -> JStart - Opening a file Maximised...

In the File paramater add the URL instead of a file name.


118. What are Flash Tools ?
Flash Tools are third party softares that give you that extra functionality and customisation to the Flash
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SWF format. We provide such tools.

You can find other such tools here

http://www.swftools.com


119. What does SWF to EXE mean ?
Basically it means converting your SWF to an application that can be run on any machine. These are
usually called Projector files.

To do this in Flash you would go to

File -> Publish Settings

The advantage in using a Projector file is that it has the Flash Player built inside it. So you don't have to
worry about end users not having the flash player install. Minimise the extra support for your clients.

120. How can I play a Macromedia Flash animation in PowerPoint?
Please read this

http://office.microsoft.com/en-us/assistance/HA010348071033.aspx

and

http://www.ellenfinkelstein.com/powerpoint_tip.html#flash

121. How can I open a new window like a popup from a Flash file inside a html file ?
Visit... http://www.flash-db.com/PopUp/

Create the window with the features you want or don't want!, generate the code, and simply copy &
paste the generated code on your Flash button. No html stuff envolved here. Everything's in the Flash
movie.

122. How can I put carriage returns into a text file using JSystem -j:sy:savetofile command ?
Simple add the chr(13) to your variable

i.e.

TheString='Line1'+chr(13)+'Line2'

or a shorter way to insert new line is:

TheString='Line1\rLine2';

See the example file below.
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123. Here are some additional tips when using JStart provided by Joe B. 
Thanks

1) Publish as a EXE not SWF. SWF or CTRL+ENTER emulation will not work. 
2) Do not include path (c:\fscommand\...) in the fscommand to launch the executable. 
3) Do not include path (c:\fscommand\...) in the "Application=" statement of the ini file. 
4) EXE that you publish should be in the parent of the fscommand directory.

124. How do I find out the CD-Rom Drive letter because my links work on hard drive, but not when I
put it on CD?

You need to use JStart with parameters and rather than defining a full path (e.g. D:\files\mymovie.mpg)
you need to put in the relative path (e.g. if your JStart and SWF are in D:\ , you'd use
"files\mymovie.mpg"). If you are using Jugglor, try using the Current Directory feature or you can use
the LOCAL% command (see Jugglor Help file -> Tips).

125. I brought JStart and have successfully used it in my Flash MX movie to launch a PDF within its
application and also another .exe file. However, this CD needs to be cross platform. I know that I
can build an "applescript" that I can launch from an fscommand in Flash (although I'm not all
together sure what Applescript is or how to use it....). However, what I wonder is, how would that
affect my button? Would I have to run some sort of automatic test of the user's computer to see
whether they're using Mac or PC before the flash movie even launched? I just wondered how I could
have both of the fscommands in my Actionscript: Like "Do this if they have a PC, and do this if they
have a Mac." Is that possible? I'm really not too good with Actionscript. 

You will have to create 2 different FLA's one for the Mac and PC and publish them as Projector files.
The PC FLA with JStart commands and the other with Applescript as described below.

http://www.flashjester.com/?section=faq&cPath=28_41#232

For creating a hyrid CD and Autoruns for both platforms read this

http://www.flashkit.com/board/showthread.php?s=ffa1834a93ea5d8f5c4c8f9e97f34191&threadid=5003
26

Hope this helps.


126. Do you offer any custom solutions?
We can create and produce a screen saver to your specifications and requirements. Please contact us for
more details on support@flashjester.com

127. Can I use the copy and paste commands in Flash using Actionscript? We want to copy text in
the clipboard and paste it in the Flash file?


Yes sure this possible.

See you can use the

CopytoClipboard
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and

GetFromClipboard

See

JSystem Help -> FSCommand List -> File Manupulation -> CopyToClipboard / GetFromClipboard

See the example file below

128. How I could create copy and paste buttons for input text fields (as some novice users of
software would not think to use ctrl+c / p or right click copy/paste)? 

Flash Actionscript doesn't support this. You can use our JTool - JSystem to do this.

See

JSystem Help -> FSCommand List -> File Manupulation -> CopyToClipboard / GetFromClipboard

Look at the example file provided below.



129. What is the best way to optimise flash to video ?
FlickerLab have written a very good article on this.

Click on

http://www.flickerlab.com/flashtovideo/


130. I want to read all the files names from a given directory in Flash Projector. How can I do this ?
You can use JSystem to read a folder and much more.
 
Download an evaluation copy from
 
http://jsystem.flashjester.com
 
Then read the JSystem Help file 
 
Home > Command -> ReadFolder 
 
look at the example files provided.

131. How can I reduce the size or optimize the size of my SWF ?
Please look at the following tools
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Flash Optimizer
http://www.flashoptimizer.com

Sparkle SWF Optimizer
http://www.flashkeeper.com/so.htm

Swift Optimizer 
http://www.swishsoft.com/swiftoptimizer.htm

Optimaze!
http://www.erain.com/products/optimaze/

132. How can I create a Flash MP3 player ?
Please visit this website, it gives you an indepth tutorials how to do this.

http://www.kennybellew.com/tutorial/



133. How can i browse SWF file in Windows Explorer in the thumbnails view ?
SWF Live Preview 1.0 

SWF Live Preview is aimed to help you preview Macromedia Flash files using standard built-in
Windows Explorer. Excellent design, easy-to-use interface, powerful features and unique capabilities
make SWF Live Preview indispensable application. And it is free of charge! You won't find anything
similar!.

http://www.eltima.com/download/swf-live-preview/

134. When I execute JSAVE does the function return a value to show it is finished? ResultVar?
No JSave cannot do this.

BUT you can look at JSystem - SaveToFile command.

http://jsystem.flashjester.com

Download the evaluation copy and look at the help file.


135. How can I keep all these JProWeb and html files into one EXE ?
Please read this

http://www.flashjester.com/index.php?section=faq&cPath=14_56_74

136. How do you make those litte icons in the address bar, you know to the left of where you put the
address?
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Take a look here

http://www.favicon.com

137. Is it possible to build dynamic JSTART statements. For instance I have a number of different
.pdf's that are opened from different sections in my flash app. It would make my life much easier if it
were possible to build a function on my _level0 movie to run a JSTART command and just pass the
file name when calling the function. 

i.e.: function openDoc(docName){ 

fscommand ("exec", "JSTART"+ docName +" /error=error" );
Yes it's possible, you will need to use JStart with Jugglor.

Read this

http://www.flashjester.com/index.php?section=faq&cPath=14_56_26#282

138. How can I use JPrintor and Jugglor together?
Take a look at this section

http://www.flashjester.com/index.php?section=faq&cPath=14_47

139. What can Jugglor be used for?
There are many different uses for FlashJester Jugglor. By clicking below you can see a list of  possible
uses for Jugglor.

http://www.flashjester.com/index.php?section=tricks_jugglor_jugglor30plus

140. Do you have any Flash Tips ?
Yes go to Macromedia Support Area

http://www.macromedia.com/support/

Kirupa
http://www.kirupa.com/

FlashKit
http://www.flashkit.com

We recommend you also to our links section

http://www.flashjester.com/index.php?section=links
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141. How do you configure Creator for a silent install ?
We have tried (Creator -> Build -> Top Left -> Uncheck all expect for Welcome, Destination and
Message Dialog) but it won't let us uncheck the Welcome Page and Message Dialogs. 

Yes this is not possible with Creator, you will have to use another third 
party installation to create a silent install. 
  
Read the following 
  
http://www.flashjester.com/index.php?section=faq&cPath=6_10 
  
and here are list of FREE Installers 
  
http://www.flashjester.com/index.php?section=faq&cPath=50#225 
  
or if you have Wise or Installshield you can use them. 


142. On one machine when I use JProWeb it opens up the notepad instead of the browser with all
the JProWeb settings ?

Check is the file association of *.HTA and *.HTML files, this is what JProWeb uses too.
You should open this file with IE . 

143. Why doesn't the following flash exec fscommand work ?

fscommand("exec","mydoc.pdf")
Flash Exec Fscommand only supports EXE's and no other type of extension. You can use JStart to
overcome this problem.

Try it

http://jstart.flashjester.com


144. I would like to use the In-Memory file support in Jugglor, where I can hide the text file in
memory away from the user, now can I load that file using JSystem and the LoadfromFile command
?

Yes you can, you just add the prefix

INMEM%, 

so 

"Filename"

will be

"INMEM%Filename"
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Take a look at the example file provided.


145. Does Creator support Dual Monitor ?
Not currently, the new version 2.0 will support dual monitor.

146. I am having problems carriage returns and linefeeds with JSave ?
We found the problem.

After tracing the encoded string, it converted it into _d and _a.

Looking at the EncodeForJugglor function, :

s=ord(c).toString(16);
if (ord(c)<10) s='0'+s;
Result += '_'+s;

Te second line should be: if (ord(c)<16) s='0'+s;

so

s=ord(c).toString(16);
if (ord(c)<16) s='0'+s;
Result += '_'+s;

We have updated the Jugglor and JSave Help file.


147. I need help using  Jugglor and JMapi together to generate an email sent to an address entered
by the user using a form the Projector file AND attaching a document. 

Is there a way to use the JMapi  tool that will allow sending an email attaching a document but
allowing the user to enter the email address with a form (located in the Projector file)?

Yes sure this is possible.

Please look at the example file below.

148. How can I convert my Powerpoint Presentations into SWF files ?
Flash Spring
http://www.flashspring.com

Open Office - Impress - FREE
http://www.openoffice.org/

IceSlide
http://www.iceweb.com
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PowerConverter
http://www.presentationpro.com/products/powerdelivery/PowerCONVERTER.asp


149. How do I convert my Flash movie to a DVD ?
You can use Macromedia Director 

Read this

http://www.macromedia.com/devnet/mx/director/articles/flash_dvd.html

150. How do i open a word or pdf document from my flash file thats on my website ?
Use

getURL("your word or pdf document path", "_blank");

That's it, no extra tools required.

151. I have 2 Excel documents that I am putting on a Flash CD with about 20 Word and 40 PDF
documents. Everything works fine except the 2 Excel documents don't open. Excel starts up but I
get a 

'"filename.xls" could not be found.'

error. 

I can open the file by clicking on the file and I have double checked the spelling and location.

JSTART.exe "/Financial_Forms/document.pdf"

Are there any special problems with .xls documents?



You have forward slashes, you should always use BACKWARD SLASHES

i.e

JSTART.exe "\Financial_Forms\document.pdf"

That will do the trick.

152. How do I  use JSave to save more than one variable and then how by using loadvariable
command to split and get them to load them?


Here

Variable1=xyz&Variable2=abc& etc.
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Then the loadvariable command will split them automatically

153. How do I change the Flash Cursor or something people call it the Flash Pointer?
First of all create the image you want and save it as an mc cal it "my_cursor".

Then drag an instance of this mc just off the side of the stage and give it an 
instance name of "my_cursor"

Copy the following code into the first frame

 Mouse.hide();
 my_cursor.onMouseMove = function() {
     this._x = _xmouse;
     this._y = _ymouse;
     updateAfterEvent();
 };

We is a posted example-

http://www.nepeanmedia.com.au/flash/flas/my_mouse_flash_8.fla

154. How to a convert my Flash SWF file to Video ?
Here is an excellent site that describes how to convert the SWF to Video

http://www.flickerlab.com/flashtovideo

155. Do you have any Flash Tutorials for me ? I am a beginner
We don't but these guys certainly do

http://www.sephiroth.it/tutorials.php

http://www.actionscripts.org/tutorials.shtml

156. How do I use Flash to connect to mySQL ?
Read these

http://www.webmonkey.com/webmonkey/programming/php/tutorials/tutorial2.html

http://www.actionscripts.org/tutorials/beginner/Integrating_Flash_and_mySQL/index.shtml

http://www.sephiroth.it/tutorials.php



157. I am having problem using JProWeb. i get the following error
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"This file does not have a program associated with it for performing this action. Create an
association in the Folder Options control pane.


Check that the file association of *.HTA and *.HTML files, this is what JProWeb uses too.

You should open this file with IE .

Windows Explorer -> Tools -> Folder Options -> File Types ->  HTM Application

158. How can I print a document i.e Word, PDF or Text file?
You can use the /Print command that comes with Start it prints any document that supports DDE
printing.

Please read

JStart JWeb JEmail Help File -> JTool settings -> JStart - Using the Print Command

and download the example file given.

159. How do I print a PDF file from Flash Projector ?
JPrintor will not do this. You need to use JStart please follow this link

http://flashjester.com/?section=faq&cPath=28_41#352

160. Can JStart and Flash MX or Flash 8 work with Jugglor ?
Yes sure you can. 

http://www.flashjester.com/?section=faq&cPath=14_26

161. How do I Launch Windows Explorer to open at a certain folder and drive ?
You will need to use JStart

1. Create a new JStart link in JHelpor 
2. Select "Use parameters" 
3. In the File box type WIN%\EXPLORER.EXE. This declares the program to be run 
4. In the Arguments box type in location that you want Explorer to open up in eg. d:\temp 

When JStart is then run using these parameters, it will run Windows Explorer with the directory
D:\Temp in the main view. 

Now if you wanted to open up Windows Explorer in the current directory where the Projector file
resides i.e in the CD-ROM or a sub-directory on the CD-ROM then you will have to use Jugglor along
with JStart. 

1. Download Jugglor from http://www.jugglor.com 
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2. Create the new JStart link in Jugglor - JTools 
3. Select "Use parameters" 
4. In the File box type WIN%\EXPLORER.EXE. This declares the program to be run 
5. In the Arguments box type in LOCAL% (if in a sub directory i.e sub1 then use LOCAL%sub1) 
6. Copy and paste the command into the Flash FLA file. 
7. Export the SWF and then patch it (Jugglor - JTools - Patch Movie). 

8. Create a Projector file and assign this in Jugglor - Flash Details - Flash Projector file 
9. When you press build it will compile ONE Juggled file containing JStart and the Projector file. So all
you have to do is distribute one file. 

We recommend you download the sample file from 


162. Why don't the zip file links to your downloads don't work on Firefox?
This is the firefox bug. It can't read zip files. However, all other files download fine.

You must download and install addon
https://addons.mozilla.org/extensions/moreinfo.php?application=firefox&category=Popular&numpg=10
&id=201

to fix this problem.

After installation, restart firefox and load page again. Right click on the link and select Save Link with.

163. I am having problems saving text to my XML file using JSave. Seem I am having problems with
the double quotes.

Please download the following example file. This example does exactly this.

164. I need help using JProWeb. I need to open a borderless window url from a Projector file ?



First of all read the help file given.
 
Start -> All Programs -> FlashJester -> JTools -> JProWeb -> JProweb Help
 
Setting up JProWeb Command -> Setting up for Flash MX
 
Follow the step by step.
 
Then look at the example files given
 
C:\Program Files\FlashJester\JTools\JProWeb\Mx
 
Also read the online FAQ
 
http://www.flashjester.com/index.php?section=faq&cPath=28_49
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Hope this helps.

165. The code works just fine in v2.1, I don't know if it's because of the version change or what.

This is our code :

MakeXMLMap();// our function to make xml content=gXMLDoc.toString(); //make
a string out of our xml document //write it down to temp.xml
fname="temp.xml";

fscommand("exec",EncodeForJugglor('j:sy:savetofile:"'+fname+'","'+content+'"
,ResultVar'));

Is there something wrong with this code or is the new version clash with Jsystem? Other
functionality of Jsystem works just fine (Save/load dialog)



Each " symbol in the content must be encoded with two " symbols, because one symbol will terminate
the string.

166. I have a main projector file. Now I want to use addtional SWF's to load my web pages and links
with JProWeb. Is this possible ?

Yes it sure is.

See the example below.

Please please please. Go through the 2 FLA's files so you can understand how it all works. Look at the
directory structure and why its that way.

167. I get the following message on my Flash web page.

"Click to activate and use the control" 

How can i remove it ? 

Read this for all your answers

http://www.amarasoftware.com/flash-problem.htm

or

http://activecontent.blogspot.com/

168. How do a convert my DVD to Flash FLV ?
To turn your DVD into a Flash FLV then following these instructions.

1. Copy the .VOB files from your DVD to your hard drive.  DVD video 

Page 38



Flashjester  FAQ.

is MPEG, so change the file extension to  nameofvobfile.MPG. 

2. Use this freeware software called DVDx.

  DVDx allows you to convert your own DVD to VCD2.0/SVCD1.0/AVI/WMV 
  in one step (Including multiplexing, splitting). It produces very 
  good quality movies in AVI/MPEG1/MPEG2/WMV9 format and you don't 
  need to have 5GB free on your hard disk !

Download it from here

http://prdownloads.sourceforge.net/dvdx/DVDx_2_5_1_setup.zip?download

3.  Open in Flash 8 Video Encoder, create flv file.


169. I have a Flash Projector EXE file, I don't have the oringal FLA, is there anyway to recover the
SWF from the EXE ?

EXE to SWF ?
Yes you can.

 Look at these tools

SWF2ExE
http://www.flashkeeper.com/fk/swf2exe.htm

SWF Scanner
http://www.livetronix.com/products/swfscanner/

170. I am looking for a method to print (whether it be a local file, or a frame in Flash) from a Flash
projector. The project I will be using this for will be a Kiosk which will print maps to a local printer if
the user so chooses.

The application I am building will be a fullscreen Flash application and we would like to bypass the
printer dialogue box when the user touches the "Print" button within the Flash app. (ie. Press button
once > Out comes a page)

Does JPrintor allow me to do this?
For Local File Printing

We recommend you use JStart with the /print command. This will print a doc or pdf file without any
dialog boxes.

Read this

http://www.flashjester.com/?section=faq&cPath=28_41#352
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and look at the example file given.

Frame Printing

To print a screenshot then use JPrintor. It will by pass the Printer Dialog, just make you don't have this
option checked

Other -> Show Printer Dialog  



171. How do I open a powerpoint presentation file *.pps using a Flash Projector file?
You can do this using JStart.

http://jstart.flashjester.com

See the example file beloiw

172. We are having problems opening a Powerpoint File pps or ppt file in a Flash Projector using
JStart.

We get the following error

"This file does not have a program associated with it for performing this action. Create an
association in the folders options control panel." 

I have installed the Powerpoint 2003 Viewer on this machine which doesn't have Office 2003 -
PowerPoint. On the other machines with Office 2003 it works fine.

This is a PowerPoint Viewer issue and not a JStart. 

The installation doesn't add the PPS or PPT file association in the folders option in the Control Panel.
You have to-do this manually.

Read this if you want to do this

http://ask-leo.com/what_does_this_file_does_not_have_a_program_associated_with_it_mean.html

But this doesn't make sense as you can't do this on all your clients machines.

So we need to find a workaround.

PowerPoint had an option called 'Package for CD'

1. Open the PPS file you want on the CD.
2. PowerPoint -> File -> Package for CD
3. Copy to Folder..
4. Change the name if you want.
5. Press OK.
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Then copy the folder if just created. i.e.

My Documents\PresentationCD

to you working folder.

You will notice that in this folder it has ALL the files you require to open a PowerPoint file regardless to
whether the end user has PowerPoint. The PowerPoint viewer files are all here.
Double click on the play.bat and you will see it open up.

Now you need to go to the JTools section in Jugglor and use JStart. There are 2 methods which we can
use :

1. Open the bat file play.bat
2. Construct the command line in JStart that opens the viewer and PowerPoint file

i.e pptview.exe /L "playlist.txt"

Open Jugglor.

Jugglor -> JTools -> + -> JStart
Use Parameters

Method 1.

File
local%PresentationCD\play.bat

Default Directory
local%PresentationCD

Method 2

Now if you don't want to see the MS-DOS black box appear before the presentation starts then we an
eliminate the use of the bat files so we have

File
local%PresentationCD\pptview.exe

Arguments
/L "playlist.txt"

Default Directory
local%PresentationCD

REMEMBER :  PresentationCD is the folder where all the PowerPoint files are.
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That's it.

Press the OK button and Close the JTools window.
Press the bottom Copy button next to the Arguments edit.

The paste this into your FLA file.

It will look something like this.

1.
on (release) {
	fscommand("Exec",
"JSTART_20local_25PresentationCD_5Cplay.bat_20_20_2Fdir_3Dlocal_25PresentationCD");
}

2.

on (release) {
	fscommand("Exec",
"JSTART_20local_25PresentationCD_5Cpptview.exe_20_2FL_20_22playlist.txt_22_20_2Fdir_3Dlocal
_25PresentationCD");
}

Publish it and bring it into Jugglor and Build the project.

Now if you have mutliply PowerPoint files, then you don't need to create another folder with the view
inside, but just another playlist.txt file and change the name of the PowerPoint file inside it.

i.e.

playlist2.txt

inside it just has
FlashJester2.pps

Please please download the example file to see if working. It has all the source files you require.


173. How do I use JSave and XML in my Flash Projector ?
We've added as much power as we can to JSave with all the features we have put into it but at the end of
the day it is a tool to help your creativity and do with it what you wish. And that is exactly what Nicolas
S Roy, Interactive Developer for Logient (www.logient.com) did. 

Using our JSave example file that comes packaged with JSave, he modified it to save XML files on the
hard drive!

He has also kindly given us the code so that you can implement it in your Flash files!
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function jSave (srcText, fileName) {
// This is the procedure that
// saves the text
x = "1";
y = "1";
// srcText is the text you want
// to save
tempstr = srcText;
z = length(srcText);
result = "";
Load = z;
while (Number(x)<=Number(z)) {
if (substring(tempstr, x, y) eq " ") {
result = result + "`1";
x = Number(x)+Number(y);
} else if (substring(tempstr, x, y) eq chr(10)) {
result = result + "%CR";
x = Number(x)+Number(y);
} else if (substring(tempstr, x, y) eq chr(13)) {
result = result + "%CR";
x = Number(x)+Number(y);
} else {
result = result + mbsubstring(tempstr, x, 1);
 
x = Number(x)+1;
}
}
x = x;
y = y;
r = result;
// SaveFile is the file name you
// want to save the text as.
r2 = "jsave.exe" + mbchr(9) + fileName + ".txt" + mbchr(9) + "srcText=" + r;
fscommand ("Exec", r2);
}
 
}


174. Will I have to include a copy of JAvi for each Avi I open with it?
Yes that is correct. For each movie you have you will have to create a javi.exe and javi.ini.
Now if you have 100+ this is not  a good solution. 

To avoid this you can use Jugglor and JAvi together, where it will only require 1 copy of Javi.exe which
Jugglor automatically adds to the final exe.

With Jugglor you have a choice whether you want to

1. Keep the avi files inside the final Juggled file
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2. Keeo them outside the Juggled file where you will have to use the local% command. See

JAvi Help -> Flash Support -> Using the LOCAL% command

See the example below.

For more information on Jugglor go to

http://www.jugglor.com


175. Do you have a SWF to FLA tool ?
Look at

Sothink SWF Decompiler MX 2002 Pro 

http://www.sothink.com/flashdecompiler/index.htm

Sothink SWF Decompiler MX 2002 Pro is a tool to browse, view and parse Shockwave Flash movies
(.swf files). It can extract sounds, images, movie clips from a Flash movies. What's more, SWF
Decompiler can decompile the action scripts in a Flash movie and turn them into neat and readable code.
New version supports Flash MX format

and

IMPERATOR FLA generates FLA-files (readable with Flash MX(6) or higher) from the selected input
SWFs (compiled with Macromedia Flash) and thereby makes it possible to alter the content of a SWF
even when the corresponding FLA got lost. Furthermore it gives you the opportunity to extract all
included media-files (pictures, sounds and videos) so you can edit them with other programs.

http://ave-imperator.com

176. Can I recover my FLA from a SWF file ?
Yes you can well part of it.

Read this

IMPERATOR ?FLA generates FLA-files (readable with Flash MX(6) or higher) from the selected input
SWFs (compiled with Macromedia Flash) and thereby makes it possible to alter the content of a SWF
even when the corresponding FLA got lost. Furthermore it gives you the opportunity to extract all
included media-files (pictures, sounds and videos) so you can edit them with other programs.

http://ave-imperator.com

and

Sothink SWF Decompiler MX 2002 Pro 
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http://www.sothink.com/flashdecompiler/index.htm

Sothink SWF Decompiler MX 2002 Pro is a tool to browse, view and parse Shockwave Flash movies
(.swf files). It can extract sounds, images, movie clips from a Flash movies. What's more, SWF
Decompiler can decompile the action scripts in a Flash movie and turn them into neat and readable code.
New version supports Flash MX format


177. When I double click on a Flash SWF file on my PC nothing happens ?
I've installed the latest Flash Player but still nothing.

It works fine on Internet Explorer
There are 2 things you can do here.

1. Publish the SWF file as a Projector file using Flash.

2. You will need have SAFlashPlayer.exe which actually comes with Flash and plays the Flash file.

C:\Program Files\Macromedia\Flash XXX\Players\Release

Double click on this and then close it. Now your SWF files will be assigned to the SAFlashPlayer.exe
you clicked on.

If you want to load SWF's file in different Flash Players i.e. MX, MX 2004 or 8 then find the
appreciated SAFlashPlayer.exe.

Below you will find a link the Flash 8 - SAFlashPlayer.exe


178. What tool can we use for an installer?
Inno Setup is by far the easiest installer to use. You can go from installing it to having your installer
done in ten minutes if it's simple. Writing an installer involves editing a simple text file that is similar to
an INI file. The included editor has syntax highlighting and a great help file. It has a lot of features and
should cover most situations. If you need more functionality it has Pascal scripting. It is open source and
very professional.

http://www.jrsoftware.org/isinfo.php

NSIS (Nullsoft Scriptable Install System) was originally written by Nullsoft, the guys who wrote
Winamp. It creates really SMALL installers -- a full featured installer has a 34k overhead. This is (in my
opinion) it's main advantage over Inno Setup. NSIS is open source and has a lot of documentation.
Writing an installer takes more work, since you have to write the install script by hand. If you have a
complicated install procedure or need the smallest possible installer, NSIS is for you. It has some nice
features like multiple compression methods. If it doesn't have built in functionality that you need, it can
be extended easily with DLLs
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http://nsis.sourceforge.net/

here are some more

http://www.thefreecountry.com/programming/setup.shtml



179. We have Jugglor and Jtools. 

The program will be run from the CD. The main uses of JTools will be to open PDFs and open
specific directories in Explorer. 

I cannot get JTools to work?  

Below are the settings I am using. Please tell me where I am going wrong. 

Open PDF: 
File: C:\Program Files\Adobe\Acrobat 4.0\Reader\AcroRd32.exe 
Arguments: LOCAL%\Reading_Room\Reading_Room.pdf 



OK first of all, make sure you are doing this in Jugglor and not JHelpor. To open a PDF file you don't
have to specify the AcroRd32.exe all you need to do is specify the *.pdf file. 

So select JStart, set to Use Parameter and in File you should have 

LOCAL%Reading_Room\Reading_Room.pdf 

YOU DON'T have to add the extra \ as you have between LOCAL% and Reading_Room. 

Then press OK and the Copy button and paste into the Argument section in your FLA file, export it as a
SWF, then patch it to create a Projector file.

180. I need help using JStart with Flash MX or Flash 8. What to do ?
Read the help file first, located here

C:\Program Files\FlashJester\JTools\JStart_JWeb_JEmail.hlp

Setting up JTool links -> Setting up for Flash MX

Also look at the example files provided here

C:\Program Files\FlashJester\JTools\Examples

F5 - Flash 5
MX - Flash MX 

Use the MX examples for Flash 8 also.
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This will help you get started.

Now if you don't want the files you open to go in the background when you click outside it we
recommend you use Jugglor and JStart together.

Read this

http://www.flashjester.com/index.php?section=faq&cPath=14_56_26#268

Jugglor
http://www.jugglor.com

This will help you get started.

181. I want to create my own Flash CD Player. Can you help ?
Yes, download an evaluation copy of JCD from

http://jcd.flashjester.com

We first of all we suggest you look at the 3 example files given.

Look here

C:\Program Files\FlashJester\JTools\JCD

This will help you get started.

182. How do I Load a HTML file, edit it and then Save it back as a HTML file in a Flash Projector ?
Yes you can use FlashJester JSystem - SaveToFile function todo this

In additional to the EncodeForJugglor command you will also need to use another function called
EncodeDQuotes.

i.e

    fscommand("exec",
EncodeForJugglor('j:sy:savetofile:"local%test.html","'+EncodeDQuotes(mainstorage)+'",ResultVar'));

and the function to encode 

function EncodeDQuotes(x:String):String {
                        var c:String; var EncodedQuotes='';
                        for (var i=0; i<length(x); i++) {
                            c=x.substr(i,1);
                            if (c=='"') c+='"'; // double each "
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                            EncodedQuotes+=c;
                        }
                        return EncodedQuotes;

Please look at the Flash 8 example file to see it working.

183. Can I view IPIX files from my Flash Projector file ?
Yes you can do this with our JTool - JStart

http://jstart.flashjester.com

The ini file should look something like this

i.e

[START]
Application=..\ipixviewer\ipixviewr.exe
Parameters=..\files\bed.ipx

ipixviewer.exe is a standalone IPIX viewer from 

http://www.ipix.com/products_standalone.html

In the parameter section you specify the location of the ipx file.

Now it is very important that you also keep a copy of Ipx32_56.dll in the same directory as the viewer
exe.

Please download the example file to see it working.


184. Why should I pay for JTools when I can use the START and Batch commands for free?
1. When using the start command or batch files, an MS-Dos box appears, this can look very
unprofessional and can be off putting for the user. With JTools there is no MS-DOS box. 

2. JTools works on Windows 95/98/NT/2000/ME/XP/Vista

3. The JTools are simple to set up with the help of JHelpor.

4. Its a clean and professional solution 

5. Each JTool (JWeb, JStart and JEmail ) are only 30kb in size

185. Can I automatically build these Juggled files without any interaction in Jugglor. I would like the
user to select a few settings in my Flash file and then build the new Juggled file based on these
settings.

Yes you can. Read the following
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Jugglor Help -> Advanced Techniques -> Importing & Exporting

this will help you get started.

If you would like more technical help then you can hire our Development Team to help you further.

http://hire.flashjester.com



186. I am using Jugglor to create a presentation on a CD.  It's an auto-run flash projector file (.exe),
but the file is really big.  it takes a long time to load, and my client wants a "loading" screen. 

Would Jugglor give me the ability to have a "loading" screen come up while the rest of the exe was
loading in the background. 

Try using the feature that is built into Jugglor already.
 
Build -> Message during extract

Simple.

187. How do you execute a flash projector file when inserting a CD ?
Say your Flash projector is called 'project.exe', you would create a plain text file called 'autorun.inf'
containing the following:

[autorun]
open=project.exe

You can do this in Notepad.

Then you write this file to the CD on the same level as the .exe file.

It can be bypassed by the user if they hold down the shift key after inserting the CD.

This is for Windows. If you want to do the same for Macs, you'll need to look at the documentation that
comes with Toast.


188. How do I extract swf files from a flash file or even a flash file from a website?
Use this extraction tools.

http://www.19.5degs.com/swfextractor.php#swf-extractor



189. How can put a Flash SWF or a Flash Projector file on a memory stick, flash drive or usb flash
drive and automatically auto launch the flash file when inserted into the flash drive ?
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First of all we recommend you convert or publish the flash file as a Projector file, so it has the Flash
Player built in, as many end user's PCs will not recognise a SWF file.

Then create a plain text file called 'autorun.inf' containing the following:

[autorun]
open=project.exe

You can do this in Notepad.

Then you write this file to the CD on the same level as the .exe file.

For more information on this please go to

http://www.samlogic.net/articles/autorun-usb-flash-drive.htm



190. Is there a way to clear the cache for the player... or load the entire site and it's contents into the
player's memory. If I test it from my local drive, it works fine... On a CD-ROM, the entire site gets
stuck and it chugs along incredibly slow. 

The CD-ROM is composed of multiple SWFs constantly being loaded and unloaded. On a CD-ROM,
for the PC, is the stand-alone player losing memory or something?


Yes, this is because you are running the flash file from the CD-ROM. There are memory issues when
running projector files from a CD-ROM which Adobe have acknowledged (see technotes on the website
for further info), so animation and sound will not play too well. 

See:

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_16591&sliceId=2

We suggest you use Jugglor to 'Juggle' the flash projector file and add the additional swf files in the
'Additional Files' section in Jugglor. 

You can also take advantage of Jugglor's other cool features, edit/remove right click/change icon, menu
bars etc. 

Once you press "Build it" it packs and COMPRESSES (sometimes the Juggled file is smaller than the
original) all the files into one EXE i.e Juggled file. 

Well now when you run the Juggled file, the original projector and all other file included will
uncompress onto the users hard drive i.e Windows/Temp directory. 

This will now give you the smooth playback you originally had. 

Please download an evaluation copy and try it for yourself and see the difference in speed.

http://www.jugglor.com 
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Remember if you are using the LOADMOVIE command and you want to access files outside of the
Flash Projector file then you will need replace it with a new LOADMOVIE command using the
LOCAL%.

See the 

Jugglor Help -> Advanced Techniques -> Using LOCAL%

There you will find an example file also.

Also read this

http://www.flashjester.com/index.php?section=faq&cPath=14_55#47

Good Luck

191. How do I build a hybrid CD for both Mac users and PC users?
Read here

http://www.flashkit.com/board/showthread.php?s=ffa1834a93ea5d8f5c4c8f9e97f34191&threadid=5003
26

also read this

http://kb.roxio.com/content/kb/ET6000102

and

Using MacImage to create a cross-platform, auto running CDrom from a PC - tutorial  (also known as a
hybrid CDrom)

http://www.kook.com.au/kook/hybrid.html

and

Preparing Flash Video, Audio and other .SWF Files for CD Rom Projects

http://www.wildform.com/support/tutorials/flashvideoforcdroms/

192. I'm looking for a tool or some way to save files to disk from inside Flash.

I want to save dxf files straight from a CD on to the hard drive. Do any of
your tools do this?

We recommend you use an installation tool to transfer files across to your user's machine 

Take a look at
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Inno Setup

http://www.jrsoftware.org/isinfo.php

193. I want my main application to be on the end user's machine, but I want the rest of the media to
be on the CD-ROM. How can I have access to these from my Juggled file ?

We've just added a CDROM% command that supports this.

Please read the 

Jugglor Help -> Advanced Techiques -> Using CDROM% command

Also look at the example file provided.

194. I had to do a flash presentation that will be put on a CD-ROM and sent to clients. 

I've used Jugglor to 'Juggle' and customise the orginal flash projector file. How do I make the flash
presentation play automatically from a CD?

Take a look at:

Using the Autorun feature on a custom CD

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_12011&sliceId=2

and
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15212&sliceId=2

From Microsoft

http://msdn2.microsoft.com/en-us/library/bb776826.aspx



195. I can't get my projector file to work using the Local or Current Dir. command. I am launching an
AVI file from a button in my projector file. I thought by creating a single folder named c:\jug where I
could place my projector.exe, my jug.exe, and my AVI file, I could make it work, but it doesn't. Why?

To make it work you need to put a copy of JStart into the same directory as your Projector file and
Juggled file. Normally, Jugglor includes any JTools you've specified automatically and then when it's
run these are extracted to the temporary directory. Now, because you are not using the temporary
directory, it cannot find JStart. So, this is why you must put a copy in there. 

A current directory demo is now available for download which contains source files of an example of
launching AVIs, using JStart, from the current director.
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196. Can I use my custom DLL to talk to my Projector file?
Yes there is a way to do this with Jugglor and a custom DLL.

It's not for the faint hearted and non-experienced developers.

We can show you a few examples of how this can be done, but any support that is required from us will
be chargeable, as it consumes a lot of our time, if it's our bug we will not charge for it.

Please download the examples files given.

There is a C++ and Delphi example. Please take a look at all the files very carefully to get a better
understanding.

197. I am confused, and have been reading up on the distribution of flashplayer within applications
such as Jugglor.

What is the legal issue here with using your application to distribute the Flash Player?

There are a few Points to consider
1. The Flash Player is defined as the Activex/OCX control that is installed/viewed through the browser.
If you are distributing this then you may require additional licensing. Read this
http://www.macromedia.com/licensing/ 

2. The Flash Player doesn't mean the Flash Projector.

3. Jugglor allows you to use the Flash Projector file and the SWF file. If you use the Flash Projector file
then there are no distribution or legal issues. We are the only third party tool that gives you the choice to
use the Projector or Flash Player as the engine.

Read this
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_13247 

4. If you use SWF files in Jugglor then Jugglor doesn't automatically add the FlashPlayer(OCX control)
inside the final Juggled file. There is an option to include the Install file. Again read the licensing
agreement from Macromedia.

5. Jugglor doesn't 'hack' into the original projector file, it creates a shell around it enabling/disabling
features. So if you change the icon of the Juggled file you are changing the icon of the Jugglor Engine
and not the final projector file.

6. We've been developing Jugglor for the last 10 years. We are in constant touch with Adobe and their
developments.
If there were any issues with Jugglor we are sure Adobe would have brought them up. Also take a look
at our client list.

Further reading
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_13247 
http://www.flashjester.com/index.php?section=tricks_jugglor2_reason 
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We hope this clears up a few things.


198. Can I distribute my Juggled files freely ? Are there any restrictions ?
No, you can distribute as many as you like, it's unlimited and no restrictions apply.

But you cannot distribute Jugglor itself. If you have purchased one copy of Jugglor then you are only
allowed to install it on 1 developers machine. If you have mutliple developers then you need a multiple
user license. Please email us for more details on sales@flashjester.com


199. Do I need some sort of license to distribute the Flash Plugin/ Flash ActiveX Player?
YES

You can apply for a flash player/plug-in distribution license. It's an instant process
done online. Once completed you will be given links to ActiveX and plug-in installer
files which you can include on your CD. Then all you need is a splash screen where you
can ask the user to install whatever's necessary.

If that's an option for you, then go to: 

http://www.adobe.com/licensing/distribution/

and visit the link : "License Flash Player only"

p.s

Another option is  using a Flash Projectorfile EXE where the user does not need the player because upon
export it wraps the player around the file making it a totally stand alone application.


200. After successfully installing the trial version of FlashJester Jugglor v.3.0, I get an error message
when running the application. 
 
"Error loading type library/DLL."
 
This also probably causes the errors when I want to save the project files:
access violation at blablabla in module Jugglor.exe 


OK, you need to install the latest version of the Flash Player.

Go to

http://www.flash.com

and then restart Jugglor.

That will do the trick.
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201. What is the limit on file size for additional files? I have to package an installer with my .exe and
I keep getting the error: "Append file(s) too big." Is there any way around this?

The limit is 2GB. 
The same error will be shown if some of the files have zero length.

202. When I compile my Juggled file I get the error "Stream write error". Why does this happen?
Most commonly, this means that your hard disk is full. You can help solve this by deleting old or unused
files from your hard drive. This error might also occur if you compile to a removable storage drive and
there is no disk present.

203. I downloaded my new version of Jugglor and then uninstalled the trial version and installed the
full version." The prompt still comes up to tell me I have so many days left. Have I ignored
something to delete?

You have to enter your registration details in Jugglor -> Help -> Registration

204. There are boxes within Jugglor to write error messages. What happens if I don't fill these in?
Jugglor will use the default error messages built into the software.

205. I keep getting an error message when I try to use Jugglor that says "Append file size too big" Is
there a limit on the file size I can create?

You have a file with zero length. Take a look at all the files used in your project.
Look at the 'Additional Files' section and check in there also.



206. How do I load an AVI (or Mp3, MPEG video file, etc.) SPECIFICALLY in the Windows Media
Player?

This can be done by using a simple JStart command combined with adding a Windows Media Player*
shortcut to the additional files in Jugglor. If you go to the directory where the Windows Media Player* is
installed on your machine you will see a list of files it needs to run. From here, add Mplayer2.exe to your
additional files. This is a shortcut that will find and run the Windows Media Player* from wherever it is
installed on your users system. 

Then just go to add another JTool, specify the AVI (or Mp3, MPEG video file, etc.) and choose the
shortcut you included in the additional files. This will then launch the Windows Media Player*. To
actually load the file into Media Player, you must put it in the Arguments line of the JTool setup.

207. Why doesn't the FS COMMAND - Exec work to open a normal executable file in a
"Juggled-movie"?

When you run a Juggled file it uncompresses the projector file into the Win/Temp directory. So this
means if you run the Exec command it will try to look for the *.exe in the Win/Temp directory. Now
you can do two things here: 

Include the *.exe in the Additional Files section 
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or 

Use JStart and the LOCAL% to run files from where the Juggled file was launched from.

208. How can I make my Flash file support a Joystick or a Gamepad ?
See

Jugglor -> Setup Settings -> Joystick/Gamepad

No coding involved. It allows the user to Disable Joystick/Gamepad support. Other options allow you to
provide Cursor Position ,Cursor Speed, Mapping Mode and Flash Variables control to the
Joystick/Gamepad. 

<b>Cursor Position</b> : The mouse cursor position will correspond to the position of the
Joystick/Gamepad. With this option enabled the position of the Joystick/Gamepad will determine the
position of the mouse cursor. If your Joystick/Gamepad is in the centre position, the mouse cursor will
be at the centre of the screen. If your Joystick/Gamepad is at the top position, then the mouse cursor will
be at the top of the screen.

<b>Cursor Speed</b> : The Joystick/Gamepad will control the movement and speed of the mouse
cursor. Basically the Joystick/Gamepad will act as your mouse, if you move your Joystick/Gamepad
forward it will move the mouse cursor upwards, if you move your Joystick/Gamepad backwards, the
mouse cursor will move downwards. The Joystick/Gamepad will thus act as your mouse.

<b>Mapping Mode</b> : Allows you to use the Joystick/Gamepad to simulate user-defined keyboard
buttons on Joystick/Gamepad movement and buttons. Diagonal movement will be presented as a two
key sequence combining the keys corresponding to the main directions (up/down/left/right). 

<b>Flash Variables</b> : This mode is where all the data is put into Flash variables.Joy1X, Joy1Y,
Joy1Z, Joy1R, Joy1Buttons, Joy1POV for Joystick 1 and Joy2X, Joy2Y, Joy2Z, Joy2R, Joy2Buttons,
Joy2POV for Joystick 2. The X, Y, Z and R coordinates are normalized in the range -1 .. +1 The buttons
are a binary combination of the pressed state of the buttons - bit 0 is button 1, bit 1 is button 2, etc. The
POV values are in the range 0..35900, where 9000 is 90 degrees, 18000 is 180 degreess etc. 65535
means no direction. 

Download the example file to see how the Flash Variables work.




209. What is Flash Remoting?
Adobe Flash Remoting MX provides the connection between Adobe Flash and your web application
server, making it fast and easy to create Rich Internet Applications. With its powerful yet simple
programming model, you can easily integrate rich Adobe Flash content with applications built using
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Adobe ColdFusion MX, Microsoft .NET, Java, and SOAP-based web services.

Read more about it here.

http://www.adobe.com/products/flashremoting/


210. Will all my Flash Remoting code work when I have Juggled my Flash Projector or SWF file ?
Yes, it will work, for sure.

If it works in a normal projector file then it will work when you have Juggled it. Jugglor will not disable
any of these features.

Just make sure all the links are absolute (full addresses).

211.  I have used the Flash Projector to create a CD.  On my final frame I have an exit button 
which works well. Also, on the final frame I want the CD to close automatically 
after 10 seconds.  How do I do this? 

//add the script bellow to your final page.

 t1 = getTimer();
 onEnterFrame = function(){
    t2 = getTimer();
    t3 = t2-t1;
    if(t3>=10){
       delete onEnterFrame;
       fscommand("quit", "");
    }
 }

212. I tried to call a page named Magic.html in the same folder as the Exec file. So I put Magic.html
on the get URL and it doesn't work. Also, when I try the same thing with my Projector, it works.
Why?

You will either have to add the html file inside the Juggled file in the Additional files section or Use the
LOCAL% command. This will allow you to access files from where the Juggled file resides in.

Check here for more info:

Jugglor Help -> Advanced Techniques -> Using LOCAL%

213. Why is my FLV in Flash 8 not loading when I use it with Jugglor? It works fine on a normal
projector file.

If the FLV file resides outside the Juggled File (i.e Final Projector File) then you have to add the
LOCAL_25 command in front of the path of the FLV to tell Jugglor where to look.

1. Click on the FLVPlayback object in the FLA.
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2. Parameter -> contentPath

You might have something like this

data\videofile.flv

which now needs to be

local_25data_5Cvideofile.flv

where 

_25 mean %

_5C mean \

Please remove all UNDERSCORES from the filename. The underscore will confuse Jugglor and will not
recognise the statement.

More on this can be found in

Jugglor Help -> Advance Techniques -> Using LOCAL%

If you leave it as 

data\videofile.flv

then it is looking for the FLV inside the Juggled file. Which can be added into the Additional Files
section.

If you still have problems. Please add the FLVPlayback object on or after the 5th frame, giving Jugglor
time to initialise.

Please look at the example file provided.


214. How can I create my own custom FLV Player ? I would like to be able to skin the flash file. I
would also like to allow the user to select different FLV files. Is this possible?

Yes this is possible. You will need to use

Jugglor

http://www.jugglor.com

and

JSystem

http://jsystem.flashjester.com
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It resizes at runtime time also.

215. External FLV files won't play in a juggled projector. Our projector runs next to a folder called
\"assets\" which contains several FLV movies. These are played through the MediaDisplay
component.

my_media.setMedia("assets/m7.flv","FLV");  

for FLV files and

my_media.setMedia("assets/music.mp3","MP3");

for mp3 files
You need to add the LOCAL_25 command :

assets/m7.flv

so

local_25assets/m7.flv

Note that we don't need to add \ or / before assets

Now we need to change / or sometime users use \ 

but change it to _5C

so we have

local_25assets_5Cm7.flv

and finally we have

FLV
my_media.setMedia("local_25assets_5Cm7.flv","FLV");

MP3
my_media.setMedia("local_25assets_5Cmusic.mp3","MP3");

See 

Jugglor Help -> Advanced Techniques -> Using LOCAL%

for further details.
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216. I'm working on a project that has about 20 flv files that are pulled from a directory and displayed
within a swf. Sometimes,I click the button and a flv plays perfectly. Other times I can hear the audio
track of the flv then get a delay (sometimes long) before the video appears. And, other times the
audio plays fine and the video never appears.

This will eventually end up on a cd, but right now I'm just testing from the projectors and swf files on
my local drive. I've tested it on several different computers and it misbehaves on them all. I'm not
sure how to solve this problem, since it seems to behave quite erratically. Can someone point me in
the right direction?

Yes, this is because you are running the flash file from the CD-ROM. There are memory issues when
running a projector file from a CD-ROM which Adobe have acknowledged (see technotes on their
website for further info).

The machine doesn't have enough memory to play it from the CD-ROM itself.

Here is a suggestion.

Use the hard disk memory, this can be achieved by using one of products called Jugglor.

http://www.jugglor.com

It will compress the main PC projector file in a new Juggled Projector file. When the user executes this
file it will uncompress itself to the windows/temp directory hence the hard drive. Now you will get a
better and smoother playback. You can keep the FLV on the CD-ROM and use the LOADMOVIE
command along with the LOCAL% to load these files. You can also pack the FLV's into the Juggled file
using the Additional File section.

Jugglor Help -> Advanced Techniques -> Using the LOCAL%

it has worked for many of our clients.

Download a FREE 30 day trail and see if it works for you.

Email support@flashjester.com if you have any further questions.




217. How do I disable the right click menu in Flash?
From a Flash Projector file you can use Jugglor

http://www.jugglor.com

Jugglor -> Setup Settings -> Default Flash Right Click Menu -> No right menu

From a Flash file on the web, please read this

<a class=txtmainorange
href="http://groups.google.com/group/macromedia.flash/browse_thread/thread/9c0d8a403388567c/2e74
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a4a8001720f2#2e74a4a8001720f2" target="_blank">How to hide the right click popdown menu</a>

That will help you get started.

218. Does Jugglor support Flash FSCommands?
Yes, all FSCommands that are built in Flash will work in Jugglor.

219. I have a strange problem, Jugglor does not read the function stop().
Move the stop() or any other commands to the 3rd Frame then it will work. Our guess is that it's on the
first frame.

Jugglor needs to initialise and take some time hence the move of all commands after the 3rd frame.

Try it.

220. Is it possible to change the words 'Close' and 'Minimize/Restore' - on right click - into other
languages?

Yes you can.

Double-click the text to the right of the checkboxes for the right-click menu.

Setup Settings -> Add to Right Click Menu


221. I just purchased Jugglor and when I press the flash projector/movie file it only lets me select
.exe files, I dont get it. I want to select SWF files.

You have probably purchased the Standard Edition.

The Standard edition doesn't allow you to use the transparency feature, which require the SWF files.

Now for all other projects we recommend you publish your Flash file as a Projector file since it has the
Flash Player and your end users will not be required to have the Flash Plug-in.

If you wish to use the transparency feature and use SWF files then you can upgrade to Pro by paying the
difference.

Email support@flashjester.com with your registration details.

Hope this helps.

222. How do I close a Juggled file?
Use the normal actionscript code

on (release) 
  { fscommand("quit"); 
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}


223. What is the latest EncodeForJugglor function?
Here we go, please download the text file below.

224. How do I  start up my Flash Projector minimized, is this possible?
Yes you  need to add the following command 

fscommand("exec", "jcommand:minimize") 

on or after the 5th frame.

See the example file given.

225. How do I disable the right click menu in my SWF Flash File?
The right click menu in the SWF flash movie can be disabled using the menu attribute, and setting in
html embed code as below

<EMBED src=mymovie.swf type="text/html; charset=iso-8859-1" quality="high" menu=false
bgcolor=#000000 WIDTH=120 HEIGHT=30>

It will not disable the full right menu, as it will still show the two menu options on the right click

226. All the projector "exe" are bigger than before, nearly double the original size of the one made
with Flash 4 or 5. 
Is this due to a different flash engine (MX) or is there something else?

Yes it's due to the engine. 

The standalone player SAFlashPlayer.exe is 800KB. 

:\Program Files\Macromedia\Flash MX\Players 

If you are not using any of Flash MX features then I suggest you use F4 or F5 projector files. 

To create a Flash 5 projector file you first need to run 

C:\Program Files\Macromedia\Flash 5\Players\FlashPla.exe 

and load swf from File - Open. This will also now load all SWF files in the Flash 5 player. 

To switch back to Flash MX then double click on 

:\Program Files\Macromedia\Flash MX\Players\SAFlashPlayer.exe
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227. As usual, these 3rd party applications cause animations to run slower.. like a 30 FPS movie
would look like 24 FPS..?

Jugglor our third party tool DOES NOT cause the animation to run slower. Why? Because we don't use
the Flash Plugin to play the animation we use the built in flash player that comes with the projector file.
Hence if you use Jugglor it will play at the same rate. 

Why not try it if you don't believe us? 

Download a FREE evaluation copy from 

http://www.jugglor.com

228. In my root movie, I load several movies on seperate layers once the root movie has started. I
create a projector, but if the movies I am calling aren't in the folder with the projector they won't play.

I want to create the projector so it includes everything. So I can avoid putting several .swf files on a
CD along with the projector. 

Is there a way to make the projector totally self contained?
Yes, use Jugglor's 'Additional files' feature. Add your SWF files in there and Jugglor will create one
EXE.

229. Why should I use Jugglor rather than SWF Studio or Flash Studio Pro or any other tools on the
market?

OK, let me break it down for you slowly. 

1. Jugglor is the ONLY tool that use the Projector file as the Flash player, the rest use the OCX control.
So what does that mean I hear you say. Well, you don't need to distribute anything ELSE when you
distribute your app, as the Flash Player is built in. You will not have bulky applications with OCX, DLL
slipped inside of it. Which means less headaches from your end user. Let me give you are an example
and what has happened in the past. You have distributed your app using the other tools and have the
Flash 5 OCX control inside. Fine. Flash MX comes out and there is a new plugin. Your end users are
using Flash MX and they run your app with the Flash 5 plugin. It overwrites their Flash MX, plugin.
They ring you!!! Using Jugglor and the projector gives you peace of mind. No matter what Flash Plugin
your users have, your Juggled file will not interfere with their system settings. 

2. Jugglor has been around for 10 years. Meaning it's very very stable, tried and tested. We were the
original creator of such a tool. 

3. By using the Flash OCX control the playback is much slower than if you use the projector file. This
has been proved and admitted by one of the competitors. 

4. Much smaller applications can be built using Jugglor. We also use compression techniques on the
final projector. Please compare the output with the other tools. 

5. Great support, of course. 
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6. Easy to use. 

;)) 

Please, please compare and test all the products yourself and don't just take our word for it, we are
biased.

230. Why are all my external applications (html, .pdf, etc.) loading behind the Flash .exe window?
Make sure in the Jugglor settings "Window Size and Position" -> "Always on Top" is unchecked.

231. Why does my Juggled file flicker when I first run it ?
1. Make sure you are using the latest version of Jugglor. 
2. Do NOT put in a FS command "full screen/true" in the Flash FLA file.

232. I don't seem to be able to get any URL links to work in the juggled file using Flash MX and the
GETURL command?

Simple
 
on (release) { 
getURL("http://www.flashjester.com"); 
} 

See the example provided.

233. I have a flash .exe that is 750x435. I want a projector that runs fullscreen, but keeps the original
file at the 750x435 size. Basically, I just want jugglor to put a fullscreen border around my original
file. How do I do this?

You need to use the FSCOMMAND - ALLOWSCALE 

fscommand("allowscale", false);

234. Are there any restrictions or royalty requirements on using Jugglor or the Jtools for commercial
use?

No restrictions. Depending on how many people you have working for you that will be using the tools
make sure you have the correct license. 

That's it.

235. I have disabled the Windows keys on my Juggled file but when I press the Windows key and
"U" the Utility manager appears?

Whilst Jugglor can disable the Windows key and different combinations that it can be used in, the Utility
Manager is still one that can be loaded up. This is something to do with the way Windows works and
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cannot be stopped at present.

236. I was wondering if any of your products have the ability to reduce the 
published file size of a Flash .exe or .swf file? I was looking at your web site and didn't see anything
specifically about this but thought I would ask you directly instead. Thanks.

Yes, Jugglor has a built in compression ability. This is just one of Jugglors feature. All projector files
used in Jugglor are automatically compressed. When you run each of the Juggled files they uncompress
automatically. If you use the additional files options in Jugglor it will also compress these files too.

237. I am trying to change the title bar caption but can't find this option anywhere in the application
or help. It just defaults to the filename. Can you point me in the right direction?

The New Juggled filename will be the name of the title bar caption. Change this to whatever title bar you
want.

238. The cursor keeps appearing in the middle of the Projector file when playing. It's annoying as I
always have to move it out the way. Can I do anything about this?

Yes you can. You can choose to hide the cursor in the 'Setup Settings' tab, stopping the cursor from
appearing over the top and in the middle of what you are viewing.

239. Can I read and write to the Windows Registry using a Flash Projector?
Yes you can.

Please look at the Jugglor Help File -> Additional Features -> Read/Write to the Windows Registry

Please download the example file.

240. How big can a Flash movie be?
Read this

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14437&sliceId=1

241. I am using the getURL command to download a zip

	getURL('http://www.mysite.com/myfile.zip', "_blank");

This works fine, then sometimes the dialog that pops up goes behind the projector file.

How can I stop this ?
You can by just putting the Flash projector through Jugglor and Jugglor will take care of the rest. No
special commands needed.

Look at the example file given.
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242. Can I use the GETURL to open a local file? Something like a pdf file?
Yes you can, just specify the filename 

i.e.

getURL('file.pdf',"_blank");

This will open the pdf file in a browser.

See the example below

The only disadvantage of using this method is in IE it will ask the user if they want to show the active
content... etc. Depending on the user's security settings.

To avoid this and any browser issues we recommend you use JStart, which will open up in the default
application rather than the browser.

Look here

http://jstart.flashjester.com 

and the online FAQ, you will have to use the LOCAL command.

http://flashjester.com/?section=faq&cPath=14_56_26


243. We cannot find a way to create our own .lng-files in Jugglor. We need the install dialogues to
be in Greek and Swedish along we the default languages. Weâ€™ve tried all text editors we can
think of, but no luck.



Yes, sure this is possible.

Open Jugglor and create a new project.

1. Build -> Build Installation
2. Dialogs -> Language -> Press the + button
3. Enter a new name i.e. Greek and press OK.
4. Make sure Language is selected that you have created.
5. Now double click on any text in the work area where is shows an image of the Installation sections.
Change the text and press OK.
5. Save the project. It has now create a *.lng file in sub directory called \Language where the project has
been saved.
6. Now if you want this language file to appear on all new projects, then copy this *.lng file to 

C:\Program Files\FlashJester\Jugglor v2\Language

7. Now start a new project and it will appear in the Language Dialog when you press the + button.

That's it.
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244. I am using the Additional Files section to add SWFs, but the Juggled file won't load them. I
thought they were included in the Juggled file?

Yes, anything you add into the Additional Files section of Jugglor will all be compressed into the final
Juggled exe file.

Now when you run the Juggled file it will uncompress all the files into the Users Temp directory. This
may take a few seconds to uncompress.

This is the Jugglor initialisation process. If you have the loadmovie command on the 1st Frame i.e.

loadmovie(myfile.swf,1);

then it will not load due to the initialisation process. So in order for this to finish we ALWAYS
recommend that you put the LoadMovie command on the or after the 5th Frame.

Please try this.

Also.

1. If you have the SWF files in a sub folder then don't forget to create the sub folder in the additional file
section. You can do this by pressing the "Create a New Folder" button.

2. If the SWF files are large then set the Progress bar option on when extracting

Build -> Message during extract

Thats it really. Give it a go.

245. My LoadMovie command on my Flash Projector was working fine until I put it through Jugglor.

What happened?

I have the following:

loadMovie("library\20060916154752.jpg");

Ok you have to add local_25 in front of the filepath and change the back slashes ( \ )  to _5C if you're
using any.

So 

loadMovie("library\20060916154752.jpg");

will now be

loadMovie("local_25library_5C20060916154752.jpg");

and
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loadMovie("myfile.swf");

will now be

loadMovie("local_25myfile.swf");

IMPORTANT : Remember also not to add the loadmovie command on the 1st frame, add it on or after
the 5th frame.

For more information about this go to

Jugglor Help -> Advance Techniques -> Using LOCAL%



246. Why doesn't my LoadVariable command work after I juggled the Flash MX/2004/CS3 projector
file?

This is because the way Jugglor works. Jugglor packs the projector file and any additional files into the
final Juggled file. When you double click on the Juggled file it uncompresses into the Windows Temp
directory. Hence the LoadVariable will not work as it's looking for the text file in the Windows Temp
directory. So we have the following options 

Jugglor -> Additional files 

Please add the text file in the Additional Files section and that will solve your problem. 

In addition to this you can use our newest feature 

LoadVariable LOCAL% 

Where you add LOCAL% to the beginning of the file you are about to access. So if you have the
following 

loadVariablesNum("JNetCheck.txt", 0); 

then this should now be 

loadVariablesNum("local_25JNetCheck.txt", 0); 

Where _25 stands for % 

the same applies to 

loadVariables("data.txt", _root.vars, "") 

which is 

loadVariables ("local_25data.txt", _root.vars, "") 
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The LOCAL_25 works with any ActionScript method or function that deals with a file
path.  

IMPORTANT : Please remember not to use the loadvariables command in the first 10 frames (or so),
because the Jugglor will not be recognize the prefix. 

Please download the example file to see how LoadVariable and LOCAL_25 work.


247. I have gone through building a projector file, but it still does not link to my external swfs. They
are added as additional files.

Add the LoadMovie command after the 2nd frame and not the first. This might help you. 

See the example file below.

248. I am having problems using the new LoadMovie command with LOCAL%.

I had the following

on (release) {
    _root.myMovie.loadMovie("mySWF_1.swf", 1);
}
 
When I click myButton the movie loads and runs  GREAT......
 
Now I would like to modify the above code so Jugglor can do it.
 
Here is my modified Jugglor code:
 
on (release) {
    _root.myMovie.loadMovie("local_25mySWF_1.swf",1);
}

This doesn't work. What am I am doing wrong?

Please remove all UNDERSCORES from the filename before you start to add the local_25 command.
The underscore will confuse Jugglor and will not recognise the statement.

So you should rename the SWF to

mySWF1.swf

and then you will have

on (release) {
    _root.myMovie.loadMovie("local_25mySWF1.swf",1);
}


Page 69



Flashjester  FAQ.

249. How do I access My Documents folder ? I have a text file in there I want the user to read.
Please look here

http://www.flashjester.com/index.php?section=faq&cPath=28_39#260

250. How can I align my Flash file just on the 1st Monitor rather than stretching on both my monitors
?

In Jugglor go to

Jugglor -> Setup Settings -> Windows Settings -> Alignment -> Align to primary monitor.

251. How I can get the resolution of a Window?
You can get this by using Actionscript

System.capabilities.screenResolutionX and System.capabilities.screenResolutionY



252.  I have 2 monitors hooked up and I want to run my flash .exe file (with a fullscreen
FSCommand) on Screen 2 instead of Screen 1 without changing the display settings. Does anybody
know how to do that?

The only way to do this is to use a third party tool like ours.

FlashJester Jugglor supports multi-monitor using your Flash Projector

Download a FREE evaluation copy from

http://www.jugglor.com

and then go to

 Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support -> 
Show the window on Monitor No -> 2

Thats it, no coding required.


253. I am making an autorun CD to open a flash .exe file, which has one movie clip playing inside. 

Currently, I have created a flash project of the size 800*600  set fscommand to fullscreen and
Stage.scaleMode = "noScale"; so that my movie  does not get pixelated if the screen resolution is
more than 800*600.

Since my major concern is to prevent the movie from getting pixelated I have created a few more
applications with different stage sizes like 1024*768 and 
1208*1024.
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Now what I want is that once the autorun CD starts it detects the user screen 
resolution and based on that opens the corresponding .exe file. I have the 
javascript to detect the screen resolution, but what i don't know is where should I 
place that script and how do i call the .exe file?


You can get this by using Actionscript

System.capabilities.screenResolutionX and System.capabilities.screenResolutionY

Another option would be to use our third party tool Jugglor to automatically set the users display to say
800x600 or 1024x768, this means you will need only one Flash exe. Once the Flash file has been closed
it will then set the screen resolution back to the original resolution. Similar to the way games work.

Download a FREE evaluation copy from

http://www.jugglor.com

Jugglor -> Setup Settings -> Windows Settings  -> Full Screen Resolution

Try it.

254. I need to show my flash movies in full screen mode spread (spanning across) across multiple
monitors.  Does any of your software allow for this?

Yes FlashJester Jugglor allows you to do this.

Download an evaluation copy from

http://www.jugglor.com

then go to

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support -> Use (Stretchto) all monitors

Build the project and thats it. 

255. Is there Dual monitor support in Flash?
Flash doesn't support Dual Monitor.

But FlashJester Jugglor supports Dual Monitor with Flash files. You can have different Flash files
appear on dual monitors and also you can Clone Monitor the same screen on all monitors.

Download a FREE evaluation copy from

http://www.jugglor.com

and go to

Setup Settings -> Windows Settings -> Multi monitor Support

Page 71



Flashjester  FAQ.

Try it and see it in action.

256. Is the Mouse Wheel supported with Jugglor?
Jugglor itself doesn't support the Mouse Wheel but the new Flash 7 Player does.

Read below

http://www.communitymx.com/content/article.cfm?cid=A3BDC567C4BE81CE


257. I want, to get information from an external source and store it in a local txt file, so the latest
price info can be used when offline. Any ideas as to how this can be done?


Yes, just use the LoadVars object.

Something like this

var my_lv:LoadVars = new LoadVars();
my_lv.onLoad = function(success:Boolean) {
   if (success) {
      trace(this.toString());//show me the text
//do soemthing else here like load the text into a text field
   } else {
      trace("Error loading/parsing LoadVars.");
   }
};
my_lv.load("http://www.yousite.com/yourtextfile.txt");//just use the URL to your text file here

or you can use some server side scripting i.e php, asp etc.

Once you have read the text, you can either save the text into a text file using JSave or JSystem -
Savetofile command

http://jsave.flashjester.com

http://jsystem.flashjester.com

Or even simpler use the Read/Write to the Windows Registry feature

See

Jugglor Help -> Advanced Techniques -> Read/Write Windows Registry

That will help you get started.

258. Can Jugglor use the LoadMovie command to get SWF files from the internet?
Yes sure you can. Just specify the URL,
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i.e

loadMovie("http://www.flashjester.com/download/temp/test.swf",1);

See the example below to see if is working.

259. I'm having trouble with Jugglor 2 pro, I have it setting the screen resolution of user's computers
to 800x600, on some machines this works fine, on others (laptops) it seems to centre the flash in the
middle and fill the rest with black - it tries to force the screen resolution (it flickers on and off) then
just leaves it the same. The screen resolution was at 1024x768 to start with, and has no problems
displaying at 800x600 if you set it manually.

Is there another way to do this? or is there an option/setting i have missed?

Please try to update the video drivers on the laptop.

260. I have a Flash Game file that I want to be displayed in 16 bit color and not 32 bit for speed
enhancement. Is this possible ?

Yes you can do this in Jugglor.

Go to 

Jugglor -> Setup Settings -> Windows Settings -> Full Screen Resolution -> Select Size of Screen ->
Force 16 bpp

Force 16bpp - Forces the color resolution to be set at 16 BitsPerPixel - Color quality to 16 bit. Used by
game developers to speed up the FPS.


261. I have more than 2 monitors I want my Flash file to be displayed on. Does Jugglor support this?
Yes Jugglor supports Multi monitor in Flash. See

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support -> Use (Stretch to) all monitors



262. I have Flash MX on my machine but I want to create a Flash 5 Projector. How can I do this
without reinstalling Flash 5?

First make sure you have Flash 5 on the machine. Then locate 

\Program Files\Macromedia\Flash 5\Players\FlashPla.exe 

Open it and then close it. This will set the Flash 5 Player as default. Click on an exported Flash 5 SWF
file from Flash MX and now it will open up the Flash 5 player. Then go to File -> Create Projector. Now
if you would like to create a Flash MX Projector just use the Publish command and check the Window
Projector checkbox.
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263. For FSCOMMAND - Exec to work with Flash MX, I heard you have to create a FSCOMMAND
directory. Is that true ?

If you are using Jugglor and the JTools then you don't need to create the FSCOMMAND directory.
Jugglor will take care of this. 

Now if you are using the JTools without Jugglor then yes you do. Please read the JStart JWeb JEmail
help file for further information. 

See the JStart Jweb Help file -> Setting up JTools link -> Setting up for Flash MX 

and please take a look at the examples provided 

:\Program Files\FlashJester\JTools\Examples

264. I am now using Flash MX Projector files, but none of my previous JTools links work? Why is
this?

This will not work due to the changes made by Macromedia in Flash MX. 

You will need to recreate the links by pressing the Copy button again in the JTools section and paste
accordingly into the FLA file and export it back as a Flash MX/6 Projector file. 

Remember you will not need to create the FSCOMMAND directory for the JTools to work, Jugglor has
taken care of this.

265. Where can i get the latest Flash Projector files from? I want to update my Flash Players for my
current version of Flash.

The Flash Players are not automatically downloaded by Flash you have to do this yourself.

Go here

http://www.adobe.com/support/flashplayer/downloads.html



266. Can people tell its a projector file?
Using Jugglor's many features, your Projector file can be disguised so well that no-one will know it is a
Projector file. With options like changing the icon, the user will click on it to start the Projector file
thinking that it is it's own program. Then, by choosing how your Projector file is displayed you can put it
in a window, changing the caption, size and removing the right click and main menus.

267. What is a projector file?
Using Macromedia Flash 3, 4, 5 or MX, you can create animations and export them to Shockwave Files
(SWFs). The SWF can then be made into a stand-alone Projector file, a single executable file created by
opening an SWF in the Shockwave player and then choosing "Create Projector" from the file menu. Also
in 4 (5 & MX) you can go to -> File -> Publish Settings -> Windows Projector(*.exe).Go to
www.flash.com
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268. We have some sensitive data and wish to keep these files away from the end user in our Flash
Projector. We don't want our users hacking into this data from the Flash Projector or SWF file. How
can we protect oufiles, whether they be a SWF, FLV, XML, JPG  or TXT file?

Please look at the 

NEW Security Feature - In Memory File Support 

http://www.flashjester.com/index.php?section=tricks_jugglor2_security

then once you have Jugglor on your machine

Jugglor Help -> Sections -> Additional Files -> Additional File -> NEW Security Feature - In Memory
File Support 

This will enable you to add ANY sensitive data that you have into the Additional Files section of
Jugglor. This will then compress all these files into ONE exe. 

When the Juggled file is executed all assigned memory files will be in memory and accessible to Jugglor
only. All other non memory files will be uncompressed into the Windows Temp directory.

This will give security to your Flash Projector and Flash SWF file.

Please download the example file below, it shows an SWF and XML file being loaded while in memory.



269. How can I add additional security features to my Juggled file ? i.e Give x amount of licenses
etc.

Take a look at 

PC Guard for Win32 on 
http://www.sofpro.com/ 

and

Silicon Realms - Armadillo Support - Realms delivers a new technology that drives global sales while
protecting your digital assets with SoftwarePassport.

http://siliconrealms.com/index.shtml

their software works with Juggled files. 

It gives you MUCH more control and security features you can ever imagine.

270. Does SharedObjects work with flash files once they have been Juggled?
YES, it does. From the example we have tried it works just like it does in a projector file. 

When you create a new projector or Juggled file the objects will create a new cookie for that specific
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file, so it will not have variables from a previous SWF or Projector file, you have to use that exact file
where you stored the variable to. 

Please download the example file to see it working with Jugglor. 

Another very good example of SharedObjects is 

http://www.adobe.com/devnet/flash/articles/addressbook.html 

from Colin Moock (a Flash Guru)

IMPORTANT - Hint :

For people using SharedObjects, it is critical that you specify a value for the optional localpath
parameter to the getLocal method. 
For example, use 

so = sharedObject.getLocal("objectName", "/"); 

instead of 

so = sharedObject.getLocal("objectName");. 

It's a small but very important difference. Here's why...

To avoid name collisions, Flash looks at the location of the movie that is creating the shared object
(normally the host domain and directory). This is done so that shared objects with the same name will
not conflict with another.

To find out more on Shared Objects read

http://www.macromedia.com/support/flash/action_scripts/local_shared_object/




271. Does SharedObjects work with Projector files that are Juggled ?
Yes sure it will work the same as a Projector or SWF file would work.

See the example file below.



272. Can I skin a Flash file?
Yes Jugglor allows you to skin your Flash files. We call it the Border Skin Designer. Here you can select
from 100+ pre built skin files or create your own, it's very easy to use.

Please read the help file on this section.

Page 76



Flashjester  FAQ.

Jugglor Help -> Sections -> Setup Settings -> Windows Options -> Border Skin Designer



273. Where are the skin files ?



They are located at

C:\Program Files\FlashJester\Jugglor\Border Skins\Border Skin Files

You will also find the source files here

C:\Program Files\FlashJester\Jugglor\Border Skins\Source

This gives you an idea on how the skins files were created.

274. Is it possible to use transparency in Flash?
Yes it's possible if the transparent color in the Flash file is just one colour and not different shades.

Go to the Flash Details Section in Jugglor

If you wish to add Dynamic Shaping / Transparency features you must select the Flash SWF file as this
will not work on the Flash Projector (.exe) file. 

Jugglor creates it's own executable file which you can use.

ActiveXSettings 

Read the Help file

Jugglor Help -> ActiveX Settings 

You can find many transparency examples here.

Jugglor -> File -> Open Packaged Project

C:\Program Files\FlashJester\Jugglor\Examples\Ambulance

C:\Program Files\FlashJester\Jugglor\Examples\Dynamic Shape Commands Example 1

C:\Program Files\FlashJester\Jugglor\Examples\Petz

C:\Program Files\FlashJester\Jugglor\Examples\Slug

C:\Program Files\FlashJester\Jugglor\Examples\Throwing Clock

This will help you get started.
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275. My transparency is not working on my Flash file? Why?
Ok first of all please make sure you are using Jugglor v3. It support CS3 and Vista.

Also please please make sure you have the latest Flash 9 player on your machine.

Check what version you have here

http://www.adobe.com/products/flash/about/

Make sure you have 9.0.47.0 or above. 

If not please download the latest here

http://www.adobe.com/support/flashplayer/downloads.html



276. How can I trap the Escape Key in Jugglor?
You have to use

fscommand('trapallkeys','true');

See

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14280&sliceId=2

Please download the example file to see if it's working.

277. How do I use Jugglor and JEmail together with Flash 5?
Jugglor will automatically add JEmail.exe into the Juggled file when you create the JEmail command in
the JTools section in Jugglor. 

Remember once you have copied and pasted the Flash 5 command from the Jugglor -> JTools section
and then published the Flash 5 projector, the next step is to Patch the projector file using the Patch
command. 

See Help file for more details and download the example below.

278. How do I use Jugglor and JEmail together with Flash MX?
Jugglor will automatically add JEmail.exe into the Juggled file when you create the JEmail command in
the JTools section in Jugglor. 

Then just press the copy button and paste it ino the FLA file and publish it as a projector file and use this
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in Jugglor.

See example below.

279. What should I use as a character for a line break inbetween
my variables? \r does not seem to work.


Here is an example

on (release) {
	inputemail = "sales@ryko.com";
	inputsubject = "Ryko Color Designer";
	inputbody = ("Name: "+userName.text+"\rAddress: "+userAddress.text+"\rCity:
"+userCity.text+"\rState/Prov: "+userState.text+"\rZip/PC: "+userZip.text+"\rCountry: );

	function EncodeForJugglor(x) {
		Result = "";
		for (i=0; i<x.length; i++) {
			c = x.substr(i, 1);
			if ((c == '.') or (c>='a') and (c<='z') or (c>='A') and (c<='Z')) {
				Result += c;
			} else {
				hex = ord(c).tostring(16);
				if (length(hex) == 1) {
					hex = '0'+hex;
				}
				Result += '_'+hex;
			}
		}
		return Result;
	}
	fscommand("exec", EncodeForJugglor('JEMAIL.EXE \"'+inputemail+'\" \"'+inputsubject+'\"
\"'+inputbody+'\"'));
}

or if not using the EncodeForJugglor function

i.e

"This is line one\rThis is line two"

Please download the example file to see it working.

280. I have developed a flash based drawing package for my company. 
The users can create their own drawings using this package, but I have no way to let them save
portions of screen as image files in their hard discs for exchange. Every user using the flash based
drawing tool should be able to save any number of drawings as image files on their machines. 
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Will JPrintor enable me to achieve this functionality?

Yes you can achieve this using JPrintor and Jugglor.

Please look at the example files that come with JPrintor. They will give you a better understanding of
how it works.


281. I have a problem using JPrintor and Jugglor with MX

I need to save as a file, rather than print, but make sure
this saves to the same directory that the projector runs from.

Here's the code:
filesave="screenshot.jpg" rect=(flashrect) title="Screenshot"

Can you help?
Yes you need to use the LOCAL% command.

So it now should read

filesave="local%screenshot.jpg" rect=(flashrect) title="Screenshot"

Please take a look at the example file.

282. How can I hide the JPrintor program from the user?
You can use Jugglor. This is another program in the FlashJester series that can take your Projector files
and turn them into fully stand-alone programs. It can change the icons, hide the right click menus, turn
off the sound, as well as being able to include all the programs it uses (including the JTools) in the one
executable file. For more information about Jugglor, take a look at the FlashJester website at
http://www.jugglor.com and download the example file.

283. Can you please show me an example how to use the fullscreen option in JPrintor with Jugglor
?

All you do is select 

Jugglor -> JTools -> JPrintor -> Screen Rect -> All screen

Please look at the example file provided.


284. How do I use the command line parameters with my external application using Jugglor and
JStart?

Create the JTool command in the Jugglor in the JTools section 

File
externalapp.exe
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Arguments
'hello'

then copy and paste into the FSCOMMAND EXEC command in the FLA file.

The externalapp.exe is actually inside the Juggled file, added in the 'Additional Files' section in Jugglor.

To load an external app that resides in the same directory as the Juggled file then use the LOCAL%
command

i.e

File
local%externalapp.exe

See the example file provided. 



285. I would like to keep my JProWeb files as one exe. Is this possible?
Yes you can use 

Jugglor
http://www.jugglor.com

and JProWeb together.

Please look at the example file below.

286. You need to go the section below

FAQ -> JTools -> JSave
http://www.flashjester.com/index.php?section=faq&cPath=28_39

287. I want to make a rescource CD and we want to build it in flash and be able to open and also
download, from the CD, pdf and doc files etc.
 
We have to update this CD quite often so we will use an xml file to store the names and info and just
re-burn a new copy. If I use your product will I have to modify the SWF/EXE everytime I update my
xml file?

We recommend you use Jugglor and JStart together.

Jugglor

http://www.jugglor.com

Will give you more control of the Projector file. i.e customise it, not allow the files you open to go into
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the background, stay on top etc.

JStart
http://jstart.flashjester.com

Will allow you to open up the files from the CD.

To see Jugglor and JStart working together please look at the FAQ and the examples given

http://www.flashjester.com/?section=faq&cPath=14_56_26#268

Now if you want the user to be able to save these files from the CD onto their machine use JSystem 

http://jsystem.flashjester.com

and the copyfile command.

Look at

http://www.flashjester.com/?section=faq&cPath=28_60#274

Download the evaluation copy and look at the example files given.

If you are using XML files, first read this

http://www.flashjester.com/?section=faq&cPath=14_59

Yes its possible.

No you don't need to modify the EXE just the XML file. If you keep the XML file inside the Juggled file
(i.e Use the Additional Files section in Jugglor) then you just need to rebuild the project.

Simple.

Hope this helps.


288. How do I launch a PDF file that doesn't go behind the maxmised projector file when I launch it?
Ok, you will need to use Jugglor and JStart together, to have better control over the Projector and PDF
file.

Also set

Jugglor -> Setup Settings -> Don't go to foreground on click.

The PDF file can be inside or outside the Juggled file.

Please download the example file below.
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289. I need help using JStart and Jugglor, help?
Please read the following Help file
  
C:\Program Files\FlashJester\JTools\JStart_JWeb_JEmail.hlp 
  
Setting up JTool links -> Using Jugglor 
  
and also read 
  
C:\Program Files\FlashJester\Jugglor\Jugglor.chm 
  
Advanced Techniques -> Using LOCAL% -> Using LOCAL% to launch other 
applications 

Download the example file below

This will help you. 



290. I cannot get the FSCOMMAND Exec to work with my Flash MX file, I want to run a setup.exe
and a pdf file?

Due to the changes in Flash MX, you now have to create an FSCOMMAND directory. Jugglor creates
this directory automatically for you. 

Now you can do 1 of 2 things. 

1. Add the additional file setup.exe into the Juggled file in the Additional files section in Jugglor. 

2. Or if you don't want to add the exe file into the Juggled file then you will have to use JStart with the
LOCAL% command and Jugglor together. Download the trial version of JStart from 

http://jstart.flashjester.com 

Please take a look at the help file and example files provided. 

Start -> Programs -> FlashJester -> JTools -> JStart_JWeb_JEmail.hlp 

Setting up JTool links -> Using Jugglor

You can also read the Jugglor Help file

Start -> Programs -> FlashJester -> Jugglor  -> Jugglor.hlp 

Advanced Techniques -> Using LOCAL%

Please download the example file below to see how it works. 
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291. I need to generate, from Flash MX, an exe file that will be able to open several PowerPoint
Presentations for a client and keep the exe file still running in the background if the PPS is closed.


Yes you can use Jugglor and JStart together, to have better control over the Projector and PowerPoint
file.

You will need to publish a Flash Projector file from Flash.

Flash -> File -> Publish Settings -> Windows Projector

Download a copy of Jugglor from

http://www.jugglor.com

then go to

Jugglor -> Setup Settings -> Don't go to foreground on click.

The PPS file can be inside or outside the Juggled file.

Use the LOCAL% command if the file is outside the Juggled file.

For more info about LOCAL% see

Jugglor Help -> Advanced Techniques -> Using LOCAL%

Also

Start -> Programs -> FlashJester -> JTools -> JStart_JWeb_JEmail.hlp 

Setting up JTool links -> Using Jugglor

Please download the example file below.

292. Can we open any file dynamically? Say a PDF, as we have over 100 PDF's and don't want to
create ini and jstarts.exe each time?

Yes this is possible, you can ONLY do this by using JStart and Jugglor together. 

Few Points.

1. When you use JStart and Jugglor together then you don't need to use ini or jstart.exe files, or create an
fscommand directory anymore, it's much easier.

2. You will need to use the LOCAL% command with JStart to locate the LOCAL directory, i.e the
directory where the final projector file (juggled file) is stored to locate the PDF file.

For more info read the Jugglor Help file

Jugglor Help -> Advanced Techniques -> Using LOCAL%
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3. For dynamic variables you will need to use the EncodeForJugglor command

Jugglor Help -> Advanced Techniques -> EncodeForJugglor

4. If you have a SPACE in the directory or file name then you must replace it with `1

5. Use / and not \ for file paths.

6. Use the JTools help file to help you create the JStart command

Program Files\FlashJester\JTools\JStart_JWeb_JEmail.hlp

JTools Settings -> JStart - Jugglor and JStart Examples

7. Create all JTool commands in Jugglor -> JTools section. Add any statement just to let Jugglor know
to add JStart.exe inside the final Juggled file.

Now look at the example file provided.

Hope this helps

293. We have a problem in printing 195 PDF documents from a flash MX projector, and nobody
wants to hardcode this, so is there a way to dynamically create these links

Yes this is possible, you can ONLY do this by using JStart and Jugglor together. 

Few Points.

1. When you use JStart and Jugglor together then you don't need to use ini or jstart.ex files, or create an
fscommand directory anymore, it's much easier.

2. You will need to use the LOCAL% command with JStart to locate the LOCAL directory, i.e the
directory where the final projector file (juggled file) is stored to locate the PDF file.

For more info read the Jugglor Help file

Jugglor Help -> Advanced Techniques -> Using LOCAL%

3. For dynamic variables you will need to use the EncodeForJugglor command

Jugglor Help -> Advanced Techniques -> EncodeForJugglor

4. If you have a SPACE in the directory or file name then you must replace it with `1

5. Use / and not \ for file paths.

6. For Printing you need to add /print at the end of the JStart command. See
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C:\Program Files\FlashJester\JTools\JStart_JWeb_JEmail.hlp

JTools Settings -> JStart using the Print Command

7. Create all JTool commands in Jugglor -> JTools section. Add any statement just to let Jugglor know
to add JStart.exe inside the final Juggled file.

Now look at the example file provided.

Hope this helps



294. I am having problems using the LOCAL% command with Jugglor. Do I need to include the
JStart.exe in the project ??

If you create the JTOOL command in Jugglor -> JTools then Jugglor will automatically add the JTool(s)
you have used into the Juggled file. 

So you don't need to add JStart.exe into the Additional Files section nor the root of the Juggled file. 

It doesn't matter whether you are using Flash 5 or MX it works the same way. 

Download the demo file to see this working.

295. How can I create a function in my Flash MX file to open several pdf files dynamically?
You will need to use 

JStart 
http://jstart.flashjester.com 

and 

Jugglor 
http://www.jugglor.com 

Then please download the example file below and take a careful look at the FLA and the *.jjf file. 

YOU MUST add the EncodeForJugglor function to encode the command line.

296. Can you show me how to use the Jugglor and JStart to launch a browser that has links to files
on my CD-ROM?

Please see the example below

297. I have one projector file (main movie.exe)which loads external swf's (all in MX). One of them
contains a few Word documents. I've tried to use JStart to load them,but without result. 
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Does the Jstart work with external SWF (not EXE) files, that are compressed into one projector file
(with Jugglor)?

Yes. See the example below. It launches a PDF file within the Juggled file from an external SWF which
was added in the additional files section in Jugglor.

298. I have used Jugglor to launch an InstallShield 'setup.exe' using fscommmand exec
successfully. Now, I need to launch 2 different InstallShield programs from the same Projector file
(both named 'setup.exe'). 

When launching 1 program from a projector file I place the 'setup.exe' in the Jugglor root. When
trying to launch 2 programs, I seperated them into their own subdirectories (since the InstallShield
setup files have the same name.) 

In my Flash movie, I used the fscommand exec parameters '/folder1/setup.exe' and
'folder2/setup.exe'. 

However, my juggled file will not execute either program unless the executable is in the Jugglor root.
Am I doing something wrong or is this an impossible task using Jugglor?

PS: I also tried '../folder/setup.exe' , './folder/setup.exe' , 
and 'folder/setup.exe' b/c I thought I might have specified the wrong path. I also tried each of the
three current directory settings with each scenario.....Nothing works!

Currently you use 

on (release) { 
fscommand("exec", "c2c\\setup.exe"); 
} 

This is wrong for Flash MX, the right form of the command would be: 

fscommand("exec", "c2c_5Csetup.exe"); 

"\" is coded as "_5C"

299. I am having problems using Flash MX, Jugglor, JStart and the Current Directory? 

The problem is that I don't want to add the SWF files I am using in the project inside the Juggled file.

Do I use the LOCAL& or the Current Directory feature ?
This is a little more tricky. 

1. You have to use Ini files but you don't have to create an FSCOMMAND directory. 

2. Set Current Directory to the 3rd option - The Juggled exe file location will be the current directory. 

3.Place the orginal projector file in the same directory as the Juggled file. 
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Download the example file to see how it all works.

300. A 'Juggled' intro FLASH MX Projector file which loads the first presentation screen (with menu)
as an SWF file which is loaded from a button using the 'loadMovieNum' command into _level0.
From this, subsequent screens are loaded from the menu into various other levels using the
'loadMovieNum' command.

I therefore have an SWF file which is loaded into _level20 (essentially a 
'popup' over the main screen at _level0).

I have a button in this _level20 swf file from which I need to open the PDF 
file.

All these SWF files are at the root level of the CD.

Can you please advise as to the best way to get these PDF files to open.
Is there an issue with using JSTART in SWF's loaded into different levels?
Do I have to put the PDF files in a seperate folder?
Do I have to use the fscommand folder?
Do I have to use .INI files?


Ok, we need to clear up a few things.

Lets start fresh.

Create a new directory called CD.

Add the Juggled file in there, (so change the build path in Jugglor) and all
the additional SWF's and PDF files in there.

DO NOT ADD THE ORIGINAL PROJECTOR IN THERE, as this will activate the current
directory feature.

We will use the new LOCAL% command in the 'loadMovieNum'

See

Jugglor Help -> Additional Features -> Using the LOADMOVIE command with
Jugglor

Read this section and change your FLA's to add the LOCAL% command.
i.e

loadMovieNum("loadstart.swf", 1);

will be
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loadMovieNum("local_25loadstart.swf", 1);

IMPORTANT: In order for the LOCAL% syntax to work, the LoadMovie command
should not be in the very beginning of the animation, because the engine
hooks would not be active yet.

IMPORTANT !! PLEASE DO NOT USE UNDERSCORCE'S _ IN YOUR FILENAMES AS THIS
WILL CONFUSE JUGGLOR. SO PLEASE REMOVE THEM.

Then in the loadstart.swf add

JSTART_20local_25jstart.pdf

which was created in Jugglor -> JTools

local%jstart.pdf

and press the copy button and paste it into the loadstart.fla.

> Is there an issue with using JSTART in SWF's loaded into different levels?

No.

> Do I have to put the PDF files in a seperate folder?

No, you can if you want. Just add the folder's path into the command.

> Do I have to use the fscommand folder?

No, not if you use Jugglor and any of the JTools.

> Do I have to use .INI files?

No.

Download the example file and see how this works.



301. I am trying to Juggle a Flash projector file that is using an fscommand to run an external
executable file. 

The projector file runs fine and opens the executable file before Juggling (the .exe file resides in an
fscommand folder).

 However when Juggled, the .exe does not launch. I have added the .exe to the additional files, with
and without a folder called "fscommand", to no avail.
 

Add the file inside the Juggled file using the Additional Files section in Jugglor.
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There is no need for the FSCOMMAND directory.

Then in the Jugglor -> JTools section Add
 
JStart nameofap.exe
 
Press the copy button and paste it into the FLA. Publish it and use it in Jugglor
 
See example file.

302. Why doesn't the patch command work with Flash MX files?
You don't need to patch Flash MX projector files. We are using a different approach here in Flash MX.
You only need to patch the Flash file if you are using Flash 5.

303. I have two CD type marketing pieces created to work separately.

Now, I would like to create a splash screen or one CD that gives people that use the CD the
capability to view one or the other.

How do I go about doing that?  I have Jugglor Pro 2  and  am using flash2004
You would create one Flash Projector file (call it CD1) that has menu options to execute the 2 main
Projector files (CD2 and CD3).

You bring CD1 into Jugglor, then go to the JTools sections of Jugglor and create a JStart link to open
CD2 and CD3. You will have to use the LOCAL% command with JStart.

For more info read this

Jugglor Help -> Advanced Techniques -> Using LOCAL% -> Using LOCAL% to launch other
applications

Also there is a step by step instruction on

JStart JWeb JEmail Help -> Setting up JTool links -> Using Jugglor

Download the example file to see a working version.

304. I'm having a bit of trouble using JSTART and Jugglor when there's a space in the filename. I'm
using a command line ZIP tool that takes in 2 parameters - a name for the zip file to create, and a
folder to zip. It is launched like:

zipper "zipfile" "*"

The file "zipper" exists on the desktop (for example) which means I have to use the JSTART
command:
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fscommand('exec',_root.EncodeForJugglor('JSTART '+folderPath+'\\zipper "zipped" "*"'));

When this command runs I get an error popup that says "Could not open c:\documents".

Is Jugglor having trouble with the space or is the text in the popup limited? Either way - do you have
any ideas for resolving this?

Thanks.
We've found the problem
 
If something has to contain spaces, it must be enclosed with "

We fixed the command:

fscommand('exec',EncodeForJugglor('JSTART "'+folderPath+'\\zipper" "zipped" "*"
/dir="'+folderPath+'"'));
 
That will do the trick.

305. I downloaded your free JWeb application (JHelp), and it works great, except when I try to
attach this method to Dynamic Text links inside of flash. The link is not viewable. Could you please
help?

You will have to use Jugglor and JWeb together to get this to work. 

You must use the EncodeForJugglor function provided in the FLA. 

By adding the JWeb command in the JTool section it just tells Jugglor to add JWeb inside the final
Juggled EXE. 

Please take a look at the example file below and build the Jugglor Project file.

306. I have a Windows Projector (.exe) created in Flash MX and exported as Flash 6. I am using
Jugglor to remove the border/titlebar etc, and I am trying to use JWEB (from within Jugglor) for a
web link contained in the projector. However, it isn't working. I have seen some reference to using
.ini files for Flash 6 (?), and that I don't need to patch the movie. Is there a comprehensive list of
instructions to tell me how to do this.

If you are using Flash MX, Jugglor and JWeb then you don't need to 

1. Use ini files 
2. Create a FSCOMMAND directory 
3. Patch the Flash movie. 

Jugglor takes care of this. 

Please download the example file to see this working.
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307. Hi,

I have a projector in fullscreen mode where I'm using getURL("site.htm", charly) to pop the HTML in
a browser window.

Everything works fine, but when I click back on the projector the window with site .htm goes behind
it. 

Is there code that I can use attached to a button in my Flash file which will set this window I've
popped up to have focus again? 


Yes it's possible. You will have to use Jugglor and JWeb together.

http://www.jugglor.com 

http://jweb.flashjester.com

Jugglor has an option called

"Don't go to foreground on click"

Please take a look at this example provided.




308. When I click build I keep getting the message "Flash ActiveX Installer not found. Do you want
to find it yourself?" - should I be concerned? Doesn't it install automatically?

You can find the Active X installer here

C:\Program Files\Macromedia\Flash MX 2004\Players\Release\Install Flash Player 7.exe

or download the latest from the Adobe website.

http://www.adobe.com/shockwave/download/alternates/

Please read the Adobe Player Licensing

http://www.adobe.com/licensing/distribution/

Or you can select the

Use IE to download and install the control from internet

Which is a much better solution.

309. How do I change the title caption of the Juggled file at runtime?
Jugglor v2 supports this feature.
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SetCaption
Allows you to change the caption of the Window Caption of the Juggled file.

Syntax - Active X :
fscommand("setcaption","title"); 

Syntax - Projector MX: 
We recommend you use the EncodeForJugglor function if you are using dynamic text or just use the
FSCOMMAND Generator if it's fixed. i.e 

fscommand("exec",encodeforjugglor("j:setcaption:title"));

Syntax - Projector Flash 5: 
fscommand("exec","jcommand:setcaption:title");

Title* : The window title caption


310. Is there an event which notifies me when the ticker application is docking? 



Yes, see the

Jugglor Help -> Advanced Techniques -> Using FSCommands -> Dock Events

SetDockNotificationKey 
  This command provides the ability to know where the Flash file is Docked to when using the Ticker
Settings .

Syntax - ActiveX : 
fscommand("SetDockNotification","Key,VariableName");

Key The variable will receive a number (as string) - the docked state when it changes Left="0";
Top="1"; Right="2"; Bottom="3"; Unknown (Quitting)="4"; Float="5";

fscommand('SetDockNotificationKey','N'); or 

fscommand('SetDockNotificationKey','55') // 55 is the key ASCII code.

Which key will be used to signal a change in the docking state.

Please download the example file to see it in action.


311. Can I pass parameters to my Juggled file? I want to have 2 different versions without having 2
different Juggled files ?

Yes this is possible.

See
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Jugglor Help -> Advanced Techniques -> Command Line Parameters to Juggled File

Command Line Parameters  

juggledfile.exe /joe /bloggs 

These parameters are then passed straight to variables at _root level when the Flash file starts. So, for the
above example it would be:

param1 = "joe"
param2 = "bloggs"

This will allow you to set different modes in the Juggled file rather than having different versions of the
Juggled file. 

Syntax 

JuggledFile.exe /param1 /param2 /param3 etc... 

Many parameters can be sent to the Juggled file. You can use the variable ParamCount to count the
number of parameters sent. 

 Please download the example file to see it working

312. How do I use the Balloon Message Hint fscommand in Jugglor with my SWF file?
Syntax - Active X :
fscommand("balloon","message,title,icon,sound"); 

You must also set 

Setup Settings -> Icon Tray -> Always sit in Icon Tray

See example file.

For further information see

Jugglor Help -> Advanced Techniques -> Using FSCOMMAND -> Balloon Message

Remember you only need to use the EncodeForJugglor function if you are using a Projector file rather
than a SWF file as your Flash file in Jugglor.

313. What is the minimum playback spec for a Flash MX Projector PC file?
The minimum requirements for the Flash Player are listed at 

http://www.adobe.com/products/flashplayer/productinfo/systemreqs/
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314. I wonder if I can monitor the Juggled application being closed?

I'd like to present a "Some changes are not saved. Save them?" dialog if a user tries to close the
application.

Is it possible? If so, how?

Yes now it is. We've added this in Jugglor v.3.0.

Syntax - Projector : 

Flash MX , MS2004, 8, CS3
fscommand("exec","jcommand_3aSetQuitNotificationKey_3aXXX't"");

or

fscommand("exec","j_3aSetQuitNotificationKey_3aXXX't"");

fscommand("exec","j:SetQuitNotificationKey:XXX'"); 

Syntax - Active X & Projector: 

Flash MX2004, 8, CS3

Engine.SendJCommand("SetQuitNotificationKey:XXX");

where XXX is the ASCII number of the key (two or three decimal digits) - 3 is coded as 03. 

After this, all quit commands will not be executed, but the above key will be sent to Flash. Then, if the
Flash script decides to quit, it can be done by 

fscommand('exec','j_3aquit'); 

See the CS3 example file provided below.

315. I cannot get the Quit command to work with Jugglor 3.0 and CS3 Projector files. 
Please help.

Ok you can use

fscommand("exec", "jcommand_3Aquit");

or

fscommand("exec", "j_3Aquit");

Take a look at the attachment example.

316. My XML file doesn't load when I Juggled my file using Jugglor?
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You need to add the local% command infront of the xml filename.

So if we have

xml.load("saved.xml")

we need to add local_25 

Xml.load("local_25saved.xml")

where local_25 mean local%

For more information on this please read

Jugglor Help -> Advanced Technqiues -> Using LOCAL%

and download the example file given.

That's it.



317. I'm having a few *simple* problems loading an XML file into a Flash projector that has been
juggled.

I'm using the standard Flash methods for loading XML so that the contents are read in as an XML
object.

I'm using an absolute path to the XML file similar to:

C:\Inetpub\wwwroot\xml_files\topic_02.xml

When I compile and run the EXE I'm not getting anything being read in as the XML object although
the movie thinks that the content has loaded?!?

Any pointers?



Jugglor cannot read this path, the path needs to change slightly.

Now because you are using the absolute path

C:\Inetpub\wwwroot\xml_files\topic_02.xml

you don't need to use the LOCAL% command as this gives you the path of the Juggled file

so this will be

c_3A_5CInetpub_5Cwwwroot_5Cxml_5Ffiles_5Ctopic_5F02.xml
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If you don't know the full path i.e the drive then you will have to use the local_25 command
so if the Juggled file was in structure in the following way then

juggled.exe
<data>
    test.xml

then you will have

local_25data_5Ctest.xml

where

<space> is _20

: is _3A
\ is _5C
_ is _5F

more information about the local% can be found here

Jugglor Help -> Advanced Technqiues -> Using LOCAL% 

or use the EncodeforJugglor function 

http://www.flashjester.com/index.php?section=faq_search&search=encodefor#361



318. How can i dynamically load variables into JEmail i.e Email, Subject and Body and when I press
create it automatically creates an email using the users email client

Yes this is possible, you can even load text inside the body now with Email. 

See the example file and build the project. 

Remember to download the latest version of JTools -> JEmail v 1.4, first.

319. How do I add a minimize button to my flash projector file?
You can use Jugglor to do this.

http://www.jugglor.com

Download a FREE evaluation copy and read the help file

Jugglor  -> Advanced Techniques -> Using FSCommands -> Minimize 

Minimize 
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  The Minimize command minimizes the projector player.

Syntax - Active X: 
fscommand("Minimize");

Syntax - Projector MX: 
fscommand("exec","jcommand_3Aminimize");

Syntax - Projector Flash 5: 
fscommand("exec","jcommand:minimize");
 
See the example file provided below.

320. We're running Jugglor to package our player and movie swf. If I create the projector with
Jugglor it takes 100% of the processor but seems to play OK. If I create the projector .exe with
Flash8 or FlashMX or some other builders - it runs with a minimal processor (10-30%). Is there a
build option that might be affecting this or a way to diagnose why this is happening?

Yes that's right because the SWF file uses the ActiveX Player to play the Flash file and the Projector file
using the built in Flash player which is faster and better.

We only recommend you use SWF files in Jugglor if you are using the transparency feature.

To read more on this see below

http://www.flashjester.com/index.php?section=tricks_jugglor3_reason

http://www.flashjester.com/index.php?section=faq_search&search=fps#348

321. How do I add a maximize button to my flash projector file?
You can use Jugglor to do this.

http://www.jugglor.com

Download a FREE evaluation copy and read the help file

Jugglor Help -> Advanced Techniques -> Using FSCommands -> Maximize 

Maximize 

The Maximize command maximizes the projector player.

Syntax - Active X: 
fscommand("fullscreen");

Syntax - Projector MX: 
fscommand("exec","jcommand_3Afullscreen");
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Syntax - Projector Flash 5: 
fscommand("exec","jcommand:fullscreen");
 
 
See the example file provided below.

322. Why is my Juggled file running slower compared to my Flash Projector file? The FPS seems to
have dropped.

Let us explain by looking at the following

Normal Flash Projector runs 47-48 FPS

Juggled Flash Projector runs 47-48 FPS

Juggled Flash SWF runs 31-32 FPS

If you use a Flash Projector file in Jugglor then as you can see from the above the FPS is the same, as it's
using the Flash Player built into the Flash Projector.  Juggling the Projector file has no effect on the FPS.

Now the Juggled Flash SWF uses an SWF file which then uses the ActiveX Engine i.e the Flash OCX
control to play the Flash File. Hence the small size. It is a known fact if you use the Flash OCX control
then the FPS is reduced.

So the conclusion is 

1. That it's better to use Flash Projector and not an SWF in Jugglor.
2. When you bring a Projector file into Jugglor it doesn't reduce the FPS.

Hope this clears up a few things.


323. How can I see whether a Juggled file is focused or not?
You can use the GetFocus command.

Jugglor Help -> Advanced Techniques -> Using FSCommands -> GetFocus

Also download the example file below

324. I have created a projector file in MX and I created a stand alone with 
Jugglor but buttons with the following commands do not work. 

on (release) { 
fscommand("quit"); 
} 

on (release) { 
nextFrame(); 
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fscommand("fullscreen", "false"); 
} 

on (release) { 
prevFrame(); 
fscommand("fullscreen", "true"); 
} 

The movie hangs up and I have to use Ctrl+Alt+Del to end it.

You need to use our own commands see 

Jugglor Help -> Additional Features -> FullScreen/Maximise and Minimize 

and download the example file.

325. Can I use JShapor on its own?
No, JShapor only runs with Jugglor.

326. I have a juggled file that works on the machine that I created it on,but no other machine. The
error occurs after selecting a button to which a "Jstart command" is attached to open up a .pps file. I
am using Flash MX and Jugglor. Why would this error occur on every machine, and work perfectly
on one? 

The error reads: Create MPEG 32 task- CMD is not successful.
On Microsoft's website it says that the error message occurs because the Mciqtz.drv file is absent from
your system folder. The Mciqtz.drv is a driver for ActiveMovie. Or, if the installation of a third-party
party program, such as Apple QuickTime for Windows, makes modifications to the [mci extensions]
section in the Win.ini file. The [mci extensions] section determines the driver that the movie file format
uses. The native media player in PowerPoint must use the MPEGVideo driver, which makes a call to the
Mciqtz.drv. If this setting has changed, the problem occurs. 

http://support.microsoft.com/default.aspx?scid=kb;en-us;212409

327. I have Jugglor, and I am using the JSave feature to create a text file. The saving works fine in
Flash MX but when I convert the files
to Flash MX 2004 Professional it will not save. What has happened?

If you are using this statement in the EncodeForJugglor function

hex = ord(c).tostring(16);

then change it to

hex = ord(c).toString(16);

as MM have made a few syntax changes to their Actionscript.
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328. Can I use the LoadMovie command to load my SWF files without adding them into the Juggled
file?

Yes, we have just added support for the LOCAL% command. 

If you want to load test.swf that is in the same directory as you Juggled file then you will have
something like this 

LoadMovie("test.swf",1); 

You will need to add local_25 in front of the swf filename 

so 

The command to load test.swf now will be: 

LoadMovie("local_25test.swf",1); 

IMPORTANT !! PLEASE DO NOT USE UNDERSCORES IN YOUR FILENAMES AS THIS WILL
CONFUSE JUGGLOR. SO PLEASE REMOVE THEM.

Please read: 

Jugglor Help -> Additional Features -> Using the LoadMovie command with Jugglor

and

Jugglor Help -> Advanced Techniques -> Using LOCAL%

Remember also not to add the LoadMovie command on the 1st frame, add it on or after the 5th frame.

329. Does Jugglor work with Flash MX 2004 Professional? I have used it in the past with Flash MX
with no problem.

Yes sure it will work!! Try it for yourself.

330. I'm using Professional with JSystem and I'm trying to read a folder's contents which contains
unicode filenames e.g.Ñ‚ÐµÐ»ÐµÑ„Ð¾Ð½ - 2006-09-09 16-22-12.xml and Ð¡Ð¾Ñ‚Ð¾Ð²Ñ‹Ð¹ -
2006-09-11 10-23-32.xml but the result that comes back is ??????? - 2006-09-11 10-23-32.xml.
Can you please help?

Jugglor and JSystem do not support unicode names. It will work for russian strings if the windows
default system codepage is russian.


331. I want my Flash movie to be displayed on my second monitor. Does Jugglor support
Multi-Monitor in Flash?

Yes this is a new feature introduced in Jugglor. See below for more information

Jugglor -> Setup Settings -> Windows Display -> Multimonitor Support
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332. I'm working on a Flash Projector CDROM with around 10 FLVs in Flash 8 Professional. These
FLVs are loaded dynamically into the SWF projector using actionscript and the FLVPlayback
component. 

There are 10 buttons to load each movie into the same FLVPlayback instance. However, when I
click the button to view/load the FLV, sometimes the video does not display, but the audio can be
heard playing. Furthermore this is happenning erratically and randomly. It seems to get worse as the
CD has been playing for a longer period.

I've been told that this memory issue was solved with the release of Jugglor v2.2. I've downloaded a
trial version of Jugglor today, but all the FLV files are not loaded into the SWF. All your examples
and tutorials say we should use LoadMovie command, but in order to load FLV dynamically in Flash
8, I have to use this script: 

flvPlayback.contentPath = "videos/01-intro.flv";

So should I and can I install your Jugglor upgrade to accommodate this script from Flash 8, or is it
simply a matter of using the CDROM% command and _5C to replace the path above?



Yes that's right you have to change the path so you have

<b>flvPlayback.contentPath = "videos/01-intro.flv";</b>

1. You need to add LOCAL_25 in front of the path to tell Jugglor to look in the local path. i.e the same
path as where the Juggled file has been launched from.

More on this can be found in

Jugglor Help -> Advanced Techniques -> Using LOCAL% 

2. All forward slashes must be changed to backslashes so 

\  and change the \ to _5C

3. You have to, in the filename , change this syntax to _2D

so putting all the above together we will have the following :

<b>flvPlayback.contentPath = "local_25videos_5C01_2Dintro.flv";</b>

Try this.

333. I have the following

 LoadVars.load("mytextfile.txt") 

This was all done with MX2004 and Jugglor 2.1 and it all worked fine and dandy. I've upgraded to
Flash8 and the latest version of Jugglor and the text saving still works, but the loadVars bit doesn't -

Page 102



Flashjester  FAQ.

I've tried making a new LoadVars example to see if that works and it doesn't - help!

It stems from the fact that the Juggled file is not run from the location you execute it from, but the
windows temp folder instead, thus any linkages you may have had to do a normal 

LoadVars.load("mytextfile.txt") 

and no longer point to the right location.

You have to use the slightly awkward local_25 to prefix your linkage to the "mytextfile.txt" in this case
and replace any "\" with _5C meaning you can not have any "_" in your file link.

So just change where you have 

LoadVars.load("mytextfile.txt") 

to

LoadVars.load("local_25mytextfile.txt") 

and you should be fine.


334. How can I create a screensaver from my flash files ?
You can create a screensaver from a Flash SWF or Flash Projector by using FlashJester Creator

http://creator.flashjester.com

Download a free evaluation copy from here

http://creator.flashjester.com



335. Can I create install programs in French with Creator?
Apparently, you can create French versions of screensavers with Creator.  Under the â€œdialogsâ€•
setup, you can import a language from wherever Creator was installed.  You guys can support German,
English, French, Intalian, Polish, Portugese, Spanish and Dutch, and moreover, can run all of these
simultaneously if you want â€“ letting the user choose at run time.


336. Why are your prices higher than other products in the market?
While our prices may be higher than some competitive products, our quality is also higher. . Compare
our product to the rest of them and you'll see what we mean. Many only have the basic features and we
have many more. We've spent so much time in developing, designing, testing and improving Creator.
Quality is the key. We could have released something a long time back , say 2 months after Flash 3 was
released, but then it would have been like the rest of the stuff which is out there. We've hired quality
programmers and designers for this specific project and good programmers and designers aren't cheap.
People who want the best product possible will be our main clients. Now if you can't afford it, you can
go for the Creator Express service, where you send us the necessary files and we create the screen saver
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for you. It is only $99! and you'll get your money back if you decide to upgrade to Pro or Standard at a
later date. 

Pro - With Pro you get unlimited licences so you can freely distribute any screen saver you make as
many times as you want. This is more suitable for the large business and is aimed higher pricewise at
$595. 

Standard - More suitable for the smaller business or individual, this package offers the same features as
pro, and you can create as many screen savers as you wish. However, you only have licences to
distribute 10,000 copies of each screen saver. Because this is aimed at smaller businesses and
individuals, we have set the price at $395 

Also one thing we should point out is that around 40% of profits will be plugged back into the company
for further developments on Creator and other products such as Jugglor and we have many more ideas !! 

Charging your clients $500 minimum for a screen saver, will soon pay off Creator, with 2 screen savers.
I am sure many people out there will have fun making screensavers and a living from Creator. 

So does this seem too high now ? All comments are welcomed about the price. Please email us with your
opinions.

337. What is a Projector file and where can I get one from?
You will need a copy of Flash from Adobe, www.flash.com. Once you have created your SWF file,
double click on it, then go to the top menu, File -> Create Projector. That's it.

338. I am considering purchasing your product instead of upgrading to the latest version of
Screentime which will only cost me $99, US. 

Please tell me why your product is better than Screentime for Flash.
Thank you for showing an interest in Creator. Why are we better than Screentime? Well here is a list of
features Creator supports. 

http://www.flashjester.com/index.php?section=tricks_creator_features 

also 

We don't advertise on your screensaver that YOU create. No branding from us. 

You have much more control over the setup box. 
Supports all Windows OS 
Screentime doesn't have an Installation file. No readme files are installed hence no license agreements
can be read and used. 

Plus many many more. 

Join our many happy customers. 
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http://www.flashjester.com/index.php?section=clients 

Just found some news about Screentime take a look 

http://board.flashkit.com/board/showthread.php?threadid=349733

339. I tested my screensaver on my new machine with a resolution of 1280 x 
1024. The screen saver was created on a machine with 1024 x 768 pixels. When i click on the
"settings" menu in the screen saver dialog (display properties), I get the settings panel, but the font I
used is larger than it should be. My http, mail address and the copyright note are larger than the
panel is. How can I solve this problem?

It's the font you have choosen. Make sure you select one of the default fonts as the end user must have
this font.

340. I like the list of images that can be imported, but the only one you have missed out is * .gif?
Ok, because of the licencing laws, if you use GIF images in any app you have to pay UNISYS for using
GIF images because they have been copyrighted the LZW compression it uses. What a bummer !! We
are not prepared to pay this price, as we believe it should be open standard, and will not play or pay no
part in this injustice, Who is doing whom a favour ??

341. I'm interested in making screensavers using your software. At the moment I'm not sure if I need
a license to distribute more than 10,000. Is it possible to buy Creator Standard and then upgrade to
Pro if the need arises by paying the difference?

Sure you can buy Creator Standard now and then upgrade to Creator Pro at a later date. That is not a
problem.

342. I've created my screen saver using Creator, now I want to use a third party installation tool i.e
Wise or Installshield. Is this possible?

Yes, absolutely. There are 3 steps which you need to follow. 

1. If you look in your build path you will find a sub directory called \screensaver, in there are 2 files.
One is the actual screensaver file *.scr and the second is the registry file *.reg. You will have to make
these entries built into the installation. 

2. You will need a copy jesterss.dll which can be found in 

/Program Files/FlashJester/Creator/Engine 

Copy this file into the System32 (WinNT/Win2000) or System directory (Win95/98/ME). 

3. There is also one other registry entry you have to make 

HKEY_CURRENT_USER\Control Panel\Desktop\SCRNSAVE.EXE 

set this to the path where the screensaver will be installed on the user machine. This is usually the
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SYSTEM 32 directory. 

IMPORTANT : If the name of the screensaver is more than 8 characters, which is usually the case, you
need to take the first 6 characters of the name of the screensaver, remove all spaces and then add ~1 to
the end. 

So for example 

Name of Screensaver - The FlashJester Screensaver.scr 

would be 

THEFLA~1.SCR 

This will set the current screensaver to your new one.

343. Does the end user need the Shockwave Flash plugin installed on their machine?
No, the user requires no plugins whatsoever. All they need is your finished file made with Creator and
then as long as their machine is switched on, it can be seen with no problem.

344. Testing the screensaver in display properties on Win NT worked fine, but when screensaver
launches after a predefined timeout, an error dialog box containing "Exception EFCreateError in
module JBall.scr at 0000D68A. Cannot create file D:\NT40\__3ESolutions_temp\jball.exe" appears.
How can I fix this?

Change access privileges for SYSTEM to full access.

345. When I add a link to a web page on a Flash 5 projector, on building my screen saver, it doesn't
load up after clicking on it when the screen saver is working. Why?

The reason this happens is two-fold. First, you would have been using the 'Get URL' function within
Flash and second, you were probably running under Windows NT. There is a problem within Flash that
causes this error when running under Windows NT but there is a way to get around this. By using JStart,
one of the JTools , you can be sure that every user that has a copy of your screen saver being able to
view and fully interact with the screen saver, as designed, under whichever platform they are using. So if
you are putting the screen saver on the internet for example, you will not know which platform
everybody is using, so to be sure to avoid this problem that will frustrate NT users to death, simply use
JStart to do the job of linking to web pages. 

You can download an example on how to use this function.

346. Could you use an .rmf file as well as a midi file? Could you possibly use the beatnik plugin?
We don't have the developers kit in order to do this. When it's more available then maybe, but again we
see no advantage here... this only increases the engine size, it's much easier to grab a midi file off the net
than a RMF file.
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347. I am using a Flash MX projector file, will it work with Creator?
Yes, it will make sure you have the latest version of Creator, 1.3 or above.

348. I'm putting together a screensaver just now that includes a 1 minute video animation. I'm
wondering if it's possible to include the flv as a component that streams from a file that's installed
locally alongside the screensaver, rather like external swfs that can be included in the installer and
referenced using LoadMovie.

Yes it's possible with Creator. You need to add the FLV in the additional files section in Creator.

Please download the example file below to see it working.

You will need to Build the project from the *.jcf given in Creator.

349. How do I create a Flash projector file?
You need a copy of Flash to create an .SWF file (Shockwave Flash). You must have a copy of Flash to
turn the .SWF file into a projector file. To do this, run the .SWF in the Flash viewer and choose Create
projector from the file menu.

350. Do all the projector files have to be in full screen mode?
No. The great thing about the FlashJester Entertainor is that it will automatically change the full screen
setting to true, turning all Flash projector files to fullscreen.

351. Does it support the playing of MP3s?
No, but future versions will.

352. Where can I get the Flash files from?
The Flash files are created using Adobe Flash. See http://www.flash.com

353. Are the JTools difficult to use?
No. We have kept the parts you need to edit very minimal and simple.

354. What happens if the user doesn't have, say, a default internet browser?
This is another feature of the JTools. In the INI file, there is another line you can fill in which is the
message that appears if the browser, e-mail editor or program cannot be found.

355. I've put the command in my Flash file and exported the SWF and patched it. But nothing
happens when I click on the button. What's happening?

You need to put a copy of nameofjtool.exe in the same directory as your SWF or projector file. This can
be found in the directory you installed JTools to (e.g. c:\program files\FlashJester\JTools\Source)
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356. I created my links with an unregistered copy of JTools but when I registered and installed the
full version why does it still say the evaluation message on my links?

This is because you need to copy JStart.exe from your source directory i.e program
files\flashjester\jtools\source again to the directory of your project. The version you have in your project
folder is still an evaluation version.

357. How do I use the patch command (Flash 5 only)?
You ONLY NEED TO DO PATCHING FOR Flash 5 file and NOT 4, MX or MX 2004.

First you need to create all your JTool commands in JHelpor pasting them into the FSCommand box for
each JTool link. Then you need to export the movie in SWF format. Now go to JHelpor and select patch
movie. An open dialog will appear allowing you to search for the movie you wish to patch. Find the
movie you just exported and press ok. Your movie will now be patched. After it is, all the JTool links
will work correctly but you will need to patch the SWF everytime you export it.

358. I had no problem placing my film in a projector but I have a problem closing it. The film starts
automatically when the entry is called. I'd like it to close when I call another entry. Instead the film
stays on top of everything else untill it finishes. I created another Javi.exe + INI with the command
'close' but the film is still on top and it creates a pop-up window of the same film. I can't find anything
in the arguments for close movie. Could you tell me the proper command?

You need to use the following command 

[AVI] 
Address= 
Parameters=closeall 

This will do the trick. See the example below.

359. Does JAvi work with Flash 5?
Yes, JAvi works with all versions of Flash, including 3,4 and 5.

360. Why do I need JAvi when JStart can launch an Avi file?
JAvi adds loads more. It is its own player, allowing for a total customisation of play and look.

361. I have an AVI file on my CD-ROM. How can I access this file without adding the AVI into the
Juggled file?

You'll not be able to have access to the current directory where the Juggled file resides in, because the
projector file uncompresses to the Windows Temp directory, so using FSCOMMAND - EXEC -
sample.avi means \WINDOWS\TEMP\sample.avi. To solve this problem you will have to use the
LOCAL% command.

362. When I start an .avi file there is no audio...the video plays fine but no audio? Why?
You will need to stop the sound in your projector file before you load the Avi file. Flash uses the Wave
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Device to play its sound and so does the Avi player. So add the Stop All Sound command in the Flash
file.

363. My Avi launches fine in JAvi but when the user moves to another section in my Flash file the
Avi keeps playing. Is there any way I can close all open Avis on a keyframe or button?

Yes, we have a specific command for this you'll be happy to hear. Simply create a new JAvi link in
JHelpor. Do NOT select any Avi file but go into the argument settings of the command and go into the
"Others" section and select the option "Close all other JAvi windows". Click on the Ok button in the
settings box and then Ok again in the Add JTool link. Then copy this command onto the button or
keyframe of your choice and on activation this will close any open JAvi windows.

364. I'm using JEmail + JHelpor to launch an email app from a projector on CD.  
I've created the .EXE and INI files and stored them correctly in the fscommand folder.  Everything
works fine if the default email application is not running.  However, if it is running, or an email
window is open behind the projector, and I click an email link in the projector, the new email window
opens behind the projector. I need these in the front, as the movie is full screen, and it looks as if the
buttons just don't work....


The only way around this is to use Jugglor and JEmail together.

You will have more control over the Projector file and how it appears.

Read this

http://www.flashjester.com/?section=faq&cPath=14_56_21#85 

Download the example file and you will see it working.

Jugglor
http://www.jugglor.com


365. I am using JHelpor to install the proper fscommand to launch my default email client, but I can't
get it to do anything. 

1. I have a copy of JEmail in the same directory as the projector file. 

2. I am using Flash MX, so your site says it is not necessary to patch the file. 

I have even created a special test movie with nothing in it except one button that has the
fscommand/JEmail actionscript assigned to it as an "on release" action -- still nothing. I get no error
messages - nothing. 

Here is the actionscript from my test file: 
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on (release) { 
fscommand("exec", "JEMAIL scott@scottlent.com \"Does`1this`1thing`1work?\""); 
}

No, this is the old method for Flash 4/5 files. You have to use the new method involving ini files. Please
read the JStart JWeb JEmail.hlp file 

Start -> Programs -> FlashJester -> JTools 

Please download this example file for further information.

366. Can JEmail and Jugglor work together?
Yes they can. 

<a href="http://www.flashjester.com/?section=faq&cPath=14_21" target="_blank">Click here for
further information</a>

367. Why do I need to use JEmail when I can use the 

getURL(mailto:support@flashjester.com)?
GetUrl doesn't work all the time. Please read below 

>> 
Mailto attempts to launch the user's default mail program, but unfortunately there's no way to ensure the
user's system is set up properly, so there's no guarantee it'll work in all situations. 

There is a known issue in Windows where, if the user's system is set up with a browser other than IE, the
browser can't launch from a projector. The developers have confirmed that Macromedia owns this issue. 

Sincerely, 
Adam Burtch 
Macromedia Tech Support/Flash 

>> 

Still not convinced then look at 

http://groups.google.com/groups?q=geturl+mailto+projector&ie=UTF-8&oe=UTF-8&hl=en 

JEmail works on all operating systems

368. I have a Flash X main projector file which loads an additional SWF file. I would like this SWF to
have the JEmail link. How can I do this ?

It works the same way as running JEmail from a projector exe.

p.s You need to use ini files and create a sub directory called FSCOMMAND.
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See the example file.


369. How do I create multiple, individual email links using JEmail/JHelpor 
in the same Projector?

I am using Flash MX 2004
For multiple recipients in the same email just add them to the Address section in the ini file, separated by
;

Address=support@flashjester.com;sales@flashjester.com;info@flashjester.com

But if you want to create a new email for each user then you will have to create another copy of
jemail2.exe jemail2.exe etc. and in the FLA file refer to jemail2.exe

370. When copy pasting into the Body field it did not keep paragraph breaks. How do I have the
body stay in multi-paragraph form?


You can try coding the new-line chars as %0D%0A, sometimes the email clients will not understand
this, it depends on them. So it will not work 100% of the time.


371. Is there another way than copying jemail.exe into jemail2.exe etc for multiple email adresses?
I've got about 100 different email links, and don't want a hundred versions of JEmail on my cd with
the projector..

Yes you can by using Jugglor and JEmail together, where Jugglor will automatically add ONLY one
copy JEMail.exe inside the Juggled file.

Read this 

http://www.flashjester.com/?section=faq&cPath=14_21

Jugglor
http://www.jugglor.com

372. Does anyone know how to send an email containing flash? So that when a user opens their
email they see the flash movie in their email.

It used to be possible but now most of the mail clients block it, and due to all the security issues from
spyware because of worms, most of the users did upgrade their system so the chances to get the user to
see it are minimal.

Read this

http://www.webreference.com/multimedia/flash/email/index.html


373. What does the patch command do in JHelpor?
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When you create JTool links in Flash 3, it uses tabs so the JTool knows what the parameters it should
use to run are. You cannot use tabs in Flash 4 as they will be automatically removed. The patch
command will fix this however, making sure that your JTool links do work.

374. Is there a simpler way to set the JTools up, other than JHelpor?
Yes there is. Jugglor, another program in the FlashJester range allows the almost automatic set up of the
JTools. It can also make your projector files into fully-fledged programs with features including no right
click menus, option to change the icon, compression and many more. Visit http://www.jugglor.com for
more info.

375. Is there a way to send a command equivalent to the "Esc" key to the movie from one of the
Flash buttons in the presentation?

i.e.  

When the user clicks on one of the flash buttons the movie gets a "quit" command from the button?
Yes you can use the closeall command.

JMOVIE.exe closeall

Try that.


376. How do I set my movie file to FullScreen?
You need to add the Parameter 

fullscreen 

in the argument.

Open JHelpor

1. Press +.
2. Select JMovie from - Avaible JTools
3. Use Parmeters.
4. Enter the filename of movie.
5. Press .. in Arguments.
6. Position & Size -> Full Screen.
7. Press OK.
8. Press OK.
9. Press COPY.

So now you have something like this

[MOVIE]
Address=mymovie.avi
Parameters=playfrom=0 fullscreen
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Now also read the JMovie Help file

Start -> All Programs -> FlashJester -> JTools -> JMovie -> JMovie Help

to help you.

Also look at the following example

C:\Program Files\FlashJester\JTools\JMovie\JMovie Flash MX Example1

and change this example file to run in fullscreen.

377. How do I create dynamic movie file names using JMovie & Jugglor ?
You have to use the EncodeForFunction.

See the example file below which will explain it all.

378. Everything works correctly, but when I play a movie, the sound is all messed up?
You need to set the sound to ï¿½directsound deviceï¿½ and not waveout

379. I can't find the commands to start, stop or pause movies from a Flash file (the movie itself runs
fine with JMovie).

For these commands to work you will have to use JMovie and Jugglor together. The Play, Pause, Stop
and Close commands have been added in recently. 

Please download the example file to see it in action.

380. Why do I need JMovie when JStart can launch Quicktime, AVI or Mpeg files?
JMovie has much more features. It is it's own player allowing total customisation of play and look. It
takes advantage of the Windows Media Player.

381. I have a movie file on my CD-ROM, how can I access this file without adding the file into the
Juggled file ?

You'll not be able to have access to the current directory where the Juggled file resides in, because the
projector file uncompress to the Windows Temp directory, so using FSCOMMAND - EXEC -
sample.avi mean \WINDOWS\TEMP\sample.avi. To solve this problem you will have to use the
LOCAL% command. 

Please take a look at the example file.

382. Some of my users cannot view the movie file. It appears incorrectly on the screen, or blank.
The user will need to have the latest version of Windows Media Player 7.1 installed on their system.
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You can download the latest version of the Windows Media Player (for the ActiveX control). Also you
need to make sure that they have the video codecs used in compression of your video installed. If you
are distributing your files on CD-Rom, then it might be advisable to put a copy of the Windows Media
Player installation on your CD.

383. Every time I try and change the video dimensions or click the "Relative to Flash" box in
JHelpor, I am unable to view the video when I create a Flash projector. I'm using FlashMX. I'm
wondering if all this is just because this is the demo version?

The 'Relative to Flash' feature only works with Juggled files. Download the following example

384. I need the video to play within the interface, at the specified size and position. This I can do and
the JMovie.exe comes up fine in front of the fullscreen flash exe, however when I click on to the
flash interface, the JMovie window plays behind the flash exe?

Ok, first of all you will need to use Jugglor and JMovie to have better control over the movie.

Download an evaluation copy from here

http://www.jugglor.com

Make sure you recreate all your commands within the JTools section in Jugglor.

Jugglor -> JTools

Once you have created the commands then press the Copy button and paste into the FLA file.

Use the LOCAL% command if you are using files the are outside the Juggled file.

Now in Jugglor set the following :

Jugglor -> Setup Settings -> Don't go to foreground on click -> Checked

Thats it really.

Please download and look at the example file provided. This example also uses the additional SWF file
which is included in the Juggled file which launches the Movie file. (you don't need to use additional
SWF files)

p.s Read the JMovie Help file if you get stuck.



385. JNetCheck doesn't seem to work on my network. Is there anything else I can try?
Yes, sometimes if you are working in a Proxy environment it will not work. So we suggest you use the
/url command, where you specify a URL to see if you get an outside link. 

JNETCHECK /url=www.flashjester.com 

Page 114



Flashjester  FAQ.

would be 

JNETCHECK_20_2Furl_3Dwww.flashjester.com 

where 

20 is 
2F is / 
3D is = 

in the FLA file for Flash MX users 

Please take a look at the sample below

386. How do I work around the fact that JNetCheck needs to write to a txt file so flash can check the
variable, without installing anything to the hard drive? In other words, can you use JNetCheck when
running your projector from the CD?

Yes, you can by using JNetCheck and Jugglor (http://www.jugglor.com) together. 

You have to include the JNetCheck.exe which can be found in 

:\Program Files\FlashJester\JTools\Source 

in the 'Additional Files' section in Jugglor. 

When you build and then run the Juggled file, it will uncompress all it's content inside the Juggled file to
the Windows/Temp directory. Hence JNetCheck.exe will be able to write the status to the harddrive 

Other things to remember. 

1. You have to use 

fscommand("Exec", "JNetCheck.exe"); 

2. It's 

loadVariablesNum("JNetCheck.txt", 0) 

you don't need to add the FSCOMMAND as a sub directory. 

3. IMPORTANT. You must add the 

fscommand("Exec", "JNetCheck.exe"); 

in or after the 10th Frame, so it give enough time for Jugglor to initialise. 

Please take a look below at the example provided.
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387. How do I print my Flash file from my web page?

I have created a button in my flash file for printing. I've attached a 
print function, but it prints over 20 pages.

I want this button on the screen at all times and want to click on the button and print whatever
screen it is now sitting on.


JPrintor is not the tool for this. JPrintor is only for offline CD-ROM type work.

The answer to your problem comes from the PrintJob Class in Flash Actionscript.

See below for some simple code.  Basically what it is doing is:

1. Creating a new PrintJob instance
2. Checking if the user clicked "OK" on the print dialog
3. Adding content to the print spool
4. Sending it to the printer
5. Deleting the PrintJob instance

The method to note is the :

 printJob_pj.addPage( "_root.MovieclipName", { xMin:0, yMin:0, xMax:570, 
yMax:755 }, { printAsBitmap:true }, 1 );

This line tells the printJob:
 what movieclip from the stage to print from      "_root.MovieclipName"
 what bounding rectangle to use for printing      { xMin:0, yMin:0, xMax:570, 
yMax:755 }
 Send the data to the printer as an image           { printAsBitmap:true }
 Which frame of the movieClip to print                 1

See full code below.

 // create an instance of the PrintJob Class
 var printJob_pj = new PrintJob();
  
 // if user presses ok at the system default print dialog
 if (printJob_pj.start())
 {
      // add frame 1 of theMovieclip to the print queue
      printJob_pj.addPage( "_root.MovieclipName", { xMin:0, yMin:0, xMax:570, 
yMax:755 }, { printAsBitmap:true }, 1 );
  
      // send spooled info to printer
      printJob_pj.send(); 
 }
  
 // clean up
 delete printJob_pj
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By customizing this, you should be able to specify what to print in your movie.  You may want to pass
_root._currentframe as the frame number to the above method to print the frame that the user is currently
on.

Read this also

http://sephiroth.it/tutorials/flashPHP/print_screen/



388. I want to make a print button so it will print the whole page I am currently on. The page isn't all
flash, it's a html page with a flash button

So how can I print this page?

You will need to make a call to the javascript in the  external page for this.  If you put something similar
to the following code on your button, it should print the webpage:

 getURL("javascript:window.print();");

This will make a call to the page that your flash file is stored in and call the print function.  This will
most likely NOT print your flash content though.

 I hope that this helps you out.

389. I have just upgraded my Flash CS3 to use the latest Flash 9 Player. I've noticed now when I
use the getURL command to open a PDF file while in fullscreen

i.e
getURL('file.pdf',"_blank");

from my Flash 9 Projector fiile, the window minimises and out of fullscreen.

How can I prevent this ?



You can use FlashJester Jugglor and JStart together. JStart comes FREE with Jugglor Pro.

http://www.jugglor.com

http://jstart.flashjester.com

You basically replace the getURL command with the JStart command and let 

In Jugglor you set the Window to be in fullscreen

Setup Settings -> Windows Settings -> Size options -> Fullscreen
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and

Setup Settings -> Don't go to foreground on click (scroll down the bottom right box)

There is a tutorial here 

JStart Help -> Using Jugglor With JStart

Please download the example file below to help you


390. How do i get the <b>FileExist</B> function to work with Flash 8 and below ?
Active X
fscommand('exec','j:sy:fileexists:"FileName",ResultVar');

Projector Engine
fscommand('exec',_root.EncodeForJugglor('j:sy:fileexists:"FileName",ResultVar'));

Examples

Filename="c:\\myfolder\\projector.exe"

Please look at the example provided below.

391. How do i get the <b>FileExist</B> function to work with Flash CS3 with Actionscript 3 ?
Due to CS3 and Actionscript 3 we've had to change a few things the way with code.

First have a brief look at

Jugglor v3.0 Help -> Advanced Techniques -> FSCommands, Classes and Events

(until we update the JSystem Help files)

The same principles apply with JSystem.

Look at the  FileExist example below.

From here you should be able to figure out how it works.

Hope this helps


392. If writing to the local HD, can user "browse" to the preferred directory location before saving, as
is familiar and common in Windows OS and traditional desktop applications?  Or must they actually
type the full path to save it to a location of their preference

Yes you can by using JSystem.

JSystem Help -> FSCommand List -> File Manipulation -> SelectFile
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Download the evaluation and look at

C:\Program Files\FlashJester\JTools\JSystem\Example Files\Open_Save Dialog Example

or if you are using Flash CS3 with ActionScript 3 then download the example file below

393. I am having problems with the <b>SaveToFile</b> command with Flash 8 and below can you
please help ? 
 
 


Yes sure. Please look at the example file provided. It has a Projector and SWF example file.sss

394. I am having problems with the <b>SaveToFile</b> command with Flash CS3 and Actionscript
3 and below can you please help ? 


Yes, the scripting is much different than before. You no longer need to use the EncodeForJugglor
function and others.

The best thing is to download the example below.

This example is for Jugglor 3.0 and above users.

395. I cannot open any of the help files .CHM in Vista ?
Yes there is an issue with this. Please read the following

http://blog.crowe.co.nz/archive/2007/04/13/719.aspx

http://blogs.technet.com/seanearp/archive/2007/05/28/can-t-read-chm-compiled-help-on-vista-xp-2003.a
spx



396. I am having problems with the <b>LoadFromFile</b> command using Flash 8 and CS3 using
ActionScript 2.0 , can you please help ?

Yes sure. Please look at the example file provided. It has a Projector and SWF example file.

397. Can I have my text file be ammended / appended too rather than replaced each time the
program is run? I'd like to run my program - have the X.txt file be created, store the data - then if
another user opens the program, add a second line of text to the already created X.txt file rather
than over writing the first line of text. 

Yes you can use the AppendTo function built in JSystem

Read the JSystem Help File 

Home -> FSCommand List -> File Manipulation -> AppendTo


Page 119



Flashjester  FAQ.

398. I am having problems with the <b>AppendTo</b> command with Flash CS3. Can you help ?
Yes, the scripting is much different than before. You no longer need to use the EncodeForJugglor
function and others.

You can no longer use Actionscript 2.0 with CS3, now has to be Actionscript 3.0. This is because of the
changes made by Adobe, we've had to rewritten our engines to adjust for this.

The best thing is to download the example below.

This example is for Jugglor 3.0 and above users.

399. I'm saving out text to a text file using Jsave.

In Flash when I do a trace of the text I have typed into the input field, the output panel reads
correctly eg &StudentId = John Doe

However when I Juggle the file with JSave then run the exe I find that only the text up to the space
has been written ie "John". Also all the remaining variables and their values are also not written.

If I do not use a space everything works fine.

Also if I edit the text file and put a space inbetween 2 words it reads back in fine.

Can anyone advise me why a space should make a difference and how I can rectify the process.
You MUST have  double quotes around the ALL of the variables.
If you have double quotes in the variables already, please remove them and use single quotes.

For example

jsave textfile savedvariables 

should 

jsave texfile + '"' + savedvariables + '"'

so

fscommand("exec", EncodeForJugglor('JSAVE.EXE local%Results.txt CoursewareType='
+CoursewareType));

would be

For example

fscommand("exec", EncodeForJugglor('JSAVE.EXE local%Results.txt "CoursewareType='
+CoursewareType +''"));
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400. I am having problems with the <b>AppendTo</b> command with Flash 8. Can you help ?
This example will work with Jugglor 2.3 and 3.0.



401. I need some help and tips on how to display flash on a plasma TV? I have a Flash Projector
that will be on a Plasma TV as a presentation.

Here are a few tips

1. Publish the movie as a projector and then adjust the HD screen's settings until the 
presentation fits perfectly. 

2. It's mostly trial and error but eventually you get there.  

3. Make sure you design for the proper resolution.

4. Add a little extra space for a margin/border.  

5. If you are designing for a Plasma TV that supports HD , then the resolution is 1920 x 1080, but may
vary according to the screen manufacturer, so always check.  

6. Animate at 30 frames  per second, it looks so much better.

7. Now if you don't want or cannot change the Flash file then you can use Jugglor to set these
automatically.

Screen Resolution
Setup Settings -> Windows Settings -> Full Screen Resolution

Fullscreen
Setup Settings -> Windows Settings -> Size Options -> FullScreen

Stretch
Setup Settings -> Windows Settings -> Stretch movie to fit window

Download a FREE evaluation from

http://www.jugglor.com

That should help.




402. I am having problems with the <b>LoadFromFile</b> command using Flash CS3 using
ActionScript 3.0 , can you please help ?

Yes since Actionscript 3.0 had been introduced we'd had to change a few things the way we code.

Please look at the example below and follow this example while we update the JSystem Help file.
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403. After clicking on any button that links to a website I have the following message popping up on
the top of my executable:
 
DDE:Iexplore:WWW_OpenURL:â€•\Program Files\Internet Explorer\IEXPLORE.EXEâ€• -nohome
 
It should display the Title of my executable though.

Do you know how to fix this?

Yes due to recent changes in the CS3 we don't recommend you use getURL with your AS2 or
URLRequest in AS3.

We recommend you use JStart and Jugglor together

http://jstart.flashjester.com

and

So

getURL("http://www.flashjester.com","_blank");

would be

fscommand("exec", "JSTART_20http_3A_2F_2Fwww.flashjester.com");

Please look at the following AS3 example, the same applies to AS2

404. How do I open the explorer window to view a folders contents ?
Look at the example file below. It opens C: drive. Edit the 

cd\fscommand\Start.ini 

if you want to change it.

You must have the fscommand folder and the folder structure. It's a Macromedia Security feature.

405. I have been using Flash 8 and now upgraded to CS3. Now when I publish my old projects to a
CS3 Projector file none of the Actionscipt/Jugglor commands work ?

Yes that is because your using AS2 with CS3 Projector files. This will not work. You will need to
publish the Projector as a Flash 8 Projector file.
Now you can only do this if you are have Flash 8.

But here one way todo this without having Flash 8 installed.

1. Save the FLA has a Flash 8 Document in Flash CS3.
2. Publish the Flash files as a SWF, not a a projector.
3. Open Jugglor -> Select Flash Projector/Movie file -> The saved SWF.
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4. Then select 'Convert SWF to Flash Projector' -> Flash 8.
5. Now Build the project.

Remember AS2 and CS3 Projectors will not work with Jugglor. You can convert to AS3 and then use
CS3 Projector files.


406. How do I use the <b>CopyFile</b> function in JSystem with CS3 ?
Please look at the example file given.

In the Help file is says

Active X
fscommand('exec','j:sy:copyfile:"SourceFileName","Destination",true,ResultVar'); 

Projector Engine
fscommand('exec',_root.EncodeForJugglor('j:sy:copyfile:"SourceFileName","Destination",true,ResultVa
r')); 

but the true shouldn't be there so remove it

Active X
fscommand('exec','j:sy:copyfile:"SourceFileName","Destination",ResultVar'); 

Projector Engine
fscommand('exec',_root.EncodeForJugglor('j:sy:copyfile:"SourceFileName","Destination",ResultVar')); 



407. When I Juggled my Flash file I find that the labels in my Flash Objects such as buttons, labels
seem to go transparent when it shouldn't.

What can I do to fix this ?
In Flash FLA file select the object and set the following

Properties -> Display -> Blending -> Layer

Do this to ALL the Flash Objects.


408. What is Authenticode or Digital Signing ?
How will it help my Flash file ?

Authenticode is a very important program that Jugglor now supports. This guarantees that the code being
downloaded from the Internet has not been altered since its creation. It is then verified by showing the
downloader that the software is coming from the intended party. You are probably aware of the dialog
box that appears once you click to download a program from the net, either telling you who you are
downloading from if they've signed it using Authenticode, such as Microsoft, or if the content is not
signed. In this case, the window says "can't verify publisher." and this is when you can not be sure of the
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content of the program about to be downloaded.

The support of Authenticode is a very important step as Juggled files are made to be easily distributed
via the Internet and they must be protected from tampering, such as viruses being added. From now on,
you are able to sign these items with Authenticode to give people a guarantee that the file's content is
what you say it is.

What software do I need to do this?

The software used to apply the Authenticode is located at Microsoft's site and is downloadable from: 

http://msdn.microsoft.com/downloads

Then on the right hand side click on 

"Security -> Authenticode"

Choose which platform you are using.

Here you will find the software to add the Certificate to the Juggled files.

Where can I buy these Certificates from?

Verisign

The digital signatures required in processing the Authenticode cost's US$400 per year and can be
obtained from Verisign's web-site at 

http://digitalid.verisign.com/developer/ms_pick.htm

Thawte
Service is only US$200 per year, renewal cost 1 Year: US$100 . We recommend using this. You will
have to provide relevant information and documentation about your company, etc. Once you have done
all of this it only takes a couple of days to issue it.

http://www.thawte.com

Below you wil find a Juggled file that has been Digitally Signed.
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